Author Topic: HUD messed up?  (Read 1747 times)

0 Members and 1 Guest are viewing this topic.

In particular, the arrows that show you what weapons and missiles are selected are missing.

The HUD seems to be messed up for Blueplanet in particular.  Tested out in the Freespace 2 overhaul campaign part of BPComplete, haven't tested in bluelanet proper yet (just updated my entire FS2 installation).  I had the too small of a HUD problem in regular Freespace 2, but was able to fix it with a mod that resized the HUD.  Blueplanet also had the too small HUD problem, and I installed the hud resize (called 2HUD or something) but the arrows that show your weapon selections are still missing.

Update:  Tested blue planet AoA too and it also had missing weapon selection indicators.  Also got some kind of LUA script error on first mission.
« Last Edit: May 02, 2017, 05:29:00 pm by infernaldragon5 »


Offline Axem

  • 211
Can you copy and paste the lua error to pastebin and link it back?

There are updated files for the next update to BP that should fix the issue with missing symbols and whatnot. I should be able to cobble together a quick patch... in theory anyway. What build are you using? 3.7.4, 3.8 RC1 or a nightly?

Lemme try that mission again and see if I can get the LUA error again.  I'm using 3.7.4 right now.  Used the FSO installer to update my files recently, which I think were originally from 2012 or 2013 I think.

Also, is there a way to post on these forums without going through 2 catchpas? xD.  This is getting annoying.


Offline Axem

  • 211
I think you just get captchas if you are a real new user. They should go away after a bit.

Alright here's the link.



Looks like it might be a mod incompatibility with the HUD mod I got, I'll try removing it and rebooting mission.

Ok it was the hud mod and removing it did fix the LUA error and the weapon selection indicators missing but it brings me right back to square one where the HUD is way too small and it hurts my eyes to look at it.

Ya, did a bit more testing and this game is pretty much unplayable at HD resolutions without some kind of HUD scaling mod, the one I tried seemingly incompatible with BP


Offline Axem

  • 211
Okay, I'll see what I can do for you!

I think I fixed it.  Created a folder tables under data in bpcomplete.  in data/tables/ I created a file called mv_root-hdg.tbm and put the following text in it:

$Max Directives: 8
$Max Escort Ships: 13
$Scale Gauges: yes

Went to save as.  Clicked file type: all files.  File name mv_root-hdg.tbm .  Also did it with the .cpp extension too to be sure, since it wasn't working with .txt extension name.

Now the HUD doesn't make my eyes bleed lol.

UPDATE:  NVM, doesn't work.  It works for FSBlue but it gives me the LUA scripting error in AoA again.  It seems AoA is incompatible with hud mods period.
« Last Edit: May 02, 2017, 06:46:14 pm by infernaldragon5 »


Offline Axem

  • 211
As an interim fix, try renaming that file you created from mv_root-hdg.tbm to something like fixesbug-hdg.tbm (it ending with -hdg.tbm is the only important part).

The problem is that the lua script is looking for a hud gauge that should be in the BP mv_root-hdg.tbm, and when something else is overriding it (like in the 2HUD mod or in your custom table) doesn't have it, then the script falls apart.

So in summary right now, remove 2HUD.vp from your BP folder (it can stay in your mediavps_2014 folder though), and make the hud gauge table that you tried to make have a name that isn't mv_root-hdg.tbm.

I'll try to have a more proper fix for you tomorrow. Sorry for the trouble.

Worked perfectly!  And NP about the trouble, this game is good enough to be worth it =P

But yeah, it would be nice if BP was either compatible with other UI mods or had the scaling gauges baked into it.

Thanks for the help!


Offline AdmiralRalwood

  • 211
  • The Cthulhu programmer himself!
    • Skype
    • Steam
    • Twitter
As an interim fix, try renaming that file you created from mv_root-hdg.tbm to something like fixesbug-hdg.tbm (it ending with -hdg.tbm is the only important part).
Similarly, if you do that, the only line it needs is
Code: [Select]
$Scale Gauges: yes
Ph'nglui mglw'nafh Codethulhu GitHub wgah'nagl fhtagn.

schrödinbug (noun) - a bug that manifests itself in running software after a programmer notices that the code should never have worked in the first place.

When you gaze long into BMPMAN, BMPMAN also gazes into you.

"I am one of the best FREDders on Earth" -General Battuta

<Aesaar> literary criticism is vladimir putin

<MageKing17> "There's probably a reason the code is the way it is" is a very dangerous line of thought. :P
<MageKing17> Because the "reason" often turns out to be "nobody noticed it was wrong".
(the very next day)
<MageKing17> this ****ing code did it to me again
<MageKing17> "That doesn't really make sense to me, but I'll assume it was being done for a reason."
<MageKing17> **** ME

<MageKing17> God damn, I do not understand how this is breaking.
<MageKing17> Everything points to "this should work fine", and yet it's clearly not working.
<MjnMixael> 2 hours later... "God damn, how did this ever work at all?!"
<MageKing17> so
<MageKing17> more than two hours
<MageKing17> but once again we have reached the inevitable conclusion
<MageKing17> How did this code ever work in the first place!?

<@The_E> Welcome to OpenGL, where standards compliance is optional, and error reporting inconsistent

<MageKing17> It was all working perfectly until I actually tried it on an actual mission.

<IronWorks> I am useful for FSO stuff again. This is a red-letter day!
* z64555 erases "Thursday" and rewrites it in red ink

<MageKing17> TIL the entire homing code is held up by shoestrings and duct tape, basically.