Author Topic: Post Merdian: "Press None to Call Fire"  (Read 1285 times)

0 Members and 1 Guest are viewing this topic.

Post Merdian: "Press None to Call Fire"
I'm playing this mission and when I'm supposed to call Epsilon to fire on the Maxim fighters, I get a message saying "Press None to Call Fire". I assume None is some key that isn't properly mapped, but I've gone through all my controls and everything is bound to something, so I'm a bit confused. Am I doing something wrong in the gameplay? Are my keys not bound properly? I keep losing the mission but I can't seem to do whatever it is I'm supposed to.

Re: Post Merdian: "Press None to Call Fire"
It's usually '1' which should be mapped to multiplayer message all under misc. controls.
[19:31] <MatthTheGeek> you all high up on your mointain looking down at everyone who doesn't beam everything on insane blindfolded

Re: Post Merdian: "Press None to Call Fire"
That did it, thanks. I had remapped the controls and that one was null- I had seen it but I must have mentally assumed "the multiplayer message button can't possibly be the one mapped to fire control".


Offline AdmiralRalwood

  • 211
  • The Cthulhu programmer himself!
    • Skype
    • Steam
    • Twitter
Re: Post Merdian: "Press None to Call Fire"
Those multiplayer keys that default to 1, 2, 3, and 4 are commonly used by FREDers because assigning special functions to those keys is so convenient if they're mapped to the default, and SEXP-based keypress checks can only check for keys that exist in the controls, rather than picking arbitrary keys.
Ph'nglui mglw'nafh Codethulhu GitHub wgah'nagl fhtagn.

schrödinbug (noun) - a bug that manifests itself in running software after a programmer notices that the code should never have worked in the first place.

When you gaze long into BMPMAN, BMPMAN also gazes into you.

"I am one of the best FREDders on Earth" -General Battuta

<Aesaar> literary criticism is vladimir putin

<MageKing17> "There's probably a reason the code is the way it is" is a very dangerous line of thought. :P
<MageKing17> Because the "reason" often turns out to be "nobody noticed it was wrong".
(the very next day)
<MageKing17> this ****ing code did it to me again
<MageKing17> "That doesn't really make sense to me, but I'll assume it was being done for a reason."
<MageKing17> **** ME

<MageKing17> God damn, I do not understand how this is breaking.
<MageKing17> Everything points to "this should work fine", and yet it's clearly not working.
<MjnMixael> 2 hours later... "God damn, how did this ever work at all?!"
<MageKing17> so
<MageKing17> more than two hours
<MageKing17> but once again we have reached the inevitable conclusion
<MageKing17> How did this code ever work in the first place!?

<@The_E> Welcome to OpenGL, where standards compliance is optional, and error reporting inconsistent

<MageKing17> It was all working perfectly until I actually tried it on an actual mission.

<IronWorks> I am useful for FSO stuff again. This is a red-letter day!
* z64555 erases "Thursday" and rewrites it in red ink

<MageKing17> TIL the entire homing code is held up by shoestrings and duct tape, basically.