Hard Light Productions Forums

General FreeSpace => FreeSpace & FreeSpace Open Support => Topic started by: Iain Baker on July 12, 2021, 03:16:09 pm

Title: Test build campaigns not showing in campaign list
Post by: Iain Baker on July 12, 2021, 03:16:09 pm
Hi all, I have been asked to playtest restricted access test builds of several campaigns. Unfortunately I have ran into a snag with two of them, the snag being that the campaigns does not appear in their respective campaign lists and so can't be playtested. I checked the techroom mission simulator to see if they were listed as single missions or similar and nope, they aren't there.

I'm assuming something has gone wrong somewhere, although I'm not sure what. Anyone have any idea what might be causing this and what either I or the mod uploader need to do fix it?

Any advice greatly appreciated :-)
Title: Re: Test build campaigns not showing in campaign list
Post by: 0rph3u5 on July 12, 2021, 04:02:27 pm
Check if the mod has a game-settings.tbl or [insert-name-here]-mod.tbm, if yes check it for a section called "#Ignored Campaign File Names".
Title: Re: Test build campaigns not showing in campaign list
Post by: Iain Baker on July 12, 2021, 04:28:38 pm
Check if the mod has a game-settings.tbl or [insert-name-here]-mod.tbm, if yes check it for a section called "#Ignored Campaign File Names".

I had a look but couldn't find it. I did notice when i looked in the folders that it was set up in an unconventional way. The data folder was in one called Contents, and there was a folder called 'shiny'  :confused:

I have attached the debug log in case that helps :-)

 
Title: Re: Test build campaigns not showing in campaign list
Post by: wookieejedi on July 12, 2021, 05:53:02 pm
Always good to check the physical files got downloaded in the package. Also make sure the missions are in folder called 'missions'.
Title: Re: Test build campaigns not showing in campaign list
Post by: Iain Baker on July 13, 2021, 04:50:09 am
Always good to check the physical files got downloaded in the package. Also make sure the missions are in folder called 'missions'.

It looks like the files are there, and the missions are in the missions folder, but still no joy. It seams that Knossos isn't 'seeing' them. If this is the case, then what usually allows Knossos to see the files, since I'm assuming mine is missing. Any ideas?

Cheers :-)
Title: Re: Test build campaigns not showing in campaign list
Post by: 0rph3u5 on July 13, 2021, 06:41:30 am
Hmmm, that log has me highly suspicious - I assume that "My_Apo-1.1.6" is the mod you are trying to load? - If so educated guess from that log is that mod.json might be broken.