Author Topic: major audio problem  (Read 1770 times)

0 Members and 1 Guest are viewing this topic.

Offline alisbin

  • 24
hey everyone,
first of all, fantastic job on the FSO project, i love it. however i've got an irritating bug and i have no idea how to fix it or find a work around.
when i'm playing FSO (doesnt matter if its a mod or not), if more then 3 sound events (at least i think 3, might be more) are initiated (example, i'm flying in the last FS2 mission, i've got a missile on my tail, so i hit the burners and drop a couple countermeasures at the same time) my entire system hangs for about a second, all the sounds that are going hum, then my computer reboots. also, every time this happens when it finishes restarting windows has an error and asks me to reboot yet again.

i've checked and updated all drivers, including getting the latest openal, i've gotten and run the latest FSO installer and i've tried running with both generic hardware and generic software sound. i've also run some registry cleaners in case i had a bad value.  anything i can do? no command line stuff normally, tried it with and without

my system: ECS nForce 570 SLIT-A Socket 775, Intel Core2 Duo E6300 1.86Ghz, 3 gig Corsair TWINX 1024MB PC5400 DDR2, XFX GeForce 7600gt XXX, Sound Blaster Audigy SE, Saitek X52 flightstick.
« Last Edit: September 07, 2007, 07:52:53 pm by alisbin »

 

Offline karajorma

  • King Louie - Jungle VIP
  • Administrator
  • 214
    • Karajorma's Freespace FAQ
Check your sound drivers. Are you running the most recent ones?
Karajorma's Freespace FAQ. It's almost like asking me yourself.

[ Diaspora ] - [ Seeds Of Rebellion ] - [ Mind Games ]

 

Offline Flipside

  • əp!sd!l£
  • 212
I used to get that and spent ages checking the soundcard before realising that it was a heating problem on the Graphics card. You might also want to try setting the processor affinity to only one processor, it could be that the 'psuedo' multithreading is causing some problems, I've had that with a couple of games.

 

Offline jr2

  • The Mail Man
  • 212
  • It's prounounced jayartoo 0x6A7232
    • Steam
Check your sound drivers. Are you running the most recent ones?
i've checked and updated all drivers, including getting the latest openal, i've gotten and run the latest FSO installer and i've tried running with both generic hardware and generic software sound.

:p  I was about to suggest drivers, but I actually read his post.  :p  You know I'm just picking, right?

 

Offline karajorma

  • King Louie - Jungle VIP
  • Administrator
  • 214
    • Karajorma's Freespace FAQ
If I had a pound for every person who has claimed to have the right drivers and turned out not to I'd be hiring someone else to troubleshoot for me and be sitting on a beach sipping cocktails right now.
Karajorma's Freespace FAQ. It's almost like asking me yourself.

[ Diaspora ] - [ Seeds Of Rebellion ] - [ Mind Games ]

 

Offline alisbin

  • 24
unless sound blaster's auto driver update gave me the wrong drivers, i've got the right drivers. i'll try setting the affinity and see what happens