Author Topic: Missing ships in FS2?  (Read 2376 times)

0 Members and 1 Guest are viewing this topic.

Hi.

I'm currently playing through fsport but I wanted to make sure FS2 was working fine. It's did some weird things for me, however.

First, I am running 3.6.10 on linux. I compiled the binaries on this machine. FSport runs fine, except for some cutscene/sound issues which are not terribly important.

I created to startup scripts for FS1 and FS2 respectively. they read:
"<appropriate tree>/fs2_open_r -spec -glow -mipmap -snd_preload -fps -orbradar -mod fsport, mediavps"
"<appropriate tree>/fs2_open_r -spec -glow -mipmap -snd_preload -fps -orbradar -mod mediavps"

So, when I load up the -mod mediavps one and look at the tech room, the ships appear to be missing... or at least, missing a lot of parts. Lights are blinking but they're not attached to anything. The same happens in the game as well. I start  the first training and I can't see the ship, though I can target it.  Also, when it's time to start shooting the drone, I shoot at where the target box ssays the drone should be , but no impacts.

So, any thoughts on what's going on?

Thanks for the help.


 

Offline jr2

  • The Mail Man
  • 212
  • It's prounounced jayartoo 0x6A7232
    • Steam
You'd have to create a new pilot for FS2 or wait until after you finish the FSPort campaign.  That's a bug with the current pilot file code.

 

Offline karajorma

  • King Louie - Jungle VIP
  • Administrator
  • 214
    • Karajorma's Freespace FAQ
That sounds like the error you'd get if you were running 3.6.9 without mp-710_models.vp in your mediavps folder and without the -jpgtga flag.

However you shouldn't be getting that error if you're using a current build from the 3.6.9 branch (i.e 3.6.10). Of course the easy way to find out is to check if you have that VP and add the -jpgtga flag. if you are running 3.6.10 it will let you know right away that the flag is unrecognised.
Karajorma's Freespace FAQ. It's almost like asking me yourself.

[ Diaspora ] - [ Seeds Of Rebellion ] - [ Mind Games ]

 

Offline jr2

  • The Mail Man
  • 212
  • It's prounounced jayartoo 0x6A7232
    • Steam
I'm currently playing through fsport but I wanted to make sure FS2 was working fine. It's did some weird things for me, however.

From this I gather that FS2 campaign was working fine for him, and also that he switched to a new campaign (fs2) in the middle of another campaign (fsport).  Which is what led me to believe that the problem is his pilot file.  Also, he stated that he was using 3.6.10, which led me to believe that -jpgtga was enabled by default.  About the mp-710 patches, I didn't think of them.  ;)

 
Re: Missing ships in FS2?
I tried to load up the game and created a completely new character in FS2. The same problem came up, though, that the ships were missing.

What else can I try to help figure this out?  Would I need to delete old characters first, etc? which would suck, but wouldn't this also be a problem for any mod? or just going from fsport to whatever?

re: -jpgtga flag. I'm using 3.6.10 so if this flag is included, I get a "not found" sort of error which the system ignores anyways.

 

Offline jr2

  • The Mail Man
  • 212
  • It's prounounced jayartoo 0x6A7232
    • Steam
Re: Missing ships in FS2?
OH... did you perchance forget to change the campaign in the Campaign Room?  When you switch mods, you have to do that... although FS2 should have told you that the "currently selected campaign is not available"...

EDIT: And no, you don't have to delete your old pilots; if that is the problem, the new pilot file would work independently from any broken old ones.

 
Re: Missing ships in FS2?
I seem to have gotten things working, but it took the following:

1. load FS2 as fs2_open_r     NO MOD INFO
2. delete all FS2 pilots inside FS2.
3. create new pilot inside FS2.
4. only campaign available is FS2, but selected that anyways.
5. When I load it, I have to leave off any mod info in the command line. If I put it in "-mod mediavps", the ships disappear.

 

Offline jr2

  • The Mail Man
  • 212
  • It's prounounced jayartoo 0x6A7232
    • Steam
Re: Missing ships in FS2?
That's.... odd.  you have the 710 patches for the 3.6.8 Zeta mediavps?

 
Re: Missing ships in FS2?
I used Turey's installer/downloader for the latest version which was 3.6.10, I believe. that was... less than a month ago I think, so whatever version comes with that I'm using. if there's another way to check the version, let me know.

 

Offline jr2

  • The Mail Man
  • 212
  • It's prounounced jayartoo 0x6A7232
    • Steam
Re: Missing ships in FS2?
Nah... we know what you have now...