Author Topic: Choppy gameplay  (Read 3750 times)

0 Members and 1 Guest are viewing this topic.

Offline AlienTermite

  • 25
  • I love... lamp?
Hey guys, sorry to bump an old thread but I have some new info. I've been playing around a little more and I noticed something interesting that may be the cause of my problem.

So, the framerate is terrible in full screen and smooth as butter in windowed mode, even with the window stretched across the whole screen. Now, I kept the task manager open to monitor CPU load and noticed that in windowed mode, core 2 runs at only maybe 30% load, and in full screen mode the game totally maxes out core 2. I'm using an AMD Phenom x6 1100t 6-core CPU (3.3 ghz stock, OC'd to 3.8). I know freespace only uses one core, and I wouldn't think that CPU speed would be a problem with my setup... but that's what I've noticed none the less and I think this may be the reason I've been having such a terrible time with the choppy gameplay.

Anyone have any thoughts or know of any possible way to solve this??

 

Offline The E

  • He's Ebeneezer Goode
  • Moderator
  • 213
  • Nothing personal, just tech support.
    • Steam
    • Twitter
What about running it in fullscreen window mode (Which is like windowed mode, but without the window borders)?
If I'm just aching this can't go on
I came from chasing dreams to feel alone
There must be changes, miss to feel strong
I really need lifе to touch me
--Evergrey, Where August Mourns

 

Offline AlienTermite

  • 25
  • I love... lamp?
Nope, the game still stutters in full screen window mode :(

Honestly... I guess playing in windowed mode really isn't that bad when I consider how much better the game runs vs. in normal mode. Maybe I'll just have to get used to the border at the top lol

 

Offline Herra Tohtori

  • The Academic
  • 211
  • Bad command or file name
Could you tell if this happens when you turn the ship with keyboard (or joystick) instead of mouse?

If the problem is connected to mouse, it would suggest some sort of problem with (hidden) cursor movement fighting for CPU power, could be a mouse driver thing... but please confirm the problem happens also if you disable mouse controls and use other input device to control the ship's orientation.

Also, have you tried disabling Aero desktop environment already (although it really should switch off automagically when you start FSOpen)?
There are three things that last forever: Abort, Retry, Fail - and the greatest of these is Fail.

 

Offline AlienTermite

  • 25
  • I love... lamp?
It happens with both keyboard and mouse.  I tried disabling mouse and use just keyboard and it still stutters. I think it's definitely some sort of weird CPU bottleneck thing going on but what's causing it is the question. The framerate is like night and day in windowed mode vs. normal screen mode.... and the CPU load in task manager is the proof that something weird is going on.

Also, I don't have any of that Aero stuff enabled

 

Offline AlienTermite

  • 25
  • I love... lamp?
Hey everyone, sorry to bring up this REALLY old thread again but I think I finally shed some more light on the problem I was having a while back and wanted to share. After taking a few months off from playing freespace I decided to come back and try again. I'm still having the same problem I was having before (with a different PC build BTW...) but I think I finally found to problem.

Whenever my computer is idle, my CPU downclocks to 1.5 ghz. For some reason, my computer doesn't detect FSO as a "strenuous" activity and doesn't clock back up to full speed (which is a 4.1 ghz OC.) I think this is what's causing the framerate to become really choppy when there's lots going on. I'm going to try to disable whatever setting is in BIOS that controls CPU downclock at idle and see if it makes a difference. I'll post back soon with the results.

Keeping my fingers crossed....

 

Offline pecenipicek

  • Roast Chicken
  • 211
  • Powered by copious amounts of coffee and nicotine
    • Minecraft
    • Skype
    • Steam
    • Twitter
    • PeceniPicek's own deviantart page
that... is actually quite a fair bit possible. Have you tried to update your chipset drivers maybe?

due to FSO being  a single core app, its quite possible that some throttling solutions might not pick it up as a "proper" load.


my memory is a bit iffy, but i remember something like that happening to me with an intel c2d E7500 a while back.
Skype: vrganjko
Ho, ho, ho, to the bottle I go
to heal my heart and drown my woe!
Rain may fall and wind may blow,
and many miles be still to go,
but under a tall tree I will lie!

The Apocalypse Project needs YOU! - recruiting info thread.

 

Offline AlienTermite

  • 25
  • I love... lamp?
Well, I was able to disable the downclock but I'm still getting a choppy framerate. I'm pretty sure it's because I'm still running into a weird CPU bottleneck. In a previous post I stated how it doesn't happen in windowed mode, only fullscreen. This also happens without any mediavp's enabled, or just vanilla game, which leads me to believe that it has something to do with the core freespace files and not the FSO upgrades.

Here are a couple pictures of my CPU load to show what I'm talking about.

If anyones got any ideas, shoot. Otherwise, I might have to be done with Freespace cause its really distracting and honesty, unplayable :(  (or just play in windowed mode, but that sucks!!)



[attachment deleted by ninja]
« Last Edit: August 12, 2011, 02:27:28 pm by AlienTermite »

 

Offline Zacam

  • Magnificent Bastard
  • Administrator
  • 211
  • I go Sledge-O-Matic on Spammers
    • Minecraft
    • Steam
    • Twitter
    • ModDB Feature

Wonder if it's an effect of the speed step or whatever.

rev_posix had an interesting issue on Unreal Tournament once, where the laptop had speedstep enabled. It was still at 60FPS (or whatever) but it was the slowest smoothest 60FPS you could imagine, until he turned it off.

You might also try the processor affinity registry setting to see if that does any good. In uncouples it from being single core bound, but you won't get any multi-threading benefits from it. If you ARE using that already, then check your speedstep or adaptive over-clocking (if there is any) and play around with those. I actively dislike any adaptive throttling myself even though I get the point behind it.
Report MediaVP issues, now on the MediaVP Mantis! Read all about it Here!
Talk with the FSU on #SCP-FSU Talk with the SCP on #SCP
"If you can keep a level head in all this confusion, you just don't understand the situation"

¤[D+¬>

[08/01 16:53:11] <sigtau> EveningTea: I have decided that I am a 32-bit registerkin.  Pronouns are eax, ebx, ecx, edx.
[08/01 16:53:31] <EveningTea> dhauidahh
[08/01 16:53:32] <EveningTea> sak
[08/01 16:53:40] * EveningTea froths at the mouth
[08/01 16:53:40] <sigtau> i broke him, boys

 

Offline Nix

  • 28
  • In the morning!
    • Minecraft
*ker-chunk-a-bump*

EDIT 10/4
Downgrading to nVidia drivers v 260.99 fixed this problem for me. When head ani's play, the game no longer goes choppy.

I'm running into these same issues, cept I'm using a three (maybe four) year old laptop.  Geforce 8600GT. 
Also running the final build (3.6.12)  MediaVP's fresh from Turey's Freespace installer, running the standard FS2 campaign.  Also occurs in the FSPort.  (Downloaded yesterday, so most current versions available to the fsoinstaller)
Installed fresh last night, ran Turey's installer, downloaded "the works" and everyting appears to be in order in the install dir. 

I thought I'd fire it up and check out some of the new campaigns, and I'm running into the choppy/hitching sensation, and it occurs in fullscreen mode, only when a head animation plays back in the window.  Disabled mouse and ran only keyboard.  Seems to only occur when running in Fullscreen or Fullscreen window, but in windowed mode it's smooth as silk.   Native res I'm running at is 1440X900

I'm going to downgrade to 260.99 and try that to see if it will stop the choppyness. Also tried latest nightly build for Windows, SSE2 build, and I'm running into another odd problem.  In addition to the chop, the hud jumps around while turning.  Occurs only in fullscreen though. Windowed mode everything stays still. 

I've forced my processor to run as fast as it can go, and not throttle down.  No difference. 

Has/had anyone had any luck on this problem?
Thanks,
« Last Edit: October 05, 2011, 01:35:39 am by Nix »