Author Topic: Weird keyboard bug?  (Read 826 times)

0 Members and 1 Guest are viewing this topic.

Weird keyboard bug?
I am testing a Voiceattack profile I am working on and have come across a weird bug. Not sure what is causing it but here goes.

I have the Delete key assigned to Decrease Weapon Energy and when I speak the command that would execute the command and send the Delete key it seems to send out a Numpad * which is assigned to Chase View.

 I even created a simple one command Voicecommand test profile and it recreated the problem. 

And the weird part... it works correctly in Notepad. This is what made me pull my hair out.

I decided to try and test this another way. I went into the Freespace 2 Open control settings screen and clicked "Bind" then spoke the command to send the Delete key and sure enough the Numpad - . showed as the new bind.

So I am not sure if Voiceattack is somehow sending the wrong key (at least the way Freespace 2 sees it as it works in Notepad) or that Freespace 2 Open is reading it incorrectly for some reason.

And on further testing:

I tested DCS and it worked fine but when I tested it in IL-2 1946 is did the same thing and sent a Numpad *

Any ideas?


  

Offline AdmiralRalwood

  • 211
  • The Cthulhu programmer himself!
    • Skype
    • Steam
    • Twitter
Re: Weird keyboard bug?
This sounds like a problem with Voiceattack rather than FSO.
Ph'nglui mglw'nafh Codethulhu GitHub wgah'nagl fhtagn.

schrödinbug (noun) - a bug that manifests itself in running software after a programmer notices that the code should never have worked in the first place.

When you gaze long into BMPMAN, BMPMAN also gazes into you.

"I am one of the best FREDders on Earth" -General Battuta

<Aesaar> literary criticism is vladimir putin

<MageKing17> "There's probably a reason the code is the way it is" is a very dangerous line of thought. :P
<MageKing17> Because the "reason" often turns out to be "nobody noticed it was wrong".
(the very next day)
<MageKing17> this ****ing code did it to me again
<MageKing17> "That doesn't really make sense to me, but I'll assume it was being done for a reason."
<MageKing17> **** ME
<MageKing17> THE REASON IS PEOPLE ARE STUPID
<MageKing17> ESPECIALLY ME

<MageKing17> God damn, I do not understand how this is breaking.
<MageKing17> Everything points to "this should work fine", and yet it's clearly not working.
<MjnMixael> 2 hours later... "God damn, how did this ever work at all?!"
(...)
<MageKing17> so
<MageKing17> more than two hours
<MageKing17> but once again we have reached the inevitable conclusion
<MageKing17> How did this code ever work in the first place!?

<@The_E> Welcome to OpenGL, where standards compliance is optional, and error reporting inconsistent

<MageKing17> It was all working perfectly until I actually tried it on an actual mission.

<IronWorks> I am useful for FSO stuff again. This is a red-letter day!
* z64555 erases "Thursday" and rewrites it in red ink

<MageKing17> TIL the entire homing code is held up by shoestrings and duct tape, basically.