Author Topic: Missing Ships/Textures  (Read 551 times)

0 Members and 1 Guest are viewing this topic.

Missing Ships/Textures
Hi all,

I've searched the forums and I can't seem to find a fix for this, so I'm hoping you fine members of this wonderful community can help me out. I've recently found myself with a lot of free time thanks to quarantine, so I've decided to fire up FS2 and revisit an old friend. So I've installed FSO the latest (4.0) media vps, and was looking forward to firing this bad boy up. Unfortunately, when I go to play the game, the ships are not visible. Lights, engine trails, weapon and damage effects are visible, but the ships simply are not, even though they are visible when viewed in the tech room. I'm not all tech savvy, but I've been using the wxlauncher and using the FS2 Open 19.0.0 Build (x64 AVX) build. I've also gone into advanced settings and have discovered that when I use the "Disable OpenGL RenderTargets" flag, the ships will show up, but then the backgrounds do not (no nebula, no stars, pitch black), making space look very empty and flat. So I'm looking for another solution if anyone has any.

The hardware i'm using is quite old, and by no means fancy, but it's a laptop running and AMD-4400M APU w/ Radeon HD Graphics and 6GB of RAM (I know its ancient, but it's what I got.)

Any help is appreciated. I'm not stranger to FS, but have been away from FS Open and the SCP for a long time, and would like to revisit this old gem.


Re: Missing Ships/Textures
First of all it you're neither using the recent most built (20.0, from the Nightly board), nor the recent most MVPs (4.1.23); maybe that will fix the issues.

In general, I'd suggest to use Knossos launcher instead of the wx one.

Re: Missing Ships/Textures
I'm not having any luck with the Knossos Launcher. It either doesn't load the available mod list properly, and when it does and I try to load the media vps (tried with 4.x, and 4.1) the game boots up, I can hear the sounds (menus, opening cutscene) but no visuals apart from the cursor.

Re: Missing Ships/Textures
Okay, this is the time for a debug log. Using the dropdown menu over a mod tile, select "Run Fast Debug", then play the game until the bug happens, and then exit the game and use "Upload debug log" option and share the link here.

Generally, these kind of bugs often happen when your drivers (most likely graphic drivers) are not up to date or if you happen to be using some broken driver release somehow. The debug log might inform us about the driver version but I'd suggest you to check it yourself right away.
How do you kill a hydra?

You starve it to death.


Offline Su-tehp

  • Devil in the Deep Blue
  • 210
Re: Missing Ships/Textures
This missing textures thing has happened to me too sometimes when I first got back to Freespace a few months ago.. What solved it for me was using Knossos and selecting "Enable Shadows" from the Graphics submenu in the FSO Settings, located in the pulldown menu of each individual mod you've downloaded. I tested it by going into the techroom of the mod before I even started playing.

Seriously, Knossos is a gawddamned gawdsend that strips all the gawds of their gawdliness. Not even the gawds can deny the gawdly awesomeness of Knossos. I swear to gawd.

Creator of the Devil and the Deep Blue campaign - Current Story Editor of the Exile campaign

"Let my people handle this, we're trained professionals. Well, we're semi-trained, quasi-professionals, at any rate." --Roy Greenhilt,
The Order of the Stick

"Let´s face it, we Freespace players may not be the most sophisticated of gaming freaks, but we do know enough to recognize a heap of steaming crap when it´s right in front of us."
--Su-tehp, while posting on the DatDB internal forum

"The meaning of life is that in the end you always get screwed."
--The Catch 42 Expression, The Lost Fleet: Beyond the Frontier: Steadfast

Re: Missing Ships/Textures
I will try the "enable shadows" option next. Might just do a clean install beforehand. I've been using the wxlauncher because, as I stated earlier, the Knossos Luancher (13.3) doesn't work for me. It's great for finding/installing mods, yes, but when I run the 4.1 media vps, I don't get any visuals and can only hear sounds of cutscenes and menus, but can only see the cursor. Knossos Launcher 14 doesn't even load all the mods and I can't install FSO or Media vps.

Re: Missing Ships/Textures
Hmm, but can you use the the 4.1 MVPS with wxLauncher reliably but not with Knossos? That's strange.

Also, not sure where are you downloading Knossos from, but try here - the most recent version with a bunch of fixes.

EDIT: Also, what about the driver update or a debug log?
How do you kill a hydra?

You starve it to death.

Re: Missing Ships/Textures
Thanks for the help, I finally figured out how to get it working, despite Knossos being a little finicky. My graphics drivers are up to date, all I needed to do was enable shadows. Also, my PC doesn't seem to like the 20.0x series FSO .exes, so I rolled back to 19.0 and it works. The only slight issue is that ships don't show up in the target info box in bottom left, but this is minor, I'll live. Everything is so purdy!