Author Topic: Knossos help - Constant pauses  (Read 377 times)

0 Members and 1 Guest are viewing this topic.

Offline Eyth

  • 21
Knossos help - Constant pauses
Hi,

I have been trying to use Knossos 0.14.3 (I have been using fs2 open before) and have run into a pretty weird bug.
The game pauses by itself every few seconds. Furthermore, the HUD disappear/reappears from time to time (less common than the pause but still several times per minutes) as if I had pressed Shift-O.
There is no crash or anything and I can unpause and reactivate the HUD but obviously this makes the game barely playable.
Those are the only two functions activating by themselves I noticed (no moving/shooting or anything else tht seems to activate by itself).

Here is what I checked/tested :
- I have checked on various random mods with new pilots and the issue is present everywhere (including the main FS2 campaign).
- I do not have this bug if I use fs2 open (for instance I don't have the issue with 3.7.2)
- The bug is even present if I disable every single key binding.
- I have the same issue with both Windows 7 and Windows 10 as well (using the same Knossos library).

I'm playing the game with keyboard and mouse and the Knossos joystick setting is set to No Joystick.
I feel like this is probably some minor thing that I missed but I just can't find it. I tried searching the forum for auto-pause but I didn't find anything.



 
Re: Knossos help - Constant pauses
- I do not have this bug if I use fs2 open (for instance I don't have the issue with 3.7.2)

Hi, uhhhh... yes, you are supposed to use Freespace Open. In fact, just install and play MediaVPs instead of retail FS2 instead, it will automatically download and use a proper FSO build.
How do you kill a hydra?

You starve it to death.

 

Offline Eyth

  • 21
Re: Knossos help - Constant pauses
I may have been unclear, I meant when I used my FS2 Open with my old launcher setup it worked. Knossos does use FS Open (21.2).

However, this did help me notice something.
I have been using an old FS Open for a while (like I said 3.7.2).
I decided to try get some newer versions and launch them with my launcher setting, and I noticed I have the same pause issue with FS Open after version 3.7.4.

So basically no issue until FS Open 3.7.4 but above (3.7.5, 3.8 and obviously 21.x).
So I guess it's probably not actually an issue with Knossos but with FS Open.

 

Offline Antares

  • 28
  • Author of The Shivan Manifesto
Re: Knossos help - Constant pauses
Is the game actually pausing (i.e., "PAUSE" comes up on the screen), or are you getting choppy gameplay?

If you're seeing stuttering during play, open your FSO settings in Knossos for whatever build you're using, pick "Game Speed" from the drop-down menu, and check the "Disable vertical sync" box. That might help.
We have returned to continue our purification of this galaxy. It is again your turn to be crushed beneath the great force that is the Antaran army. All your petty squabbling with the other beings in this galaxy is meaningless. The Antaran fleet will destroy you all, one by one. You may not surrender. You cannot win. Your only option is death.

  

Offline Eyth

  • 21
Re: Knossos help - Constant pauses
It is an actual pause with the word PAUSE on the screen.

To make it simpler, I just tried with yal_launcher (no Mod) and fs2_open_21_4_0_RC1_x64_SSE2 to launch base FS2 and I do get the pausing in the tutorial of FS2.
And it's apparently an issue that I have for all versions of FS2 since the 3.7.4.