Author Topic: FS2_Open immediately crashes.  (Read 2812 times)

0 Members and 1 Guest are viewing this topic.

Offline Liam

  • 21
FS2_Open immediately crashes.
I have previously had FS2_Open working fine on this machine, up until OpenGL somehow corrupted and I ended up having to format, however now when I run the fs2_open_3_6_9.exe file it immediately crashes, launcher.exe also crashes when I try to load the fs2_open_3_6_9 executable into it. Here's some info:

- I am running XP Pro SP2 completely patched up (had this issue before I'd patched it however.)
- I have tried a completely fresh install of FS2 with the installer linked on the main page, twice.
- I have also tried a manual install (installing from the discs and then manually getting the executables and mv_*.vp files.)
- Other OpenGL games work fine (although I don't get the chance to switch between OGL and Direct3D.)
- This happens with regular AND debug.
- If I don't have OpenAL installed it gives me the error about not having the DLL, it doesn't crash, so I'm guessing it happens some where after it searches for that DLL.

Here's the crash log:
Code: [Select]
fs2_open_3_6_9 caused an Access Violation in module ntdll.dll at 001b:7c918fea.
Exception handler called in FreeSpace 2 Main Thread.
Error occurred at 6/1/2007 13:59:20.
C:\Games\FreeSpace2\fs2_open_3_6_9.exe, run by Liam.
1 processor(s), type 586.
512 MBytes physical memory.
Write to location 00000010 caused an access violation.

EAX=00000000 CS=001b EIP=7c918fea EFLGS=00010246
EBX=00000000 SS=0023 ESP=0012f6f8 EBP=0012f76c
ECX=0000006c DS=0023 ESI=100dee80 FS=003b
EDX=100dee90 ES=0023 EDI=00000000 GS=0000
Bytes at CS:EIP:
ff 40 10 8b 45 fc 83 e0 01 89 45 e8 8b 06 ff 40

Just to reiterate, I've had it running fine before on this exact machine, so I'm fairly certain the machine is up to the job. I've been working on this for 3 days but I've completely run out of ideas so I thought I'd ask for help, I did search this forum on the subject and found a post similar to mine (here) but it looks like it was never resolved... any ideas?

Thanks for any help.

Edit: oh and one more thing, I'm not sure if this matters at all, but my OS is currently installed on my D: drive.


Offline Wanderer

  • Wiki Warrior
  • 211
  • Mostly harmless
Re: FS2_Open immediately crashes.
Hi, and welcome

If you have run the debug exe as well, then search for 'fs2_open.log' named file and copy paste it here.

Though my guess atm (without additional details) is that you haven't got properly installed OpenAL.
Do not meddle in the affairs of coders for they are soggy and hard to light


Offline karajorma

  • King Louie - Jungle VIP
  • Administrator
  • 214
    • Karajorma's Freespace FAQ
Re: FS2_Open immediately crashes.

The first 3 reasons are just as likely to scupper an FS2 install as a BtRL one.
Karajorma's Freespace FAQ. It's almost like asking me yourself.

[ Diaspora ] - [ Seeds Of Rebellion ] - [ Mind Games ]


Offline Liam

  • 21
Re: FS2_Open immediately crashes.
You mentioning that OpenAL might not've been installed correctly got me thinking... when I tried to install OpenAL again after reinstalling, the link was down on the downloads page of the main site, so I googled for the exe, it was almost the same size so I figured it was the same file, I deleted OpenAL.dll (wrap_oal.dll wasn't even there, so I'm not shocked I had problems) tried the download link on the SCP site and now it works perfectly, thank you both for your help, no more crashing :).

Thanks again.