Author Topic: In-game problem with Fs Open  (Read 3178 times)

0 Members and 1 Guest are viewing this topic.

In-game problem with Fs Open
 A little help guys.

I've played Freespace since it came out. Recently I got a new computer and ofcourse redownloaded the entire thing.

I got the 1.9c version of the complete install. All the files, videos etc. The latest Fs open, the works.

 My problem is this: I can play fine, but the game randomly crashes. I was playing Fs1 port and it crashed a couple of times during the shield prototype escort mission. I ran the debug exe and got through it no problem.
 Then I made it to the end of the Capture Ramses mission but the game crashed as I was trying to jump out.

After that I can't even get past the first few seconds of the mission without the game crashing. I seems to run fine until I start moving around. A few quick turns and the screen freezes. It's like there's so much stuff going on that if I move the screen too fast it just stops. But because it happens randomly I can't really narrow down the problem.

 Nothing works, I've tried disabling all the graphical do-dads, changed from opengl to direct3d. Messed around with my video card settings. Downloaded newest drivers. Pretty much turned off all that could be turned off but still nothing.

 I get this if I look at the errorlog:

fs2_open_3_6_9_debug caused an Access Violation in module fs2_open_3_6_9_debug.exe at 001b:0056f51b.
Exception handler called in FreeSpace 2 Main Thread.
Error occurred at 6/11/2007 08:21:00.
E:\Games\FreeSpace2\fs2_open_3_6_9_debug.exe, run by X.
1 processor(s), type 586.
1024 MBytes physical memory.
Read from location 00000000 caused an access violation.

EAX=00000000 CS=001b EIP=0056f51b EFLGS=00010246
EBX=7ffdf000 SS=0023 ESP=0012ee24 EBP=0012f2e4
ECX=0159e45c DS=0023 ESI=0012ee24 FS=003b
EDX=00000000 ES=0023 EDI=0012f2e4 GS=0000
Bytes at CS:EIP:

I tried searching the forums for help, but all similar errors offered no certain fixes to the problem.

 The funny thing is that not few years ago I played an earlier version the scp with a different computer and I remember getting similar crashes. The screen would just freeze mid-movement. I can't remember what I did back then, but I'd sure like to play the game with the latest eyecandy turned on.

 I haven't tried other mods or skipped mods entirely because I'm not sure that the problem would even appear immediately. I got through several missions before it started happening... besides, if I can't play it all(especially the official releases) I'd rather not play it at all.

 So... throw some possible solutions at me. I'll try them out and see what happens.


Offline Wanderer

  • Wiki Warrior
  • 211
  • Mostly harmless
Re: In-game problem with Fs Open
Post your computer specs.. Especially graphics card.

If the game crashed last time you were running debug exe then.. First search for 'fs2_open.log' named file. Should be in your main data directory. Upload it somewhere so that we can take a look at it. Or alternatively run the debug again until such point that the game crashes. And then find the fs2_open.log file
Do not meddle in the affairs of coders for they are soggy and hard to light

Re: In-game problem with Fs Open
 I'm having truoble getting the fs2_open.log file. I can see the debug screen that appears when you run the debug version. But when the game crashes it crashes in a way that I can no longer get back to the desktop to view or copy the text from the log. And it dissapears when the game shuts down.

 By pressing the windows key or activating the taskmanager will allow me to choose the debug log from the taskbar but the frozen screen of the game occupies the screen and I cannot get rid of it before the entire thing shuts down, leaving me without the log.

As for the specs:

 AMD Athlon 64 3700+(2,21Ghz)
 1024mb Ram
 Radeon X800GTO 256mb - latest drivers
 Asus A8N32-SLI Deluxe

It's a good computer by all means. I can play nearly every game that has been realeased lately with good visuals and no problem. Games like Half Life 2 and C&C 3 ran with everything maxed no less. I haven't had any serious problems with any game of late.

 Another thing I noticed is that if I play using the Valkyrie fighter during the missions, it starts ok - probably won't even crash. But if I change to Apollo it will crash almost the minute I try to start spinning around with it.
 Because I've only had these two fighters to choose from it could be that there is some problem with the Apollo model or something. If that's the case I suppose I could try to play the game without using it. Still... I'm not sure that this is the root of the problem, or even if it's only restricted to this one fighter model.
« Last Edit: June 11, 2007, 02:01:51 am by Archangel »


Offline jr2

  • The Mail Man
  • 212
  • It's prounounced jayartoo 0x6A7232
    • Steam
Re: In-game problem with Fs Open
Can you find the archive that contained the FSPort .vp, and use your archive managment program to test it?  WinZip, WinRAR, and 7-Zip support this.  Usually it's Action -> Test Archive, Tools -> Test, or in Windows Explorer, right-click on the archive, go down to WinRAR, WinZip, or 7-Zip, and hit "Test".  If you can't find it, let me know, I'll post pictures / instructions.  Do you have any of these archive programs?

Re: In-game problem with Fs Open
 I used a single archive that extracted everything. I'll test that, but I'm not sure that'll yield much results.

I seem to be able to play the game fine since I stopped using the Apollo fighter. Which is a pretty weird reason for the game to crash. I can even have wingmen flying the Apollo, as long as I'm not flying one.
 I suppose I could revert to the original Apollo model, but to be honest - if the problem is simply because of the fighter - I think I'll rather just not use it.

 But thanks for your help guys. If the problem persists I'll feed you more data.


Offline Turey

  • Installer dude
  • 211
  • The diminutive form of Turambar.
    • FreeSpace Open Installer Homepage
Re: In-game problem with Fs Open
1.9c is actually pretty old.
Creator of the FreeSpace Open Installer.
"Calm. The ****. Down." -Taristin
why would an SCP error be considered as news? :wtf: *smacks Cobra*It's a feature.


Offline jr2

  • The Mail Man
  • 212
  • It's prounounced jayartoo 0x6A7232
    • Steam
Re: In-game problem with Fs Open
Which version of the Apollo are you using?  They did some upgrades on that nice model... I forget where it is, someone can probably point you to the latest version.