Author Topic: Insignia uses an invalid LOD  (Read 919 times)

0 Members and 1 Guest are viewing this topic.

Offline TopAce

  • Stalwart contributor
  • 212
  • FREDder, FSWiki editor, and tester
Insignia uses an invalid LOD
I need some help debugging the TF Kvasir. When I run a mission featuring it, I get this:

Code: [Select]
Warning: Model 'TF-13_KvasirR6.pof': insignia uses an invalid LOD (-1)

File: modelread.cpp
Line: 2418

The offending model is this. (Not sure this is the same as the one linked to in the wiki, so uploading it to my MF just in case.)

Log attached.

I can include tables and textures if needed. The problems occurred on every nightly debug I've tried, beginning some time at the end of March and including the new 21.2.0 release candidate.

[attachment deleted to save space]
My community contributions - Get my campaigns from here.

I already announced my retirement twice, yet here I am. If I bring up that topic again, don't believe a word.


Offline Goober5000

  • HLP Loremaster
  • 214
    • Goober5000 Productions
Re: Insignia uses an invalid LOD
The model you're using must be a buggy version.  I looked at the link you provided, and the model does indeed specify -1 for the LOD number of two of its insignias.

I downloaded the version from the FSMods link and all of its insignias specify LOD 0.  Also, the FSMods model uses 5 insignias, whereas the model you linked only uses 4.  There are also different sets of primary and secondary weapon points.