Author Topic: Can't get FSOInstaller, Knossos or WXlauncher to work properly on Linux Mint 21.  (Read 445 times)

0 Members and 1 Guest are viewing this topic.

Offline Stolas

  • 21
Can't get FSOInstaller, Knossos or WXlauncher to work properly on Linux Mint 21.
I've tried with Linux Mint 20.4 and 21.1 (Based on Ubuntu 22.04) with the same problems:

FSOInstaller installs mediaVPs and mods correctly except the second part of Freespace Open 22.2.0 Linux Standard. Error is always "FreeSpace Open 22.2.0 Linux Standard: The file 'mod.ini' could not be downloaded." I can still run the base Freespace2 from the Linux executable it downloads.

The instructions for Knossos linked at the top under the link Installing Freespace Open don't work. The PPA ngld/knossos is not compatible with newer versions of Linux, error is "Cannot add PPA: ''This PPA does not support jammy''." I've also tried building from the github source - I just get a blank window with a bar at the top saying the version number and a purple and black thing in the corner when I run ninja run, nothing else.

WXlauncher does not work either, tried building from source and installing the version available in app install with the same issues, advanced settings page just says "the executable did not generate a flag file" and play is greyed out. Mods and mediaVPs appear correctly on it and it is detecting the two downloaded linux executables though. I guess this might be related to the FSOInstaller second stage failing.

 
Re: Can't get FSOInstaller, Knossos or WXlauncher to work properly on Linux Mint 21.
From the knossos thread:
If you don't like bash-scripts, here is how it worked here on Ubuntu 20.04

Code: [Select]
sudo apt-get install python3 build-essential libasyncns0:i386 libavahi-client-dev:i386 libc6:i386 libcaca0:i386 libdbus-1-3:i386 libflac8:i386 libgcc1:i386 libglu1-mesa:i386 libjansson4:i386 libjpeg-turbo8:i386 liblua5.1-0:i386 libncursesw5:i386 libogg0:i386 libopenal1:i386 libpulse0:i386 libpulse-dev:i386 libsdl1.2debian:i386 libsdl1.2-dev:i386 libslang2:i386 libsndfile1:i386 libstdc++6:i386 libtheora0:i386 libtinfo5:i386 libvorbis0a:i386 libvorbisenc2:i386 libvorbisfile3:i386 libwrap0:i386 libx11-6:i386 libxau6:i386 libxcb1:i386 libxdmcp6:i386 libxext6:i386 zlib1g:i386 python3-wheel python3-setuptools pyqt5-dev pyqt5-dev-tools qttools5-dev-tools qt5-default curl python3-pyqt5.qtwebengine python3-pyqt5.qtwebchannel python3-requests-toolbelt python3-ply git p7zip-full libopenal-dev ninja-build pipenv yarnpkg python3-semantic-version libsdl2-dev libgtk-3-dev liblzma-dev libzstd-dev zlib1g-dev
sudo add-apt-repository ppa:linuxuprising/libpng12 && sudo apt update && sudo apt-get install libpng12-0
git clone https://github.com/PhantomHoover/old-knossos
cd old-knossos
pip3 install raven
pip3 install token-bucket
yarnpkg install
python3 configure.py
ninja run

Tl,dr: you need to use PhantomHoovers fork on current linux systems

 

Offline Stolas

  • 21
Re: Can't get FSOInstaller, Knossos or WXlauncher to work properly on Linux Mint 21.
Okay, at first I had exactly the same issue as before. I then made an alias for python specifically to python3.10, compiled and ran it again and now it works. python3 was pointing to python3.8 before, but it wasn't giving any errors when compiling. ¯\_(ツ)_/¯

And for future reference to anyone with a similar problem in the future, the qt5-default package doesn't exist anymore and I also had to run npm install .

Thanks.

Also, can I move all the mediavps and mods I already have over or do I need to completely redownload them again through Knossos? It seems to only be detecting the retail FS2 install and not the other stuff in that directory that I downloaded using FSOInstaller.

 
Re: Can't get FSOInstaller, Knossos or WXlauncher to work properly on Linux Mint 21.
Knossos uses another mod metadata format, as far as I know, it is easiest to re-download everything.

 

Offline taylor

  • Super SCP/Linux Guru
  • Moderator
  • 212
    • http://www.icculus.org/~taylor
Re: Can't get FSOInstaller, Knossos or WXlauncher to work properly on Linux Mint 21.
There is a more up-to-date knossos build available which should work with current Ubuntu versions. Grab it here: https://pxo.nottheeye.com/files/test/knossos/knossos_0.15.0-dev+73b131a_all.deb