Author Topic: Knossos Joystick Issues  (Read 562 times)

0 Members and 1 Guest are viewing this topic.

Knossos Joystick Issues
I have tried everything I can to get Knossos to reconize my joystick and throttle. There are times in which it will have one work, but not the other, change between which works. The numbering between the two (joy 0, joy 1, joy 2) changes between them and my mouse. I cannot figure out any pattern or logic to this. I was able to use JoyToKey, but that was a crutch since it fails to support axis data and only keys. I was hoping to use my throttle and buttons on it as well as my joystick.

If only plug in my joystick then select it in Knossos then start the game it works. But if I plug in my throttle it overrides my joystick, taking it's place as joy 1 and killing my joystick in game. Of course I cannot unplug either with the game running due it causing a crashing.

If I select my joystick as joy 0 and throttle as joy 1 in Knossos only my mouse and throttle work, but the throttle shows up as joy 2 and mouse as joy 0.

I have also looked into SDL2.dll that was referred to in a couple topics, but mismatching it throws errors for Knossos. I resolved those by reinstalling Knossos to get the old files back.

I looked into fs_open.ini as well, but only added to the confusion since it looks like the game skips over one of my joysticks at all times no matter what I changed for their reference IDs..

Any suggestions are how to get Knossos to work with my joy and throttle would be appreciated.

https://fsnebula.org/log/644cbf22f880738157b2e1b1

 

Offline wookieejedi

  • 29
  • Intensify Forward Firepower
Re: Knossos Joystick Issues
If you want more rapid back and forth help I might recommend asking on the Discord for Knossos here: https://discord.gg/jzdXGrT

Overall, there is also a setting in the game Options menu (same screen as difficulty settings) that allows you to separate Mouse and Joy 0, so perhaps you could give that a try, too?

 
Re: Knossos Joystick Issues
I have tried messing with the in game setting for mouse and joy 0. It just makes the game thing my mouse is joy 0, my throttle as joy 1, and my joystick as just gone. It shifted my mouse from being defined as mouse to joy 0.