General FreeSpace > Multiplayer

"Hacked tables" strike again

<< < (2/2)

Heh, looks like it won't be so easy. :blah: Basically, me and my friend just can't see each other's games on game list screen. Both on 'FSU Media VPs 4.4' mod and retail FS2 (launched via knossos). We see each other in lobby, but hosted  games (no matter who is the host) are not visible.

We tried both 'FSO 21.0.0' and  'FSO MPBETA 1.1.0' builds (with FSU Media VPs) but with no success.
Also, we tried to play a non-PXO multi using our IP adresses - still nothing. We can chat on lobby, nothing appears on the game list.
Is it the same reason as on 'original' PXO, when only some ppl were able to host without port-forwarding-magic tricks? If you suspect/know the problem, (and, hopefully, solution  ;)), we will be glad for any help. Of course we will share the times and dates when we're gonna play, so maybe we can fly some big juicy 8-players co-ops (ToF, Vegas). :cool:

Also, I have one more strange problem - I installed mods 'FreeSpace 2 Multiplayer Coop Up' & 'War Games', but they just won't launch. When I click 'Play', Knossos displays 'FSO is launching' for one second, then 'FSO is running' for another, then just nothing happens. :wtf: When I check "FSO Setting" for those mods, I see only the build (FSO MPBETA 1.1.0) - 'Custom flags' and 'Full command line' fields are all empty. If I chose the same build (FSO MPBETA 1.1.0) for FSU Media VPs, the game starts and works normally, and the standard set of 'custom flags' and 'full command' line is there. But this is secondary problem - I'm going to reinstall the whole game today and see if it persists. 

Whenever possible the port-forwarding magic tricks are done automatically now. At least in your case that's not the issue though. It looks like you are behind carrier-grade NAT, which we simply can't do anything about. Your IP address and port number changes on nearly every connection so there is no way for you to host a game server. Your best bet would be to connect to someone else's standalone server and host a game that way.

Assuming that your friend is c914, the games they started all failed a connectivity test. It's not obvious that they are behind carrier-grade NAT like you are so it's possible that it's simply a firewall/port-forwarding issue. Their mulit.log file should have some information about whether or not the automatic port-forwarding was working or not. It is only automatic if the person has NAT-PMP/PCP/UPnP (depending on router) enabled in their router however.

Thank you for your answer. I feel déjà vu from 2001-2003, when me and some of my squadron mates were sitting on lobby like beggars, waiting for someone with host capability to appear. Seems my luck with internet service providers remained the same after all these years. :rolleyes:

I will ask c914 to host a game and check multi.log, but I am afraid that the story will be similar as with mine. Today we'll probably do one more try with the game .exe whitelisted on every firewall/antivir we use and see if it helps.

Multiplayer schedule topic looks dead and outdated, so I am thinking about posting new one to see if we can find a volunteer able to host game or set up a standalone.

There tends to be a few standalones running but I believe all of them are down at the moment. I'll ask around and see if we can get something set up.

The new SquadWar is currently in testing so once it's ready perhaps there will be a bit more interest in multi, or at least a few more regular players.


[0] Message Index

[*] Previous page

Go to full version