Community Projects > The FreeSpace Campaign Restoration Project

Updating Knossos mods to more recent MediaVP versions

(1/4) > >>

Mongoose:
One downside to how Knossos manages mod packages is that users may wind up with multiple versions of common packages such as the MediaVPs and FSPort installed at the same time. Given the ever-increasing file sizes of some of these packages, this can essentially lead to many gigabytes' worth of duplicated data across separate versions, and a user may need to have a particular older version of them installed just for the sake of one or two campaigns that haven't been updated since being added to Knossos. In addition, users won't be able to apply the updated models, textures, and effects added to newer MediaVP versions to these older campaigns. Per discussion on Discord, it may be that some of these older campaigns would run just fine on the newest version of these common packages, or at the very least require some simple (and hopefully one-time) table updates. Mjn.mixael made the suggestion of forcing these mods to the most recent MediaVPs, and then using the F3 ship lab to see if any models triggered errors, since that would catch some of the most common and easily-fixable issues. Obviously some more complex mods would require more technical expertise, but at least this would be a start, and hopefully upgrading these mods would eliminate the need to keep one or two of the oldest common mod versions installed and save everybody some drive space.

So here's what I'm proposing: for those of us who have some of these older campaigns installed and don't mind tinkering a bit, force one of them to use the most recent MediaVPs/FSPort versions (by editing the dependencies in the mod.json file, unless you feel like creating your own separate mod entry in Knossos). See if it will still run, then check the F3 lab and see what models trip up FSO. We can use this thread to keep track of what breaks where, and hopefully find some fixes for them. I'll edit links to posts about specific mods into the OP in an attempt to keep things organized.

-Joshua-:
Since a couple of people have asked: The upcoming Blue Planet update will switch the mod to the latest MVP version.

0rph3u5:
Did they fix the issue that Knossos requires exact matches for the package names?

EatThePath:

--- Quote from: 0rph3u5 on August 30, 2022, 04:23:54 am ---Did they fix the issue that Knossos requires exact matches for the package names?

--- End quote ---
How exactly does that issue arise, and how in the world would allowing anything else work?

Mongoose:
To be clear, this thread has nothing to do with making any changes to Knossos itself. It's intended to see what campaign dependencies can be tweaked to hopefully eliminate the need to have very old versions of the MediaVPs installed.

Navigation

[0] Message Index

[#] Next page

Go to full version