Author Topic: Mission 07  (Read 760 times)

0 Members and 1 Guest are viewing this topic.

Hi,

i played through missions 1-6 without problems, now ill get an error saying Mission 7 couldnt be loaded.

What can i do?

 

Offline starbug

  • 210
    • DarkSide Animations
What is the exact error message or can you post the debug log?
http://www.youtube.com/user/AnubisX1

if there is any consistancy with the Shivans, it's their lack of consistancy - -Norbert-

 
The exact error message is "Attempt to load the Mission failed."

No debug log found after the error.

 

Offline Trivial Psychic

  • 212
  • Snoop Junkie
Try loading it with a debug build.  That should reveal the source of the problem, but you may be forced to sift through a number of unrelated warnings about things that debug builds are picky about, but that won't prevent the mission from running.
The Trivial Psychic Strikes Again!

 
Try loading it with a debug build.  That should reveal the source of the problem, but you may be forced to sift through a number of unrelated warnings about things that debug builds are picky about, but that won't prevent the mission from running.

How can activate this debug-build? im using Knossos.

 
Nevermind, ive found it.

Getting this as Message:

Warning: Error in mission event: "Start fakebombing": Invalid waypoint.

In sexpression: ( when-argument
   ( any-of
      "Delta 1"
      "Delta 2"
      "Delta 3"
      "Delta 4"
      "Beta 1"
      "Beta 2"
      "Beta 3"
      "Beta 4"
      "Gamma 1"
      "Gamma 2"
      "Gamma 3"
      "Gamma 4"
   )
   ( and
      ( or
         ( is-facing
            "<argument>"
            "Cyrus#1"
            60
            2500
         )
         ( is-facing
            "<argument>"
            "Merit"
            60
            2500
         )
         ( is-facing
[...]

(Bad node appears to be: Cyrus)

File: missionparse.cpp
Line: 6150

 

Offline Goober5000

  • HLP Loremaster
  • 214
    • Goober5000 Productions
Fixed in Knossos.  I'll fix it in SVN as well as soon as I get the repository downloaded to my new machine.

 
Fixed in Knossos.  I'll fix it in SVN as well as soon as I get the repository downloaded to my new machine.

As said in discord: Thank you Goober5000, now it works well.

Have good 2022 in a few days.