Hard Light Productions Forums

General FreeSpace => FreeSpace & FreeSpace Open Support => Topic started by: SkycladGuardian on January 26, 2014, 02:18:16 pm

Title: FSPort with MediaVPs_2014: Lots of Warnings
Post by: SkycladGuardian on January 26, 2014, 02:18:16 pm
I did a fresh install of FS2, downloaded the new MediaVps, the FSPort 3.4 files and Macfie's unofficial patch.
When I start the mod I get a warning, that the mod has produced 70 warnings, so I ran a debug build. The warnings are in the attachement.
The fs2_open log is an unformatted mess, but I'll attach it for completeness' sake.
So has anyone an idea what could cause these warnings? Thanks in advance. :)

[attachment deleted by an evil time traveler]
Title: Re: FSPort with MediaVPs_2014: Lots of Warnings
Post by: General Battuta on January 26, 2014, 02:29:27 pm
Debug logs have gotten so ****ing long. We need to do something to clean out the cruft.

Are you sure you've got Macfie's patch installed? If it's a VP file I don't see it.
Title: Re: FSPort with MediaVPs_2014: Lots of Warnings
Post by: SkycladGuardian on January 26, 2014, 02:36:46 pm
The patch is a tbm file and it's located in "fsport-mediavps\data\tables\"
Here's a link to Macfie's thread: http://www.hard-light.net/forums/index.php?topic=86514.0
Title: Re: FSPort with MediaVPs_2014: Lots of Warnings
Post by: mjn.mixael on January 26, 2014, 03:43:07 pm
Debug logs have gotten so ****ing long. We need to do something to clean out the cruft.

Are you sure you've got Macfie's patch installed? If it's a VP file I don't see it.

That's why I made this. (http://www.hard-light.net/forums/index.php?topic=84905.0) Have you tried it? Helps to make log sniffing a bit easier by marking out anything that's actually relevant to mod debugging.
Title: Re: FSPort with MediaVPs_2014: Lots of Warnings
Post by: Macfie on January 26, 2014, 05:07:29 pm
You are missing the MV_Effects file from the MediaVPs_2014 folder.  That is probably causing your errors.
Title: Re: FSPort with MediaVPs_2014: Lots of Warnings
Post by: SkycladGuardian on January 27, 2014, 02:15:07 pm
Ah, stupid me. I thought I had all the files. Thanks for the heads-up!