Hard Light Productions Forums

General FreeSpace => FreeSpace & FreeSpace Open Support => Topic started by: Caligma on January 14, 2015, 09:01:55 pm

Title: Error Messages
Post by: Caligma on January 14, 2015, 09:01:55 pm
I downloaded Freespace 2 via GOG and did not install it until I downloaded the Freespace Open Installer. Once I had the installer downloaded, I installed it using the zip Freespace 2 file from GOG. Everything downloaded just fine, except for the MV_RadarIcons, which I had to install separately. Once I had everything, I clicked on the launcher that looks like a dog paw. When I clicked on it, I got this Fatal Error Message "Failed EnumAdapterModes in UpdateAntialiasList". I clicked okay and the launcher appears (FS2 Open Launcher 5.5g). I followed all of the instructions listed and when I went to the graphics section, the only option is OpenGL. If I clicked okay or apply, it gives me this message "Failed to set graphic mode".

Not really sure what else to do at this point.
Title: Re: Error Messages
Post by: AdmiralRalwood on January 14, 2015, 09:14:29 pm
I downloaded Freespace 2 via GOG and did not install it until I downloaded the Freespace Open Installer. Once I had the installer downloaded, I installed it using the zip Freespace 2 file from GOG. Everything downloaded just fine, except for the MV_RadarIcons, which I had to install separately. Once I had everything, I clicked on the launcher that looks like a dog paw. When I clicked on it, I got this Fatal Error Message "Failed EnumAdapterModes in UpdateAntialiasList". I clicked okay and the launcher appears (FS2 Open Launcher 5.5g). I followed all of the instructions listed and when I went to the graphics section, the only option is OpenGL. If I clicked okay or apply, it gives me this message "Failed to set graphic mode".

Not really sure what else to do at this point.
The "Failed EnumAdapterModes" error is harmless, but if you want a launcher that doesn't have known, irrelevant error messages you can try wxLauncher.

As for the other error, you might want to try running the launcher as an administrator to make sure it can set the registry settings properly.
Title: Re: Error Messages
Post by: Caligma on January 14, 2015, 09:40:58 pm
I used the wxLauncher. Much better! But now I get this error:

Error!

mv_effects-sdf.tbm(line 16):
Error: Required Token - [#END] or [$Species_Name:], found [$Countermeasure
Type:         Type One].

ntdll.dll! NtWaitForSingleObject + 12 bytes
KERNELBASE.dll! WaitForSingleObject + 18 bytes
fs2_open_3_7_0.exe! <no symbol>
fs2_open_3_7_0.exe! <no symbol>
fs2_open_3_7_0.exe! <no symbol>

[ This info is in the clipboard so you can paste it somewhere now ]


Use Ok to break into Debugger, Cancel to exit.
Title: Re: Error Messages
Post by: Caligma on January 14, 2015, 10:08:50 pm
Btw, I was using the MediaVPs 2014 when I received that error. I tried the MediaVPs 3.6.12 and I did not receive that error.
Title: Re: Error Messages
Post by: niffiwan on January 14, 2015, 10:21:26 pm
For MediaVPs 2014 you need Freespace Open 3.7.2 RC4.  This is available in the installer, once you've downloaded it you just need to select the new executable in the launcher.
Title: Re: Error Messages
Post by: Caligma on January 14, 2015, 10:48:46 pm
outstanding pilot! It worked.

And thanks to everybody that put this together. What a fricken fantastic job the graphics, mods, everything is.