Hard Light Productions Forums

Announcements => Getting Started => Topic started by: GD10 on October 27, 2016, 02:13:18 am

Title: Freespace Open Issue
Post by: GD10 on October 27, 2016, 02:13:18 am
Hello Freespace Community ! I've recently installed Freespace 2 ( GOG version) and tried to install and run Freespace Open...
So I downloaded Java, ran the package normally ( well almost, since 2 campaigns wouldnt install no matter what) and tried to run the game with the FSOpen launcher. But everytime I try to run it, it returns me an error : alcGetString couldnt be found in fs2_open_3_7_0.exe.

I tried running the exe fs2_open_3_7_0 manually, but the same error persists. ..

How can I fix this ?

My system runs on Windows 10.

Thanks in advance !
Title: Re: Freespace Open Issue
Post by: AdmiralRalwood on October 27, 2016, 02:59:52 am
fs2_open_3_7_0.exe
...How did you get a version as outdated as 3.7.0 from the installer? It hasn't been in the download list since 3.7.2 was released, let alone 3.7.4...

Which launcher are you using, wxLauncher or Launcher.exe from the FS2 folder? Do you have OpenAL installed?
Title: Re: Freespace Open Issue
Post by: GD10 on October 27, 2016, 10:53:12 am
I got all versions installed by Freespace Open , all with their respective DEBUG exe. So i have  3.7.0, 3.7.2, 3.7.4 SSE, SSE2 and AVX installed, but the error from the wxlauncher specifies version 3.7.0...^

Yes I've installed OpenAL.
Title: Re: Freespace Open Issue
Post by: GD10 on October 27, 2016, 10:58:47 am
Oh and something else. When I use the yal_launcher.exe and change the fs2_open.exe, i get these errors in particular :

3.7.0 - alcGetString not found
3.7.2WIN9X.exe - alclsExtensionPresent not found
3.7.4 - alSource3i not found
3.7.4 AVX.exe - alSource3i not found
3.7.4 SSE.exe - alSource3i not found
3.7.4 SSE2.exe - alsource3i not found

Hope this helps
Title: Re: Freespace Open Issue
Post by: jr2 on October 29, 2016, 06:48:22 am
Select the 3.7.4 exe in the launcher
Title: Re: Freespace Open Issue
Post by: GD10 on October 29, 2016, 09:16:34 am
I run the wxlauncher and select 3.7.4, but the error persists... It cant find entry point alSource3i in DLL fs2_open_3_7_4.exe.

Its beginning to annoy me . SInce I thought it was an outdated/faulty OpenAL and uninstalled/reinstalled it... but still no improvement  :mad:
Title: Re: Freespace Open Issue
Post by: jr2 on October 29, 2016, 02:45:54 pm
Try running wxlauncher in administrator mode once   (shot in the dark)

If that doesn't work, delete the fs2_open exes and re-download them (jut re-running the installer should work, it will detect what you already downloaded and what's missing)
Title: Re: Freespace Open Issue
Post by: niffiwan on October 30, 2016, 02:51:51 am
You could also try installing OpenALSoft for both wxLauncher & FSO using the details in the thread here:
http://www.hard-light.net/forums/index.php?topic=85640.0
Title: Re: Freespace Open Issue
Post by: GD10 on October 30, 2016, 04:36:47 am
Thank you Niffiwan FOR the Tip with the thread. Worked like a charm. Now i Can enjoy fs2 in All its glory.
Thanks everyone !