Author Topic: CTD in M07 w/INF_SCP-HTL  (Read 2283 times)

0 Members and 1 Guest are viewing this topic.

Offline Trivial Psychic

  • 212
  • Snoop Junkie
CTD in M07 w/INF_SCP-HTL
Howdy:

I'd decided to do another once-through of the Inferno R1 campaign, before resuming my own project.  Now last time, I started out with the INF SCP build, but this was pre-HTL, so I quickly reverted to standard FS2 to play it through.  This was partially due to difficulties that I've now narrowed down to my video drivers (now overcome), and then to the performance drain on my less-than-average system.  With HTL now more stable, and acting as a preformance boost, I decided to do a second run with the latest INF-SCP build.  Everything was going well until M7, when there's the face-off between the Diablo, Kismat, and Independance (I forget the mission name).  There's a point in the mission when you've knocked out the Gorgon fighters and you and your fellow surviving wingmen and bombers are in close on the Diablo's main gun, and are trying to knock it out.  I hear the friendly arrival music, followed by a freeze for nearly a complete second, before the game crashes to the desktop.  The only warning message I ever get is in regards to dlhelp causing a problem in , but its hardly explanitory.

Now, I tried opening the mission in the debug version, but it won't even get to the pilot selection screen before shutting down... debug builds never seem to work on my system.  Anyway, I then decided to open it in the latest FRED_inf version.  Before the program even loaded up, I was met with several model, weapon, and background error messages, as this is based on the new version of FRED_open with the error messages, and the Inferno team as recently mentioned having to fix several errors in its models for the upcoming combined release of R1.1 & R2.  Anyway, I focused on the error messages that presented themselves when I opened up the actual mission, hoping that one of them would be the culprit.  I managed to repair a few of these errors, by renaming the communications subsystem on the Danus bomber, and adding fighterbay subsystems on the Olemus dreadnaught, (or was it a superdestroyer, whatever), but I couldn't trace the problems on the Warlock with turrets 36 & 37 (there are 39 turrets on the model, and 41 in the tables... any help?), or with the missing LOD on the Durja, but I was hoping that the fixes I'd implimented, would solve the CTD problem.  Unfortunately, these did not prevent the CTD, so I am at a loss.  Is there anything that anyone on or off the team can contribute?

Later!
The Trivial Psychic Strikes Again!

 
This happened to me as well.
I played normal fs2 to pass this mission no other mission gave me any trouble.
"What does not kills me, makes me stronger!" -Nietzche

There is no peace, there is Anger;

There is no fear, there is Power.

There is no death, there is immortality;

There is no weakness, there is the Dark Side.

 

Offline Woomeister

  • Infyrno Missile
  • Moderator
  • 213
    • Inferno SCP
CTD in M07 w/INF_SCP-HTL
The warlock does have 41 turrets...

If it's the friendly arrival music then it could be a problem with a specific ship class as it arrives.

Try checking the 'disallow support ships' box to see if its the Eos, if it isn't it could be one of the SOC ships.


R1 wasn't tested on FS Open so I gave no guarantees it would work :D

 

Offline J3Vr6

  • 28
CTD in M07 w/INF_SCP-HTL
I used Phreak's inf_build that's in his signature and was able to play the campaign straight thru.
"I wanna drink til I'm drunk, and smoke til I'm senseless..."
-Tricky

"Hey barkeep, who's leg do I have to hump to get a dry martini around here?"
-Brian, Family Guy

 

Offline Trivial Psychic

  • 212
  • Snoop Junkie
CTD in M07 w/INF_SCP-HTL
Quote
Originally posted by Woomeister
The warlock does have 41 turrets...


Then why does modview only show 0 though 38 (therefore 39 turrets)?

Quote
Originally posted by Woomeister
If it's the friendly arrival music then it could be a problem with a specific ship class as it arrives.

Try checking the 'disallow support ships' box to see if its the Eos, if it isn't it could be one of the SOC ships.


It shouldn't be the support ships, since they work in other missions.

Later!
The Trivial Psychic Strikes Again!

 

Offline Goober5000

  • HLP Loremaster
  • 214
    • Goober5000 Productions
CTD in M07 w/INF_SCP-HTL
I ran into this too.  Mantis it.  If it works with retail and not with fs2_open, it's a bug.

We'd appreciate help in tracking it down, though. :)

 

Offline Trivial Psychic

  • 212
  • Snoop Junkie
CTD in M07 w/INF_SCP-HTL
I was just looking through the mission when I came across something which may be the culprit.  Most of the Terran fighter wings have initial orders such as attacking the main gun and a reactor of the Diablo.  Some of these wings also have the initial orders to warp, which is unusual.  In most cases, all 3 of these orders have a 50 priority rating.  Only one friendly fighter ( or bombers, I'm not sure) wing has an arrival time other than true, and it is supposed to arrive when a certain percentage of a couple of friendly wings have been destroyed.  This wing also has the initial order to warp.  Could this inital order to warp on an arriving wing be the culprit for this crash, since it always triggers right after a friendly arrival?

I'm gonna remove this initial order for these wings and see what happens.  I'll get back to you with the results.

While I've got you, I made some "repairs" to a few of the models, ie renaming a subsystem to match with what the table says.  I've also repaired some of the table entries, removing subsystems, turrets, gunbanks, basically whenever FRED complained about something that I could fix, I fixed it.  If somone like Phreak could host these fixed-up files, I'd be willing to send 'em your way... unless you guys consider R1 like a lost cause at this point.


Well, that didn't work.  It may have something to do with the SOC Gamma and Delta wings which were keyed to arrive after about 2 min. 48 seconds near alpha 1.  I noticed that they (and a few other wings) had their orders tagged to each individual fighter in the wing, rahter than to the wing as a whole.  I've changed these and saved the mission.  When I get off the phone with my girlfriend I'll test it.  I also managed to stop FRED complaining about the Warlock .  I checked in the ships editor and turrets 36 and 37were missing, so I decided to comment them out of the tables.  After doing that, I openned the mission in FRED and it stopped complaining.  Weird eh?


Well, I've definitely narrowed the problem down to either Delta or Gamma wing, flying SOF Ophions. The CTD lines up precisely with the wings' scripted arrival time. I tried to adjust the arrival anchor and the expression method for the arrival time, but to no avail. I've now tried to link their arrival time to an "is-destroyed-delay" sexp rather than the previous "true" with mission time listed above. I also separated the 2 wings' arrival times apart by a few seconds to hopefully find out which one is the culprit. Just incase its relevant, these wings are armed with the Luyten D-9 primary and the Vortex missiles, which hadn't seen usage yet, so they may play a role in the problem.

Later!
« Last Edit: March 02, 2004, 10:56:13 pm by 1268 »
The Trivial Psychic Strikes Again!

 

Offline Woomeister

  • Infyrno Missile
  • Moderator
  • 213
    • Inferno SCP
CTD in M07 w/INF_SCP-HTL
Try changing those fighters from the Ophion to either the Horae or Banshee and see if that fixes it.

At the moment for the next release, the new FRED error system gives out 0 warnings on startup, and we get only a few errors using a debug INF build.

As for R1, we'll still support missions, campaigns and mods that want t use it, however there will most likely be no more releases by us for it.

 
CTD in M07 w/INF_SCP-HTL
Actually the Warlock DOES only have 39 turrets, turret36 and turret37 don't exist as submodels. This is fixed in our current tables though.

 

Offline Woomeister

  • Infyrno Missile
  • Moderator
  • 213
    • Inferno SCP
CTD in M07 w/INF_SCP-HTL
yeah but turret 41 does exist on the model.

  

Offline mr.WHO

  • 29
I run a subspace mission few minutes ago and somethig is wrong with subspace background I see weard things, stripes and when I target something, backgroud become totaly black
I use your INF_buind and normal fs2_open.
Anybody have the same problem??
« Last Edit: March 07, 2004, 02:06:50 am by 1471 »