Author Topic: LAN=broken, known issue?  (Read 4683 times)

0 Members and 1 Guest are viewing this topic.

Offline Goober5000

  • HLP Loremaster
  • Moderator
  • 214
    • Goober5000 Productions
Yeah, but it's not likely to get fixed any time soon.  It would require a significant amount of rework to keep track of ammunition and so forth.

 
ouch........

ok, how bad is any time soon?
just another newbie without any modding, FREDding or real programming experience

you haven't learned masochism until you've tried to read a Microsoft help file.  -- Goober5000
I've got 2 drug-addict syblings and one alcoholic whore. And I'm a ****ing sociopath --an0n
You cannot defeat Windows through strength alone. Only patience, a lot of good luck, and a sledgehammer will do the job. --StratComm

 

Offline Goober5000

  • HLP Loremaster
  • Moderator
  • 214
    • Goober5000 Productions
I honestly don't know. ;) I'd have to take a good look at the multiplayer code after 3.6 is released.  It's not a huge priority for me either.  It may get done in six months, it may get done in a year, or it may never get done.  Or someone else might do it.  I can't give you an estimate.

 
ok.

prehaps a better error message is less work? this might break up quite a few people wanting LAN play with cool new features.
just another newbie without any modding, FREDding or real programming experience

you haven't learned masochism until you've tried to read a Microsoft help file.  -- Goober5000
I've got 2 drug-addict syblings and one alcoholic whore. And I'm a ****ing sociopath --an0n
You cannot defeat Windows through strength alone. Only patience, a lot of good luck, and a sledgehammer will do the job. --StratComm

 

Offline Inquisitor

Better error message would be a good work around.

This should go into the FAQ for now though.
No signature.

 
how nice.

i tested this without LS's effects, just using the MediaVP shinemaps, glowmaps and nebulae's, and it won't work. same error.
just another newbie without any modding, FREDding or real programming experience

you haven't learned masochism until you've tried to read a Microsoft help file.  -- Goober5000
I've got 2 drug-addict syblings and one alcoholic whore. And I'm a ****ing sociopath --an0n
You cannot defeat Windows through strength alone. Only patience, a lot of good luck, and a sledgehammer will do the job. --StratComm

 

Offline Goober5000

  • HLP Loremaster
  • Moderator
  • 214
    • Goober5000 Productions
Try just removing the nebulas.

 
i will, tomorow.
just another newbie without any modding, FREDding or real programming experience

you haven't learned masochism until you've tried to read a Microsoft help file.  -- Goober5000
I've got 2 drug-addict syblings and one alcoholic whore. And I'm a ****ing sociopath --an0n
You cannot defeat Windows through strength alone. Only patience, a lot of good luck, and a sledgehammer will do the job. --StratComm

 
that was grand.......

i disabled the neb vp (changed extension to vpDISABLED) and run multi. the computers won't see eachothers games whatever i do. just nothing shows up in the list. i try some other stuff, still naught. i enable the VP and still nothing.

so basicly, things got a lot worse, without even changing builds.
just another newbie without any modding, FREDding or real programming experience

you haven't learned masochism until you've tried to read a Microsoft help file.  -- Goober5000
I've got 2 drug-addict syblings and one alcoholic whore. And I'm a ****ing sociopath --an0n
You cannot defeat Windows through strength alone. Only patience, a lot of good luck, and a sledgehammer will do the job. --StratComm

 

Offline taylor

  • Super SCP/Linux Guru
  • Moderator
  • 212
    • http://www.icculus.org/~taylor
kasperl, if you are using my 04/05 build than try the new one that Goober500 put out or my 04/01 build.  The 04/05 build is based on the Linux tree and has a lot of networking changes to support PPC.  It looks like there may be a bug in the code where it doesn't form a JR packet correctly but does process incoming packets correctly.  In other words it would work on the server end but not the client.  I would recommend not using that build for either though and try the 04/26 build instead.  If this does fix the problem then please let me know so that I can rework multimsgs.cpp and get this working again.

 
ok, i will check.
just another newbie without any modding, FREDding or real programming experience

you haven't learned masochism until you've tried to read a Microsoft help file.  -- Goober5000
I've got 2 drug-addict syblings and one alcoholic whore. And I'm a ****ing sociopath --an0n
You cannot defeat Windows through strength alone. Only patience, a lot of good luck, and a sledgehammer will do the job. --StratComm

  
LAN=broken, known issue?
ok, using Goobs build it won't work, because of the interface error (clicking commit gives me the help screen), but a home made compile from CVS (this morning) worked fine.
just another newbie without any modding, FREDding or real programming experience

you haven't learned masochism until you've tried to read a Microsoft help file.  -- Goober5000
I've got 2 drug-addict syblings and one alcoholic whore. And I'm a ****ing sociopath --an0n
You cannot defeat Windows through strength alone. Only patience, a lot of good luck, and a sledgehammer will do the job. --StratComm