Author Topic: Engine Failure  (Read 3007 times)

0 Members and 1 Guest are viewing this topic.

Well, it happens with the bundle in the installer too.
And I'm at a 100%

 
I've had somthing similar:

Sometimes when I try to warp out (retail and MOD) I get that twittering noise and "Subspace drive engaged" up.  
Then the warpout sequence stops with the 'warpout aborted' message.  
Sometimes it doesn't even get so far as making the key press noise.
I'm not under fire, not about to crash into something - sometimes it even goes when I'm on my own; not another object in the mission.

So not the same, but related, perhaps?
#Bal kote, darasumm knte,
  Jorso'ran kando a tome,
  Sa kyr'am Nau tracyn kad, Vode an#

 - Traditional Mandalorian war chant

 

Offline Goober5000

  • HLP Loremaster
  • Administrator
  • 214
    • Goober5000 Productions
Mantis it and I'll take a look.

 
I've posted the bug on Mantis.

 

Offline Bobboau

  • Just a MODern kinda guy
    Just MODerately cool
    And MODest too
  • 213
I'm thinking it's a bug in ship_get_subsystem_strength somehow
Bobboau, bringing you products that work... in theory
learn to use PCS
creator of the ProXimus Procedural Texture and Effect Generator
My latest build of PCS2, get it while it's hot!
PCS 2.0.3


DEUTERONOMY 22:11
Thou shalt not wear a garment of diverse sorts, [as] of woollen and linen together

 

Offline Antares

  • 28
  • Author of The Shivan Manifesto
I'm using 3.6 and didn't run into this problem until "... But Hate the Traitor".  I assume it's because subspace jumps are disabled at the beginning of the mission--if you try to leave, the NTF fighters just mock you and are all like "ALL YOUR JUMP CODES ARE BELONG TO US".  Normally, you should be able to jump out when Command gives you clearance at the end of the mission, but my engines still fail.
We have returned to continue our purification of this galaxy. It is again your turn to be crushed beneath the great force that is the Antaran army. All your petty squabbling with the other beings in this galaxy is meaningless. The Antaran fleet will destroy you all, one by one. You may not surrender. You cannot win. Your only option is death.

 
I was curious about this and with my build straight out of the CVS I don't seem to have this problem.  Even with all the Imperial Alliance stuff added to 3.6 I don't seem to have this problem.

 
One little question: What directx runtime are you using?

 

Offline ViRGE

  • 24
A possible temporary solution: make sure your difficulty setting is at Easy or higher(i.e. don't use Very Easy). Phreak says that the jump code will only allow you to jump if your engine health is above 30%, and the difficulty is above Very Easy, and after testing this theory, Very Easy seems to be causing the jump out problem.

 
I've just checked it out. Phreak is correct.

 

Offline Silent Warrior

  • 27
  • My thoughts go where no one knows to tread.
This has got to be the weirdest problem/work-around I've ever heard of... Difficulty-level?? Heh, trippppppyy! *Sigh* Oh well, I guess I'll just have to try to learn to fly without training-wheels now. Poor me. :)
I can't go home again until I find a stone a rose a door.
Choo choo, and that is the truth.

 
That is odd, if you ask me.....
just another newbie without any modding, FREDding or real programming experience

you haven't learned masochism until you've tried to read a Microsoft help file.  -- Goober5000
I've got 2 drug-addict syblings and one alcoholic whore. And I'm a ****ing sociopath --an0n
You cannot defeat Windows through strength alone. Only patience, a lot of good luck, and a sledgehammer will do the job. --StratComm

 
Odd is right

 
Actually I didn't realize that I had it on 'easy' instead of 'very easy'.  Turning it back to 'very easy' I get the engine failure problem as well.

  

Offline WMCoolmon

  • Purveyor of space crack
  • 213
See my post in recent builds, it should fix the prob for builds.

All future builds will have the fix, I've commited it to CVS.
-C