Author Topic: Solutions to common problems  (Read 1606 times)

0 Members and 1 Guest are viewing this topic.

Offline Shade

  • 211
Solutions to common problems
Some solutions to common problems that I've seen crop up a lot recently. Note that these cover only the most common reasons for the problems mentioned, so they may not always work. But these solutions should at least be tried before requesting further help. So, without further delay, The List:

Problem: The game crashes on startup.
Likely cause: Can be many things, but the most likely cause is a dodgy or missing OpenAL installation, or an incorrect sound configuration in the launcher.
Solution: First, start the launcher and go to the "Audio/Joystick" tab. There, make sure that "Generic Software" is selected as your OpenAL sound device. If that doesn't fix it, check your "windows\system32" directory for files called "ct_oal.dll" or "nvopenal.dll", and delete them if you find them. Then get the latest OpenAL installer Here and install that.

Problem: There are black boxes around laser bolts and other in-game effects.
Likely cause: Outdated MediaVPs and/or missing MediaVP patches.
Solution: Delete the contents of your mediavps directory, then go to This Thread and download newest MediaVPs as well as the appropriate patches and place them in the mediavps directory instead.

Problem: I can't see any asteroids AND Some of the ships are missing textures/have big holes in them.
Likely cause: JPEG and TGA textures haven't been enabled.
Solution: Start the launcher, go to the "Features" tab, and in the list of graphics flags make sure that the box labelled "Enable jpg/tga textures" is checked.

Problem: I installed a mod, but it is not showing up in-game.
Likely cause: You haven't selected it in the launcher.
Solution: Start the launcher, then go to the "MOD" tab and click "Select MOD". From the list that appears, select the mod you want to play.

Problem: My game doesn't look as good as the screenshots.
Likely cause: MediaVPs haven't been selected and/or your game is set up to have too much ambient light.
Solution: Start the launcher, then go to the MOD tab and click "Select MOD". Pick "mediavps" from the list that appears. Further, if the game is too bright you can go to the "Features" tab of the launcher and add the lines "-no_emissive_light" and "-ambient_factor 75" to the Custom Flags box. 75 is just an example, for best effect it should be tweaked lower or higher as needed depending on your monitor's brightness.
Report FS_Open bugs with Mantis  |  Find the latest FS_Open builds Here  |  Interested in FRED? Check out the Wiki's FRED Portal | Diaspora: Website / Forums
"Oooooooooooooooooooooooooooooooooooooooh ****ing great. 2200 references to entry->index and no idea which is the one that ****ed up" - Karajorma
"We are all agreed that your theory is crazy. The question that divides us is whether it is crazy enough to have a chance of being correct." - Niels Bohr
<Cobra|> You play this mission too intelligently.