Author Topic: connection failed in multiplayer  (Read 1365 times)

0 Members and 1 Guest are viewing this topic.

Offline sral

  • 21
connection failed in multiplayer
Hi I'm new here...

I've FS2 open (playing on 3.6.9 exe, with my german CD from 1998 hahaha) and I have some connection problems with the multiplaying...

afther following these instructions : http://www.hard-light.net/wiki/index..._Started_Guide

I try to open a multiplayer game by clicking on the Ready Room from the main hall.

An message is displayed: "connection failed"


I runned a 3.6.9 debug:

fs2_open debug log:

Code: [Select]
================================================== ========================
DEBUG SPEW: No debug_filter.cfg found, so only general, error, and warning
categories can be shown and no debug_filter.cfg info will be saved.
================================================== ========================
Passed cmdline options:
-missile_lighting
-ballistic_gauge
-orbradar
-rearm_timer
-targetinfo
-mod multimissions
Building file index...
Searching root 'C:\games\freespace2\multimissions\'
Searching root pack 'C:\games\freespace2\multimissions\multi-mission-pack.vp'
Searching root 'C:\games\freespace2\'
Searching root pack 'C:\games\freespace2\FS2OGGcutscenepack.vp'
Searching root pack 'C:\games\freespace2\multi-mission-pack.vp'
Searching root pack 'C:\games\freespace2\multi-voice-pack.vp'
Searching root pack 'C:\games\freespace2\root_fs2.vp'
Searching root pack 'C:\games\freespace2\smarty_fs2.vp'
Searching root pack 'C:\games\freespace2\sparky_fs2.vp'
Searching root pack 'C:\games\freespace2\sparky_hi_fs2.vp'
Searching root pack 'C:\games\freespace2\stu_fs2.vp'
Searching root pack 'C:\games\freespace2\tango1_fs2.vp'
Searching root pack 'C:\games\freespace2\tango2_fs2.vp'
Searching root pack 'C:\games\freespace2\tango3_fs2.vp'
Searching root pack 'C:\games\freespace2\warble_fs2.vp'
Searching root 'e:\'
Searching root pack 'e:\tango1_fs2.vp'
Searching root pack 'e:\tangoA_fs2.vp'
Searching root pack 'e:\warble_fs2.vp'
Found 19 roots and 7191 files.
AutoLang: Language auto-detection successful...
Setting language to German
Initializing OpenAL...
Using 'Generic Software' as OpenAL sound device...
OpenAL Vendor : Creative Labs Inc.
OpenAL Renderer : Software
OpenAL Version : 1.1

... OpenAL successfully initialized!
GR_CPU: Family 6, MMX=Yes
Initializing OpenGL graphics device at 1280x800 with 32-bit color...
Initializing WGL...
Requested WGL Video values = R: 8, G: 8, B: 8, depth: 24, double-buffer: 1
Actual WGL Video values = R: 8, G: 8, B: 8, depth: 24, double-buffer: 1
OpenGL Vendor : NVIDIA Corporation
OpenGL Renderer : GeForce 8200M G/PCI/SSE2
OpenGL Version : 2.1.2

Using extension "GL_EXT_fog_coord".
Using extension "GL_ARB_multitexture".
Using extension "GL_ARB_texture_env_add".
Using extension "GL_ARB_texture_compression".
Using extension "GL_EXT_texture_compression_s3tc".
Using extension "GL_EXT_texture_filter_anisotropic".
Using extension "GL_ARB_texture_env_combine".
Using extension "GL_EXT_compiled_vertex_array".
Using extension "GL_EXT_draw_range_elements".
Using extension "GL_ARB_texture_mirrored_repeat".
Using extension "GL_ARB_texture_non_power_of_two".
Using extension "GL_ARB_vertex_buffer_object".
Using extension "GL_ARB_pixel_buffer_object".
Unable to find extension "GL_APPLE_client_storage".
Using extension "GL_SGIS_generate_mipmap".
Using extension "GL_EXT_framebuffer_object".
Using extension "GL_ARB_texture_rectangle".
Using extension "GL_EXT_bgra".
Using extension "GL_ARB_texture_cube_map".
Using extension "GL_EXT_texture_lod_bias".
Found special extension function "wglSwapIntervalEXT".

Max texture units: 4
Max elements vertices: 1048576
Max elements indices: 1048576
Max texture size: 8192x8192
Can use compressed textures: YES
Texture compression available: YES
Using trilinear texture filter.
... OpenGL init is complete!
Size of bitmap info = 705 KB
Size of bitmap extra info = 40 bytes
ANI cursorweb with size 24x24 (25.0% wasted)
GRAPHICS: Initializing default colors...
SCRIPTING: Beginning initialization sequence...
SCRIPTING: Beginning Lua initialization...
LUA: Opening LUA state...
LUA: Initializing base Lua libraries...
LUA: Performing global function/(library/object) name repeat check...
LUA: Performing library/object name repeat check...
LUA: Performing object/object name repeat check...
LUA: Performing library/library name repeat check...
LUA: Initializing library functions...
LUA: Initializing object functions...
SCRIPTING: Beginning main hook parse sequence....
Wokka! Error opening file (scripting.tbl)!
Unable to parse scripting.tbl! Code = 5.
SCRIPTING: Inititialization complete.
Using high memory settings...
Wokka! Error opening file (interface.tbl)!
Unable to parse interface.tbl!
cf_get_file_list_preallocated looking for type=7, filter="*-sdf.tbm"
ANI 2_radar1 with size 170x170 (33.6% wasted)
Windoze reported 16 joysticks, we found 0
Current soundtrack set to -1 in event_music_reset_choices
cf_get_file_list_preallocated looking for type=7, filter="*-mus.tbm"
cf_get_file_list_preallocated looking for type=7, filter="*-mfl.tbm"
Wokka! Error opening file (armor.tbl)!
Unable to parse armor.tbl!
cf_get_file_list_preallocated looking for type=7, filter="*-amr.tbm"
cf_get_file_list_preallocated looking for type=7, filter="*-wxp.tbm"
cf_get_file_list_preallocated looking for type=7, filter="*-wep.tbm"
cf_get_file_list_preallocated looking for type=7, filter="*-aip.tbm"
cf_get_file_list_preallocated looking for type=7, filter="*-obt.tbm"
cf_get_file_list_preallocated looking for type=7, filter="*-shp.tbm"
cf_get_file_list_preallocated looking for type=7, filter="*-hdg.tbm"
cf_get_file_list_preallocated looking for type=7, filter="*-str.tbm"
cf_get_file_list_preallocated looking for type=25, filter="*.pcx"
cf_get_file_list_preallocated looking for type=32, filter="*.pcx"
loading animated cursor "cursor"
ANI cursor with size 24x24 (25.0% wasted)
Ships.tbl is : VALID
Weapons.tbl is : VALID
cfile_init() took 254
MVE: Buffer underun (First is normal)
Got event GS_EVENT_GAME_INIT (49) in state NOT A VALID STATE (0)
cf_get_file_list_preallocated looking for type=29, filter="*.plr"
ANI cursor.ani with size 24x24 (25.0% wasted)
Got event GS_EVENT_MAIN_MENU (0) in state GS_STATE_INITIAL_PLAYER_SELECT (37)
ANI 2_mainwalk.ani with size 477x477 (6.8% wasted)
ANI 2_mainflyby.ani with size 189x189 (26.2% wasted)
ANI 2_maincrane.ani with size 116x116 (9.4% wasted)
ANI 2_mainexit.ani with size 174x174 (32.0% wasted)
ANI 2_mainbarracks.ani with size 158x158 (38.3% wasted)
ANI 2_mainreadyroom.ani with size 145x145 (43.4% wasted)
ANI 2_maintechroom.ani with size 119x119 (7.0% wasted)
ANI 2_mainoptions.ani with size 206x206 (19.5% wasted)
ANI 2_maincampaign.ani with size 190x190 (25.8% wasted)
Got event GS_EVENT_OPTIONS_MENU (8) in state GS_STATE_MAIN_MENU (1)
Frame 0 too long!!: frametime = 0.333 (0.333)
Frame 0 too long!!: frametime = 0.323 (0.323)
Got event GS_EVENT_PREVIOUS_STATE (7) in state GS_STATE_OPTIONS_MENU (5)
ANI 2_mainwalk.ani with size 477x477 (6.8% wasted)
ANI 2_mainflyby.ani with size 189x189 (26.2% wasted)
ANI 2_maincrane.ani with size 116x116 (9.4% wasted)
ANI 2_mainexit.ani with size 174x174 (32.0% wasted)
ANI 2_mainbarracks.ani with size 158x158 (38.3% wasted)
ANI 2_mainreadyroom.ani with size 145x145 (43.4% wasted)
ANI 2_maintechroom.ani with size 119x119 (7.0% wasted)
ANI 2_mainoptions.ani with size 206x206 (19.5% wasted)
ANI 2_maincampaign.ani with size 190x190 (25.8% wasted)
No music file exists to play music at the main menu!
Got event GS_EVENT_MULTI_JOIN_GAME (18) in state GS_STATE_MAIN_MENU (1)
Got event GS_EVENT_MAIN_MENU (0) in state GS_STATE_MULTI_JOIN_GAME (14)
ANI 2_mainwalk.ani with size 477x477 (6.8% wasted)
ANI 2_mainflyby.ani with size 189x189 (26.2% wasted)
ANI 2_maincrane.ani with size 116x116 (9.4% wasted)
ANI 2_mainexit.ani with size 174x174 (32.0% wasted)
ANI 2_mainbarracks.ani with size 158x158 (38.3% wasted)
ANI 2_mainreadyroom.ani with size 145x145 (43.4% wasted)
ANI 2_maintechroom.ani with size 119x119 (7.0% wasted)
ANI 2_mainoptions.ani with size 206x206 (19.5% wasted)
ANI 2_maincampaign.ani with size 190x190 (25.8% wasted)
No music file exists to play music at the main menu!
Got event GS_EVENT_QUIT_GAME (5) in state GS_STATE_MAIN_MENU (1)
Freeing all existing models...



Here the old multi log (I removed the old one, and there was no new after running the debug log):

Code: [Select]
FreeSpace Multi Log - Opened Sun, Jul 19, 2009 at 02:02AM
----
----
----


07/19 02:02:28~ psnet_init() detected lan connection
07/19 02:02:28~ psnet_get_ip() reports IP : 0.0.0.0

07/19 02:02:28~ Receive buffer set to 4096

07/19 02:02:28~ Send buffer set to 4096

07/19 02:02:28~ Error on IPX startup 10047

07/19 02:02:28~ Network
07/19 02:02:28~ Found no RAS connections


----
----
----
FreeSpace Multi Log - Closing on Sun, Jul 19, 2009 at 02:03AM



Other informations are here:

http://www.game-warden.com/forum/showthread.php?p=117843&posted=1#post117843



thanks for any help  :)

« Last Edit: July 20, 2009, 01:12:45 am by Jeff Vader »

 

Offline Jeff Vader

  • The Back of the Hero!
  • 212
  • Bwahaha
    • Twitter
Re: connection failed in multiplayer
http://www.hard-light.net/forums/index.php/topic,63609.0.html

In a nutshell: 3.6.9 is old and unsupported in multiplayer. Use 3.6.10.

Also, when posting logs, please use "code" tags instead of "quote" tags. I've fixed it for you this time.

Edit: In addition, you have multi-mission-pack.vp in two places. You can safely remove it from \freespace2\multimissions\ .
Furthermore, you don't need to have any of the cd's in your optical drive when playing FSO.
« Last Edit: July 20, 2009, 01:33:40 am by Jeff Vader »
23:40 < achillion > EveningTea: ass
23:40 < achillion > wait no
23:40 < achillion > evilbagel: ass
23:40 < EveningTea > ?
23:40 < achillion > 2-letter tab complete failure

14:08 < achillion > there's too much talk of butts and dongs in here
14:08 < achillion > the level of discourse has really plummeted
14:08 < achillion > Let's talk about politics instead
14:08 <@The_E > butts and dongs are part of #hard-light's brand now
14:08 <@The_E > well
14:08 <@The_E > EvilBagel's brand, at least

01:06 < T-Rog > welp
01:07 < T-Rog > I've got to take some very strong antibiotics
01:07 < achillion > penis infection?
01:08 < T-Rog > Chlamydia
01:08 < achillion > O.o
01:09 < achillion > well
01:09 < achillion > I guess that happens
01:09 < T-Rog > at least it's curable
01:09 < achillion > yeah
01:10 < T-Rog > I take it you weren't actually expecting it to be a penis infection
01:10 < achillion > I was not

14:04 < achillion > Sometimes the way to simplify is to just have a habit and not think about it too much
14:05 < achillion > until stuff explodes
14:05 < achillion > then you start thinking about it

22:16 < T-Rog > I don't know how my gf would feel about Jewish conspiracy porn

15:41 <-INFO > EveningTea [[email protected]] has joined #hard-light
15:47 < EvilBagel> butt
15:51 < Achillion> yes
15:53 <-INFO > EveningTea [[email protected]] has quit [Quit: http://www.mibbit.com ajax IRC Client]

18:53 < Achillion> Dicks are fun

21:41 < MatthTheGeek> you can't spell assassin without two asses

20:05 < sigtau> i'm mining titcoins from now on

00:31 < oldlaptop> Drunken antisocial educated freezing hicks with good Internet == Finland stereotype

11:46 <-INFO > Kobrar [[email protected]] has joined #hard-light
11:50 < achtung> Surely you've heard of DVDA
11:50 < achtung> Double Vaginal Double ANal
11:51 < Kobrar> ...
11:51 <-INFO > Kobrar [[email protected]] has left #hard-light []

  

Offline sral

  • 21
Re: connection failed in multiplayer
thanks a lot Jeff Vader ! it works  :)