Author Topic: Graphics Problems  (Read 5276 times)

0 Members and 1 Guest are viewing this topic.

Offline wdarkk

  • 26
I just installed freespace via the .jar installer on my osx box.
However, when I start it a LOT of textures are wrong or missing.
For example, the engine trails on the instructor's ship have been replaced by squadron logos,
then on a later playthough with hull textures. I can't see the transports in mission 1 at all.
I have jpgtga enabled, but I don't think I have any other options selected.

 

Offline wdarkk

  • 26
Ok, I've tried reinstalling, but no dice.

Right now I'm trying ganking the ini files, followed by another reinstall with fewer mods.

Edit: Ganking ini files did jack, waiting for modless reinstall to finish, try that.

Edit 2: Installing modless doesn't seem to do jack. Also, 3/4 of the textures I've seen for the flares on the instructor's ship are squadron logos now.
« Last Edit: August 25, 2007, 07:35:34 am by wdarkk »

 

Offline wdarkk

  • 26
Man I feel like a moron.  I forgot to move the files in the media_vps folder into the same directory as fsopen. EVERY TIME I INSTALLED IT.

Still having the problem that the stars or space dust or w/e look like cubes though.

 

Offline Turey

  • Installer dude
  • 211
  • The diminutive form of Turambar.
    • FreeSpace Open Installer Homepage
Man I feel like a moron.  I forgot to move the files in the media_vps folder into the same directory as fsopen. EVERY TIME I INSTALLED IT.

Still having the problem that the stars or space dust or w/e look like cubes though.

Wait, what?
Creator of the FreeSpace Open Installer.
"Calm. The ****. Down." -Taristin
why would an SCP error be considered as news? :wtf: *smacks Cobra*It's a feature.

 

Offline wdarkk

  • 26
Man I feel like a moron.  I forgot to move the files in the media_vps folder into the same directory as fsopen. EVERY TIME I INSTALLED IT.

Still having the problem that the stars or space dust or w/e look like cubes though.

Wait, what?

When the installer finished downloading, there was a folder called "mediavps" that contained a bunch of .vps files. I moved them into the directory that housed the main FS application. That solved most of the graphics issues, except for the ones with the nebulas and the little things that go whizzing past your cockpit.

Edit: Below is the contents of my Freespace2 directory:
DeusExMachina
FRED2.exe
FS2.exe
FS2OGGcutscenepack.vp
FS2_Launcher.app
FS2_Open 3.6.9 (debug).app
FS2_Open 3.6.9.app
FS2_Open-3.6.9.dmg
FS2_Open_Launcher_2.0.1.dmg
FreeSpace2.exe
Installer
JAD
Launcher.exe
Sync
Transcend
UpdateLauncher.exe
awakenings
cardinalspear
data
derelict
destinyofpeace
fred2_open_3_6_9.exe
fred2_open_3_6_9_debug.exe
fs2_open_3_6_9.exe
fs2_open_3_6_9_debug.exe
fsport
homesick
launcher6.ini
mediavps
motd.txt
mp-710_adveffects.vp
mp-710_effects.vp
mp-710_models.vp
multi-mission-pack.vp
multi-voice-pack.vp
mv_adveffects.vp
mv_core.vp
mv_effects.vp
mv_models.vp
mv_music.vp
mv_textures.vp
patchw32.dll
root_fs2.vp
smarty_fs2.vp
sparky_fs2.vp
sparky_hi_fs2.vp
stu_fs2.vp
tango1_fs2.vp
tango2_fs2.vp
tango3_fs2.vp
temp
tools
warble_fs2.vp
« Last Edit: August 25, 2007, 10:35:01 pm by wdarkk »

 

Offline wdarkk

  • 26
Ok, found another problem: In "The Mystery of the Trinity" when I attempt to start the mission, the graphics from the briefing room stay onscreen. I am actually playing  the mission (I can hear afterburners and collisions).

Forgot to post my system specs earlier:

6/24/07 11:54 PM


Hardware:

Hardware Overview:

  Machine Name:   Mac Pro
  Machine Model:   MacPro1,1
  Processor Name:   Dual-Core Intel Xeon
  Processor Speed:   3 GHz
  Number Of Processors:   2
  Total Number Of Cores:   4
  L2 Cache (per processor):   4 MB
  Memory:   2 GB
  Bus Speed:   1.33 GHz
  Boot ROM Version:   MP11.005C.B04
  SMC Version:   1.7f8

Network:

Built-in Ethernet 1:

  Type:   Ethernet
  Hardware:   Ethernet
  BSD Device Name:   en0
  Has IP Assigned:   No

Built-in Ethernet 2:

  Type:   Ethernet
  Hardware:   Ethernet
  BSD Device Name:   en1
  Has IP Assigned:   Yes

Built-in FireWire:

  Type:   FireWire
  Hardware:   FireWire
  BSD Device Name:   fw0
  Has IP Assigned:   No

Software:

System Software Overview:

  System Version:   Mac OS X 10.4.9 (8P2137)
  Kernel Version:   Darwin 8.9.1

ATA:

ATA Bus:

PIONEER DVD-RW  DVR-111D:

  Capacity:   743.9 MB
  Model:   PIONEER DVD-RW  DVR-111D
  Revision:   AB09
  Removable Media:   Yes
  Detachable Drive:   No
  BSD Name:   disk2
  Protocol:   ATAPI
  Unit Number:   0
  Socket Type:   Internal
  Low Power Polling:   Yes
  OS9 Drivers:   Yes
  S.M.A.R.T. status:   Not Supported
  Volumes:
disk2s1s9:
  Capacity:   646.98 MB
  Available:   1.57 MB
  Media Type:   CD-ROM
  Writable:   No
  File System:   HFS+

Audio (Built In):

Intel High Definition Audio:

  Available Devices:
  Line Out:
  Connection:   1/8 inch Jack
  Headphone:
  Connection:   1/8 inch Jack
  Line In:
  Connection:   1/8 inch Jack
  Speaker:
  Connection:   Internal
  S/P-DIF Out:
  Connection:   Optical
  S/P-DIF In:
  Connection:   Optical

Diagnostics:

Power On Self-Test:

  Last Run:   6/20/07 1:18 PM
  Result:   Passed

Disc Burning:

PIONEER DVD-RW  DVR-111D:

  Firmware Revision:   AB09
  Interconnect:   ATAPI
  Burn Support:   Yes (Apple Shipped/Supported)
  Cache:   2000 KB
  Reads DVD:   Yes
  CD-Write:   -R, -RW
  DVD-Write:   -R, -RW, +R, +RW, +R DL
  Burn Underrun Protection CD:   Yes
  Burn Underrun Protection DVD:   Yes
  Write Strategies:   CD-TAO, CD-SAO, CD-Raw, DVD-DAO
  Media:
  Media Type:   CD-ROM
  Blank:   No
  Erasable:   No
  Overwritable:   No
  Appendable:   No

FireWire:

FireWire Bus:

  Maximum Speed:   Up to 800 Mb/sec

Built-in Hub:

  Manufacturer:   Unknown
  Model:   Unknown Device
  Maximum Speed:   Up to 800 Mb/sec
  Connection Speed:   Unknown

Graphics/Displays:

ATI Radeon X1900 XT:

  Chipset Model:   ATY,RadeonX1900
  Type:   Display
  Bus:   PCIe
  Slot:   Slot-1
  VRAM (Total):   512 MB
  Vendor:   ATI (0x1002)
  Device ID:   0x7249
  Revision ID:   0x0000
  ROM Revision:   113-A52027-140
  EFI Driver Version:   01.00.140
  Displays:
Apple Cinema Display:
  Display Type:   LCD
  Resolution:   1600 x 1024
  Depth:   32-bit Color
  Core Image:   Supported
  Main Display:   Yes
  Mirror:   Off
  Online:   Yes
  Quartz Extreme:   Supported
  Rotation:   Supported
Display:
  Status:   No display connected

Memory:

DIMM Riser A/DIMM 1:

  Size:   512 MB
  Type:   DDR2 FB-DIMM
  Speed:   667 MHz
  Status:   OK

DIMM Riser A/DIMM 2:

  Size:   512 MB
  Type:   DDR2 FB-DIMM
  Speed:   667 MHz
  Status:   OK

DIMM Riser B/DIMM 1:

  Size:   512 MB
  Type:   DDR2 FB-DIMM
  Speed:   667 MHz
  Status:   OK

DIMM Riser B/DIMM 2:

  Size:   512 MB
  Type:   DDR2 FB-DIMM
  Speed:   667 MHz
  Status:   OK

DIMM Riser A/DIMM 3:

  Size:   Empty
  Type:   Empty
  Speed:   Empty
  Status:   Empty

DIMM Riser A/DIMM 4:

  Size:   Empty
  Type:   Empty
  Speed:   Empty
  Status:   Empty

DIMM Riser B/DIMM 3:

  Size:   Empty
  Type:   Empty
  Speed:   Empty
  Status:   Empty

DIMM Riser B/DIMM 4:

  Size:   Empty
  Type:   Empty
  Speed:   Empty
  Status:   Empty

PCI Cards:

ATY,RadeonX1900:

  Name:   ATY,Alopias
  Type:   display
  Bus:   PCI
  Slot:   Slot-1
  Vendor ID:   0x1002
  Device ID:   0x7249
  Subsystem Vendor ID:   0x1002
  Subsystem ID:   0x7249
  Revision ID:   0x0000

Serial-ATA:

Intel ESB2 AHCI:

  Vendor:   Intel
  Product:   ESB2 AHCI
  Speed:   3.0 Gigabit
  Description:   AHCI Version 1.10 Supported

WDC WD2500JS-41SGB0:

  Capacity:   232.89 GB
  Model:   WDC WD2500JS-41SGB0
  Revision:   20.06C04
  Serial Number:   WD-WCANY1874258
  Native Command Queuing:   Yes
  Queue Depth:   32
  Removable Media:   No
  Detachable Drive:   No
  BSD Name:   disk1
  Bay Name:   "Bay 1"
  OS9 Drivers:   No
  S.M.A.R.T. status:   Verified
  Volumes:
disk1s2:
  Capacity:   232.57 GB
  Available:   77.83 GB
  Writable:   Yes
  File System:   Journaled HFS+

Intel ESB2 AHCI:

  Vendor:   Intel
  Product:   ESB2 AHCI
  Speed:   3.0 Gigabit
  Description:   AHCI Version 1.10 Supported

ST3160811AS:

  Capacity:   149.05 GB
  Model:   ST3160811AS
  Revision:   3.AAE
  Serial Number:   6PT2QSSF
  Native Command Queuing:   Yes
  Queue Depth:   32
  Removable Media:   No
  Detachable Drive:   No
  BSD Name:   disk0
  Bay Name:   "Bay 2"
  OS9 Drivers:   No
  S.M.A.R.T. status:   Verified
  Volumes:
disk0s2:
  Capacity:   148.85 GB
  Available:   64.79 GB
  Writable:   No
  File System:   NTFS

Intel ESB2 AHCI:

  Vendor:   Intel
  Product:   ESB2 AHCI
  Speed:   3.0 Gigabit
  Description:   AHCI Version 1.10 Supported

Intel ESB2 AHCI:

  Vendor:   Intel
  Product:   ESB2 AHCI
  Speed:   3.0 Gigabit
  Description:   AHCI Version 1.10 Supported

Intel ESB2 AHCI:

  Vendor:   Intel
  Product:   ESB2 AHCI
  Speed:   3.0 Gigabit
  Description:   AHCI Version 1.10 Supported

Intel ESB2 AHCI:

  Vendor:   Intel
  Product:   ESB2 AHCI
  Speed:   3.0 Gigabit
  Description:   AHCI Version 1.10 Supported

USB:

USB High-Speed Bus:

  Host Controller Location:   Built In USB
  Host Controller Driver:   AppleUSBEHCI
  PCI Device ID:   0x268c
  PCI Revision ID:   0x0009
  PCI Vendor ID:   0x8086
  Bus Number:   0xfd

USB Bus:

  Host Controller Location:   Built In USB
  Host Controller Driver:   AppleUSBUHCI
  PCI Device ID:   0x268a
  PCI Revision ID:   0x0009
  PCI Vendor ID:   0x8086
  Bus Number:   0x5d

USB Bus:

  Host Controller Location:   Built In USB
  Host Controller Driver:   AppleUSBUHCI
  PCI Device ID:   0x2688
  PCI Revision ID:   0x0009
  PCI Vendor ID:   0x8086
  Bus Number:   0x1d

Logitech USB Headset:

  Version:   10.13
  Bus Power (mA):   500
  Speed:   Up to 12 Mb/sec
  Manufacturer:   Logitech
  Product ID:   0x0a01
  Vendor ID:   0x046d

USB Bus:

  Host Controller Location:   Built In USB
  Host Controller Driver:   AppleUSBUHCI
  PCI Device ID:   0x268b
  PCI Revision ID:   0x0009
  PCI Vendor ID:   0x8086
  Bus Number:   0x7d

USB Bus:

  Host Controller Location:   Built In USB
  Host Controller Driver:   AppleUSBUHCI
  PCI Device ID:   0x2689
  PCI Revision ID:   0x0009
  PCI Vendor ID:   0x8086
  Bus Number:   0x3d

Hub:

  Version:   0.01
  Bus Power (mA):   500
  Speed:   Up to 12 Mb/sec
  Product ID:   0x9102
  Vendor ID:   0x05ac  (Apple Computer, Inc.)

Hub:

  Version:   1.10
  Bus Power (mA):   500
  Speed:   Up to 12 Mb/sec
  Product ID:   0x9116
  Vendor ID:   0x05ac  (Apple Computer, Inc.)

Hub in Apple Pro Keyboard:

  Version:   4.20
  Bus Power (mA):   500
  Speed:   Up to 12 Mb/sec
  Manufacturer:   Mitsumi Electric
  Product ID:   0x1003
  Vendor ID:   0x05ac  (Apple Computer, Inc.)

Apple Pro Keyboard:

  Version:   4.20
  Bus Power (mA):   250
  Speed:   Up to 12 Mb/sec
  Manufacturer:   Mitsumi Electric
  Product ID:   0x020b
  Vendor ID:   0x05ac  (Apple Computer, Inc.)

USB Monitor:

  Version:   1.0e
  Bus Power (mA):   500
  Speed:   Up to 1.5 Mb/sec
  Manufacturer:   LG Electronics Inc.
  Product ID:   0x9216
  Vendor ID:   0x05ac  (Apple Computer, Inc.)

Trackball:

  Version:   2.20
  Bus Power (mA):   500
  Speed:   Up to 1.5 Mb/sec
  Manufacturer:   Logitech
  Product ID:   0xc404
  Vendor ID:   0x046d



 

Offline jr2

  • The Mail Man
  • 212
  • It's prounounced jayartoo 0x6A7232
    • Steam
Man I feel like a moron.  I forgot to move the files in the media_vps folder into the same directory as fsopen. EVERY TIME I INSTALLED IT.

Still having the problem that the stars or space dust or w/e look like cubes though.

Wait, what?

When the installer finished downloading, there was a folder called "mediavps" that contained a bunch of .vps files. I moved them into the directory that housed the main FS application. That solved most of the graphics issues, except for the ones with the nebulas and the little things that go whizzing past your cockpit.


You're supposed to leave them in mediavps... and use the Launcher to select the mod "mediavps"... :wtf:  You do have the OS X Launcher, right?

The rest is prolly flags that are not selected in the Launcher... There's a walkthrough in my sig, at the end is a list of the correct flags to have on in the Launcher.

 

Offline wdarkk

  • 26
Man I feel like a moron.  I forgot to move the files in the media_vps folder into the same directory as fsopen. EVERY TIME I INSTALLED IT.

Still having the problem that the stars or space dust or w/e look like cubes though.

Wait, what?

When the installer finished downloading, there was a folder called "mediavps" that contained a bunch of .vps files. I moved them into the directory that housed the main FS application. That solved most of the graphics issues, except for the ones with the nebulas and the little things that go whizzing past your cockpit.


You're supposed to leave them in mediavps... and use the Launcher to select the mod "mediavps"... :wtf:  You do have the OS X Launcher, right?

The rest is prolly flags that are not selected in the Launcher... There's a walkthrough in my sig, at the end is a list of the correct flags to have on in the Launcher.

DOH. Ok, thanks.

 

Offline wdarkk

  • 26
Ok, if I use ANY mod other than MediaVPS (including no mods) the horrible graphics problems come back. All of this was installed by the launcher and not monkeyed with.

 

Offline jr2

  • The Mail Man
  • 212
  • It's prounounced jayartoo 0x6A7232
    • Steam
Alright, I need you to follow the directions under "Posting your FS2 directory contents", so I can see the file sizes of your files, perhaps there's one that's incomplete... put it as an attachment, or use www.pastebin.com and post a link here.
« Last Edit: August 30, 2007, 01:02:44 am by jr2 »

 

Offline wdarkk

  • 26
Ok, it won't be in the same format because the directions you gave are for windows, but I think this should be the mac/*nix equivalent.

Fifth column is the size in bytes.

[attachment deleted by admin]

 

Offline wdarkk

  • 26
Ok, it won't be in the same format because the directions you gave are for windows, but I think this should be the mac/*nix equivalent.

Fifth column is the size in bytes.

Forgot to make the file include subdirectories, so updated.

[attachment deleted by admin]

 

Offline wdarkk

  • 26
While I'm waiting, I decided to try trashing the installer logs and letting the installer reinstall everything. I'll let you know if that helps.


EDIT: No luck. I'm attaching some shots of some of the graphics problems in case that helps. These are all from FSPort.

[attachment deleted by admin]
« Last Edit: September 01, 2007, 03:17:21 pm by wdarkk »

 

Offline jr2

  • The Mail Man
  • 212
  • It's prounounced jayartoo 0x6A7232
    • Steam
Make sure you have the latest drivers:

http://ati.amd.com/support/drivers/mac/MacX1900G5Updater.html

-That is for Mac OS X 10.4.x and an ATI Radeon X1900

See if this helps.

 

Offline wdarkk

  • 26
Make sure you have the latest drivers:

http://ati.amd.com/support/drivers/mac/MacX1900G5Updater.html

-That is for Mac OS X 10.4.x and an ATI Radeon X1900

See if this helps.

That's for the G5, I have an Intel Mac. It won't even install.

 

Offline jr2

  • The Mail Man
  • 212
  • It's prounounced jayartoo 0x6A7232
    • Steam
Greeeaaaat.  So, where do you get your drivers from??  :confused:

http://ati.amd.com/support/driver.html

I don't see your Intel Mac mentioned... :nervous:

 

Offline wdarkk

  • 26
Greeeaaaat.  So, where do you get your drivers from??  :confused:

http://ati.amd.com/support/driver.html

I don't see your Intel Mac mentioned... :nervous:

And now you have discovered the REAL reason why there aren't any mac gamers :P

I take it you're pretty sure this isn't a problem with FS itself?

 

Offline jr2

  • The Mail Man
  • 212
  • It's prounounced jayartoo 0x6A7232
    • Steam
Only one way to find out... do you have access to another computer?  If so, 7-zip (or zip, w/e) you FS2 directory, burn it to a DVD, unzip it to the other computer, delete launcher6.ini, reconfigure the settings, install OpenAL, and try it.

 

Offline wdarkk

  • 26
Only one way to find out... do you have access to another computer?  If so, 7-zip (or zip, w/e) you FS2 directory, burn it to a DVD, unzip it to the other computer, delete launcher6.ini, reconfigure the settings, install OpenAL, and try it.

Tried that on another mac (ATI Radeon Mobility 9200), worked perfectly.

Crud, looks like the X1900 is cursed like the X1600.

 

Offline jr2

  • The Mail Man
  • 212
  • It's prounounced jayartoo 0x6A7232
    • Steam
So you need to bug ATI about their Intel Mac OS X 10.4.x drivers (ie, they need to release some updated ones).