Author Topic: Fred 2 Beta Testing  (Read 876 times)

0 Members and 1 Guest are viewing this topic.

When ever I select the run Freespace option in Fred2_open_3_6_9 for Beta testing, it always gives me the message: The system cannot find the file specified.

 
The command has never worked... I don't recall it working in retail version!  :doubt:

What most do is save the mission, run FS but keep running FRED in the background, test mission.

Tedious? A bit, but you get used to it. Just remember to save any changes you make before testing them.

One more thing:

:welcomeblue:
"You need to believe in things that aren't true. How else can they become?" -DEATH, Discworld

"You can fight like a krogan, run like a leopard, but you'll never be better than Commander Shepard!"

 

Offline karajorma

  • King Louie - Jungle VIP
  • Administrator
  • 214
    • Karajorma's Freespace FAQ
It worked in FS1 where it ran FS.exe.

In FS2 Retail it still worked. But it still only ran FS.exe. Which of course had no result as the game's executable had been changed to FS2.exe. If you renamed the file it worked perfectly.

In FS2_Open it will first attempt to run a batch file called start_fs2.bat. If that is not found it will try to run fs2_open.exe then fs2_open_r.exe before it gives up. Unfortunately since WMCoolmon changed it the working directory for FRED appears to have changed from a subfolder of data to the main FS2 folder itself. As a result it's working it's way two steps up the directory path it doesn't need to and therefore looking in the wrong place.

In other words if you have FRED in C:\Games\Freespace2 it's looking for the batch file in C:\

This should be easily fixed to let it run correctly.
Karajorma's Freespace FAQ. It's almost like asking me yourself.

[ Diaspora ] - [ Seeds Of Rebellion ] - [ Mind Games ]