Author Topic: Hi, I'm new here  (Read 810 times)

0 Members and 1 Guest are viewing this topic.

Offline deloco

  • 21
    • Skype
    • Steam
    • Twitter
    • My Blog
Hi there,
I'm J.D. from germany and new to Freespace 2 Open.
I Actually never have played FS2, only Descent Freespace, back in the day…
Now I was looking for a nice Space-Game and stumbled upon Freespace2.
Bought it on GOG, installed it via Knossos on my MacBook, but sadly, it doesn't start til now. Just shows a "FSO is starting…"-Message for a second there and then nothing happens, so I'm in the middle of trobleshooting…

 

Offline Colonol Dekker

  • HLP is my mistress
  • 213
  • Aken Tigh Dekker
    • My old squad sub-domain
:welcomered:

Hi bud.  Welkommen, once you get it working (ask if you need help) I suggest starting with the freespace port so you can experience the full story from the start.
Your friendly Orestes tactical controller
GO GO DEKKER RANGERSSSS!!!!!!!!!!!!!!!!!
President of the Scooby Doo Model Appreciation Society
The only good Zod is a dead Zod
NEWGROUNDS COMEDY GOLD, UPDATED DAILY
http://badges.steamprofile.com/profile/default/steam/76561198011784807.png

 

Offline wookieejedi

  • 28
  • Intensify Forward Firepower
Hi there,
I'm J.D. from germany and new to Freespace 2 Open.
I Actually never have played FS2, only Descent Freespace, back in the day…
Now I was looking for a nice Space-Game and stumbled upon Freespace2.
Bought it on GOG, installed it via Knossos on my MacBook, but sadly, it doesn't start til now. Just shows a "FSO is starting…"-Message for a second there and then nothing happens, so I'm in the middle of trobleshooting…

Welcome! Hmm if it isn't working feel free to join our Discord channel and ask there, as that usually gets responses relatively quickly. One reason that can cause that issue is if you have a joystick plugged in... If some try unplugging the joystick, restarting the computer, and then running Knossos without plugging in the joystick.

 
Some more people from Germany~

 

Offline ngld

  • Administrator
  • 29
  • Knossos dev
Knossos might be kind of buggy on macOS right now since we don't have as many mac users as Windows and Linux users.
Something you should try: Go to Knossos' settings, set your preferred stability to nightly and then update FSO from the Home or Explore tab. Then try launching the MediaVPs.

 

Offline Novachen

  • 29
  • The one and only capella supernova
    • Twitter
Some more people from Germany~

So maybe people who are actually playing my translation mods, so that i can get feedback after two three years finally :lol:

Welcome.
Female FreeSpace 2 pilot since 1999.
Global moderator in the German FreeSpace Galaxy Forum.

Responsible for the german translation project FreiRaum - FreeSpace auf Deutsch.
Also responsible for the Nova Upgrade Project, which upgrades and fix older campaigns to make them play- and solveable again with current builds and MediaVPs.

Release List:
German Translations:
Awakenings, Between the Ashes 1, Deneb III, FreeSpace 2 (in development), FreeSpace Port, Silent Threat: Reborn & The Destiny of Peace

Nova Upgrades:
A Walk in the Sun, Into the Halls of Valhalla, Luyten Civil War, Renegade Resurgence, Revenge: Final Conflict (in development), Rogues!, Shadow Genesis (de-facto), Storm Front Saga, The Deuterium Connection, Venice Mirror & What If: Another Great War

 

Offline deloco

  • 21
    • Skype
    • Steam
    • Twitter
    • My Blog
Nice welcome here.
Thanks for the answers.
I tried the Joystcik-thing, because I had one connected. Still doesn‘t work, but now I get an errormessage that says: „Starting /Users/…/FS2/…/fs2_open_3_8_1_20190115_08faf52_x64.add/..…. Failed! (Return code: -6).
Maybe I‘ll have look onto the discord-server, but maybe I‘ll find a solution in the forum.
Maybe I have some time for that tomorrow.

  

Offline ngld

  • Administrator
  • 29
  • Knossos dev
That's progress at least. -6 means that FSO killed itself with abort().  Can you please launch a Fast Debug build and upload the log? Go to the Home tab, hover over the mod (MediaVPs in this case), click on the little arrow in the bottom-right corner, click "Launch Fast Debug". Wait until it exits with the previous error message and click "Upload Log" from the same menu. Finally, post the link it shows here.