Author Topic: FS2 Open debris effects problem...  (Read 2648 times)

0 Members and 1 Guest are viewing this topic.

Re: FS2 Open debris effects problem...
Ok, yes sure, I've extracted the file from the .rar...but the problem is the same. I see the electric shocks on the debris, but also flashing textures...
No other solutions guys?Isn't a big problem, but is very annoying...
Ok, then I must stay with the wreckage of ships flashing ... :sigh: Thanks anyway for all the advice! :yes:
« Last Edit: April 14, 2011, 03:21:07 pm by Jeff Vader »

 

Offline Jeff Vader

  • The Back of the Hero!
  • Moderator
  • 212
  • Bwahaha
    • Twitter
Re: FS2 Open debris effects problem...
Yeah, uh, that shader pack should have fixed it. If you want to, you can in theory try this shader pack I pieced together from the 3.6.10 MediaVPs for my own personal use. Just extract the .vp file to your \mediavps_3612\ directory.
« Last Edit: April 16, 2011, 04:12:08 am by Jeff Vader »
23:40 < achillion > EveningTea: ass
23:40 < achillion > wait no
23:40 < achillion > evilbagel: ass
23:40 < EveningTea > ?
23:40 < achillion > 2-letter tab complete failure

14:08 < achillion > there's too much talk of butts and dongs in here
14:08 < achillion > the level of discourse has really plummeted
14:08 < achillion > Let's talk about politics instead
14:08 <@The_E > butts and dongs are part of #hard-light's brand now
14:08 <@The_E > well
14:08 <@The_E > EvilBagel's brand, at least

01:06 < T-Rog > welp
01:07 < T-Rog > I've got to take some very strong antibiotics
01:07 < achillion > penis infection?
01:08 < T-Rog > Chlamydia
01:08 < achillion > O.o
01:09 < achillion > well
01:09 < achillion > I guess that happens
01:09 < T-Rog > at least it's curable
01:09 < achillion > yeah
01:10 < T-Rog > I take it you weren't actually expecting it to be a penis infection
01:10 < achillion > I was not

14:04 < achillion > Sometimes the way to simplify is to just have a habit and not think about it too much
14:05 < achillion > until stuff explodes
14:05 < achillion > then you start thinking about it

22:16 < T-Rog > I don't know how my gf would feel about Jewish conspiracy porn

15:41 <-INFO > EveningTea [[email protected]] has joined #hard-light
15:47 < EvilBagel> butt
15:51 < Achillion> yes
15:53 <-INFO > EveningTea [[email protected]] has quit [Quit: http://www.mibbit.com ajax IRC Client]

18:53 < Achillion> Dicks are fun

21:41 < MatthTheGeek> you can't spell assassin without two asses

20:05 < sigtau> i'm mining titcoins from now on

00:31 < oldlaptop> Drunken antisocial educated freezing hicks with good Internet == Finland stereotype

11:46 <-INFO > Kobrar [[email protected]] has joined #hard-light
11:50 < achtung> Surely you've heard of DVDA
11:50 < achtung> Double Vaginal Double ANal
11:51 < Kobrar> ...
11:51 <-INFO > Kobrar [[email protected]] has left #hard-light []

 
Re: FS2 Open debris effects problem...
Hi, ok I can try, but the link you've posted doesn't work...thanks a lot!

 

Offline Jeff Vader

  • The Back of the Hero!
  • Moderator
  • 212
  • Bwahaha
    • Twitter
Re: FS2 Open debris effects problem...
Whoops. Amateur mistake :nervous: Try it now.
23:40 < achillion > EveningTea: ass
23:40 < achillion > wait no
23:40 < achillion > evilbagel: ass
23:40 < EveningTea > ?
23:40 < achillion > 2-letter tab complete failure

14:08 < achillion > there's too much talk of butts and dongs in here
14:08 < achillion > the level of discourse has really plummeted
14:08 < achillion > Let's talk about politics instead
14:08 <@The_E > butts and dongs are part of #hard-light's brand now
14:08 <@The_E > well
14:08 <@The_E > EvilBagel's brand, at least

01:06 < T-Rog > welp
01:07 < T-Rog > I've got to take some very strong antibiotics
01:07 < achillion > penis infection?
01:08 < T-Rog > Chlamydia
01:08 < achillion > O.o
01:09 < achillion > well
01:09 < achillion > I guess that happens
01:09 < T-Rog > at least it's curable
01:09 < achillion > yeah
01:10 < T-Rog > I take it you weren't actually expecting it to be a penis infection
01:10 < achillion > I was not

14:04 < achillion > Sometimes the way to simplify is to just have a habit and not think about it too much
14:05 < achillion > until stuff explodes
14:05 < achillion > then you start thinking about it

22:16 < T-Rog > I don't know how my gf would feel about Jewish conspiracy porn

15:41 <-INFO > EveningTea [[email protected]] has joined #hard-light
15:47 < EvilBagel> butt
15:51 < Achillion> yes
15:53 <-INFO > EveningTea [[email protected]] has quit [Quit: http://www.mibbit.com ajax IRC Client]

18:53 < Achillion> Dicks are fun

21:41 < MatthTheGeek> you can't spell assassin without two asses

20:05 < sigtau> i'm mining titcoins from now on

00:31 < oldlaptop> Drunken antisocial educated freezing hicks with good Internet == Finland stereotype

11:46 <-INFO > Kobrar [[email protected]] has joined #hard-light
11:50 < achtung> Surely you've heard of DVDA
11:50 < achtung> Double Vaginal Double ANal
11:51 < Kobrar> ...
11:51 <-INFO > Kobrar [[email protected]] has left #hard-light []

 
Re: FS2 Open debris effects problem...
Yeah, I can confirm this problem, and give a more detailed error report.

I reinstalled Windows 7 64-bit fresh on this system just yesterday, after a full format and restart. I'm running an ATI 5770 (everything at factory settings, not forcing anything at the card level), and am running the very latest drivers (11.3). I installed Freespace 2 (GOG version), used the automated installer to get The Works, and am running the main campaign using the MediaVPs_3612 mod. There's basically no room for user error here.

On floating debris and heavily damaged capital ships, any polygons near the blue lightning-arc effect are briefly coloured solid 'fullbright' white. I've not seen the problem with any other effect, just polys near the blue arcs.

I've tried both fix-files provided here. Just unzipped them and dropped them in my MediaVPs_3612 folder. First one, then the other, then both together, but none work so far.

Hopefully this issue gets fixed soon, as it's probably the one gripe I have with the whole game.

 

Offline The E

  • He's Ebeneezer Goode
  • Global Moderator
  • 213
  • Nothing personal, just tech support.
    • Steam
    • Twitter
Re: FS2 Open debris effects problem...
Except that it's almost certainly an issue with that particular series of cards. I run a 5470, and do not have those issues.

Another shader set to try would be the new per-fragment shaders. Please unpack the attached file in mediavps_3612\data\effects

Note that, in order to use these, you will need a recent nightly build (those can be found here.

[attachment deleted by ninja]
Let there be light
Let there be moon
Let there be stars and let there be you
Let there be monsters and let there be pain
Let us begin to feel again
--Devin Townsend, Genesis

 

Offline Trivial Psychic

  • 212
  • Snoop Junkie
Re: FS2 Open debris effects problem...
I reinstalled Windows 7 64-bit fresh on this system just yesterday, after a full format and restart. I'm running an ATI 5770 (everything at factory settings, not forcing anything at the card level), and am running the very latest drivers (11.3). I installed Freespace 2 (GOG version), used the automated installer to get The Works, and am running the main campaign using the MediaVPs_3612 mod. There's basically no room for user error here.
I highly recommend that you revert to the 11.2 CATs.  I too am running Win7-64 on a 5770 and when I upgraded to 11.3s when they came out and immediately started getting FSO problems.  I was getting some debris texture anomalies, but also the game would lock up on me when I got some major action like large explosions or once when I was getting slammed by AAA.  I also think that it gave me some sound anomalies.  At first I thought that it was due to a new Knightly build so I reverted to what I'd been using before but the problems persisted.  I have since reverted to 11.2 but I don't think that I've had the chance to play again since.
The Trivial Psychic Strikes Again!

 
Re: FS2 Open debris effects problem...
Yeah, I agree that it's almost certainly an issue with these drivers. I was playing another game (Spiral Knights) which was exhibiting a shockingly similar issue. Certain areas would cast light which would cause polygons to turn completely black.

I've rolled back to 11.2 and will see if that improves things.

Edit: Yeah, just tested it. It's definitely a driver issue with 11.3.
« Last Edit: April 16, 2011, 12:15:00 pm by Dominic White »

 
Re: FS2 Open debris effects problem...
If you have Windows 7 you can try the 11.4 preview driver and see if that helps, though I doubt it will, as most changes in it are performance boosts for the HD 6XXX cards. You can get it at http://support.amd.com/us/kbarticles/Pages/Catalyst114earlypreview.aspx

 
Re: FS2 Open debris effects problem...
Well, driver problem...maybe I use 11.2 now, or wait for 11.4. Thanks at all!!! ;-)

 
Re: FS2 Open debris effects problem...
Sorry people, but I've tryed to install Catalyst 11.2 instead 11.3, but without results!The debris are flashing, like before...

 
Re: FS2 Open debris effects problem...
Yeah, I agree that it's almost certainly an issue with these drivers. I was playing another game (Spiral Knights) which was exhibiting a shockingly similar issue. Certain areas would cast light which would cause polygons to turn completely black.

I've rolled back to 11.2 and will see if that improves things.

Edit: Yeah, just tested it. It's definitely a driver issue with 11.3.

Sorry, but with 11.2 Catalyst, you don't have debris flashing?I've tryed but without results...thanks!

 

Offline Qent

  • 29
Re: FS2 Open debris effects problem...
I'm sticking with 10.4 until something forces me to change. You could of course try that or other old versions.

 
Re: FS2 Open debris effects problem...
Ok Qent, thanks...but you don't have this problem with 10.4 right?

 

Offline Qent

  • 29
Re: FS2 Open debris effects problem...
No I don't.

  

Offline Trivial Psychic

  • 212
  • Snoop Junkie
Re: FS2 Open debris effects problem...
I highly recommend that you revert to the 11.2 CATs.  I too am running Win7-64 on a 5770 and when I upgraded to 11.3s when they came out and immediately started getting FSO problems.  I was getting some debris texture anomalies, but also the game would lock up on me when I got some major action like large explosions or once when I was getting slammed by AAA.  I also think that it gave me some sound anomalies.  At first I thought that it was due to a new Knightly build so I reverted to what I'd been using before but the problems persisted.  I have since reverted to 11.2 but I don't think that I've had the chance to play again since.
:bump:
I know that its considered somewhat gauche to quote yourself, but I figured that an update was in order.  I hadn't had the change to play FSO for several weeks (just bad timing with RL stuff) until just yesterday and haven't had any problems with 11.2 since reverting.  The full 11.4 came out recently, but I'm somewhat reluctant to take the plunge on that one.
The Trivial Psychic Strikes Again!