Author Topic: Particle trail script  (Read 29227 times)

0 Members and 1 Guest are viewing this topic.

Offline Slasher

  • 29
I'm having some trouble specifying a debris trail as the default trail for ships.  To do this, do I just remove the "$Class" parameter entirely and replace it with "+Default: YES"?

 

Offline m!m

  • 211
Yes, I think that should work.

 

Offline Slasher

  • 29
I'm getting a crash trying this with TBP and FS2 3.6.14 Final.  I can specify effects for individual ships and they show up in game and look great, but if I try to use the same data for a "default" trail by doing what I said in the above post, I get this:

Code: [Select]
LUA ERROR: [string "trailInfo.lua"]:328: attempt to index global 'deathParticleScript' (a nil value)

------------------------------------------------------------------
ADE Debug:
------------------------------------------------------------------
Name: checkDebris
Name of: method
Function type: Lua
Defined on: 314
Upvalues: 0

Source: trailInfo.lua
Short source: [string "trailInfo.lua"]
Current line: 328
- Function line: 15
------------------------------------------------------------------


------------------------------------------------------------------
LUA Stack:
checkDebris
doObjectInfoRun
------------------------------------------------------------------

------------------------------------------------------------------



[attachment deleted by a basterd]

 

Offline m!m

  • 211
That looks like it's an error in the script, I'll post an update tomorrow.

EDIT: New version uploaded the error should hopefully be fixed now.
« Last Edit: December 01, 2012, 05:47:23 am by m!m »

 

Offline Slasher

  • 29
Thanks for the rapid response.