Author Topic: Possible bug with $Blast force:  (Read 1045 times)

0 Members and 1 Guest are viewing this topic.

Offline Nighteyes

  • 211
Possible bug with $Blast force:
I don't know if this is a bug or not, but its just not working properly.
$Blast Force form explosions that don't have a shockwave will only give a small screen shake effect when in the explosion radius, regardless of the number you put there, instead of the full effect that happens when you hit a shockwave where your whole ship moves about.

is it possible to have the proper effect behavior where the whole ship moves? so if you only want a small screen shake set the blast force to something small, and if you want a big shake and ship being moved about set it to a higher value?

my main reason for asking this change is that there is a shockwave limit in the engine of something like 50 IIRC, if you want flak fire for instance to really  be impossible to fly through each flak burst should really shake your ship about.
currently it seems strange that this feature is simple not working when there is no shockwave...

 

Offline Fury

  • The Curmudgeon
  • 213
Re: Possible bug with $Blast force:
These are two separate things. Blast force is not related to the shockwave or the shudder a shockwave causes. It is force of the kinetic impact, the higher the blast force is, the more your ship is thrown off-course from point of impact. Force of the shudder that is caused by shockwave as far as I can remember, cannot be altered and it only exists if an actual shockwave is produced.

So it's not a bug, you're just mistaking blast force being behind the shudder caused by shockwave. Blast force doesn't shake your ship, it throws ship off-course towards opposite (supposedly) direction of impact.

 

Offline Alan Bolte

  • 28
  • Deneb III
    • @Compellor
Re: Possible bug with $Blast force:
I should think that if you set $Shockwave Speed high enough it would be tough to hit the limit unless you're creating dozens of shockwaves per frame.
Anything worth doing is worth analyzing to death -Iranon

 

Offline Nighteyes

  • 211
Re: Possible bug with $Blast force:
I should think that if you set $Shockwave Speed high enough it would be tough to hit the limit unless you're creating dozens of shockwaves per frame.

Imagine battlestar type flak field and rehink your statement ;) anyway thats not such a bad idea and I will try it with extremely fast moving shockwaves

Fury: blast force indeed supposed to throw your ship off-course to the opposite direction of impact, but if there is no shockwave then it doesn't work, this is what I meant in the first post, IMO it should work regardless of shockwave or no shockwave
« Last Edit: October 23, 2011, 04:41:42 pm by Nighteyes »

  

Offline Fury

  • The Curmudgeon
  • 213
Re: Possible bug with $Blast force:
Then it has to be a recent bug because blast force worked fine last spring/summer.