Author Topic: Still need help!: Brightness/Gamma suddenly drops majorly (and frequently)  (Read 1305 times)

0 Members and 1 Guest are viewing this topic.

Still need help!: Brightness/Gamma suddenly drops majorly (and frequently)
This one is...odd. I just installed FS Port, along with all of the other mods that come with the Installer (though they all had that "error during installation" error, indicating that one or more of the links each of them use is now broken).

This problem is new. Basically, I'll be playing midmission (this only happened during each of the first three training missions; that's when I switched to the debug version to get log data), and suddenly my brightness/gamma will drop to very low levels. None of my settings are changed--after the mission, I'll go to the settings, and changing the brightness setting at all (even lowering it) will instantly set the brightness back to where it's supposed to be. It will be fine until the problem happens again in a subsequent mission. The low-brightness continues through to the debriefing screen whenever it happens.

When using the debug version (and running it in a window), I couldn't recreate the problem. I even tried playing two of the training missions in the mission simulator, but no luck. Any idea what the deal is?

Log file is attached.

EDIT: Woah, okay, new info. I just started up the normal version again, and the brightness problem was there from the beginning this time. The same fix worked as usual, but it's notable that it didn't even occur/start midmission this time, it was there since I started up the game this time. I'm quite confused...

EDIT2: Another tidbit; I alt-tabbed out to make the first edit (AFTER I had fixed the problem by switching the brightness setting back and forth). I go back in to the game, and the low brightness is there again, and fixed the same way (temporarily).

[attachment deleted by a ninja]
« Last Edit: July 16, 2012, 09:52:36 pm by SaltyWaffles »
Delenda Est delenda est.

(Yay gratuitous Latin.)

 

Offline Yarn

  • 210
Re: Brightness/Gamma suddenly drops majorly mid-mission; no settings are adjusted
Try setting the game's brightness setting (in the options menu) to 1.0. I have to do this to get my graphics card's video settings to apply correctly in this game.
"Your fighter is running out of oil.  Please check under the hood and add more if necessary"
--strings.tbl, entry 177

"Freespace is very tired.  It is shutting down to get some rest."
--strings.tbl, entry 178

 
Re: Brightness/Gamma suddenly drops majorly mid-mission; no settings are adjusted
Sorry, I don't think that is an option for me. At 1.0, the screen is ridiculously dark.

Of note is that resolution seems to be a factor of some kind; playing at 1280X1024, I have it very frequently, but at 1280X768, I rarely (if ever) do, even though there don't seem to be any other notable discrepancies.
Delenda Est delenda est.

(Yay gratuitous Latin.)

 

Offline CommanderDJ

  • Software engineer
  • 210
    • Minecraft
Re: Brightness/Gamma suddenly drops majorly mid-mission; no settings are adjusted
This may not be it, I'm just taking a stab in the dark here, but could you try checking the "Disable setting of gamma" checkbox under the Troubleshoot menu in the Features tab of the launcher?
[16:57] <CommanderDJ> What prompted the decision to split WiH into acts?
[16:58] <battuta> it was long, we wanted to release something
[16:58] <battuta> it felt good to have a target to hit
[17:00] <RangerKarl> not sure if talking about strike mission, or jerking off
[17:00] <CommanderDJ> WUT
[17:00] <CommanderDJ> hahahahaha
[17:00] <battuta> hahahaha
[17:00] <RangerKarl> same thing really, if you think about it

 
Re: Brightness/Gamma suddenly drops majorly mid-mission; no settings are adjusted
Okay, sorry for leaving this thread hanging. I've got an update.

So it's not just FS Port and a few older mods anymore, not it's mods that worked fine beforehand. In particular, War In Heaven, though AoA is an example as well.

As for the "Disable Setting of Gamma": I tried it, and it worked...sort of. It locked my gamma/brightness at a specific level, and it didn't change. The problem, however, is that that unchangeable level is still way too dark. There are many times where I can barely see a corvette that's right in front of me.

So I turned it off, and the issue is still everpresent. It's bordering on making the game unplayable, and it's rapidly pushing me to the end of my patience.

However, there is something that I'm not sure I mentioned before, that might help. Basically, those "blackouts" I described above still occur relatively frequently (1-5 times per mission, roughly) , even though nothing changes due to the Disable Setting of Gamma being checked. I wonder if there's some kind of monitor refresh rate issue, or something, going on. Additionally, when enabling cheats, my game tends to lock up for several seconds before resuming (with cheats now enabled, though). It might be related somehow, but I have no idea.

Any help would be greatly appreciated.

EDIT: Some additional info: this problem occurs (with the same frequency and degree) on both my external, VGA-connected monitor and on my laptop's screen. Difference in resolutions doesn't change it, either. My drivers are up to date. My monitor's (and laptop's) refresh rate was increased to see if it made a difference, and it did not.
« Last Edit: July 16, 2012, 09:51:47 pm by SaltyWaffles »
Delenda Est delenda est.

(Yay gratuitous Latin.)