Author Topic: PCS2 freezes at splash screen  (Read 1185 times)

0 Members and 1 Guest are viewing this topic.

PCS2 freezes at splash screen
Hi all,

I'm struggling with a rather strange problem. PCS2 used to work fine, but recently it started hanging on the splash screen and never finishes loading. No error messages whatsoever, it just stops responding. Quite frankly I'm at a loss. Are there any know Windows updates or other software that would prevent PCS2 from starting properly? I recently installed DotNet v4, not sure if that would have had any effect? There also haven't been any GPU recent driver updates from AMD, so I'm inclined to rule GPU problems out.

Running PCS 2.03, on Windows 7 x64. I will happily provide any other system specs you may require. Thanks in advance!

 
Re: PCS2 freezes at splash screen
I had this issue several months ago, turned out that my computer and the new version of PCS2 didn't get along with a certain .dll files and downgrading in my case ended up fixing it (I was also missing a .dll file :wtf:, so re-installing obviously fixed my issue.) I'm sure you've already done this, but if not, try uninstalling/deleting the current vresion of PCS2 and give this version a whirl:

http://www.freespacemods.net/e107_files/downloads/pofcs2-2011-02-19.7z (2.1 Alpha from 2011.)

If that fails, here is the one I'm currently running (2.1 Alpha from 2010; long time back, I know, but maybe it is worth a shot if all else fails.)
Best of luck!

http://www.mediafire.com/?vkrq15snqehvdqz

 
Re: PCS2 freezes at splash screen
Many thanks, I will give it a shot and let you know.

 
Re: PCS2 freezes at splash screen
2.1 Alpha as provided in the second link works, but it doesn't load textures.

 
Re: PCS2 freezes at splash screen
2.1 Alpha as provided in the second link works, but it doesn't load textures.
Look for "Preferences" (or something) in the menus; you need to give PCS2 the path to your FS directory, so it knows where to look for the textures.

 
Re: PCS2 freezes at splash screen
Outstanding, that did the trick! One more thing: There seems to be some form of transparency switched on. When viewing a model, the foreground fades away to make the background parts visible. Can I disable this somehow? Apart from that everything is working 100%, many thanks.
« Last Edit: January 15, 2013, 12:27:35 pm by Herr_Koos »

 
Re: PCS2 freezes at splash screen
Outstanding, that did the trick! One more thing: There seems to be some form of transparency switched on. When viewing a model, the foreground fades away to make the background parts visible. Can I disable this somehow? Apart from that everything is working 100%, many thanks.
Unless someone else knows the problem, could you fire a screenshot this way; I'm unsure if you're referring to a potential model-based problem, just missing a/the right texture to the ship or if it is something beyond that.

 
Re: PCS2 freezes at splash screen
Outstanding, that did the trick! One more thing: There seems to be some form of transparency switched on. When viewing a model, the foreground fades away to make the background parts visible. Can I disable this somehow? Apart from that everything is working 100%, many thanks.

Which model are you trying to view? It sounds a lot like an inverted-normals issue...

 
Re: PCS2 freezes at splash screen
I'm viewing the models from the WC Saga mod. It happens with all models. Simple example in the attachment. Note how the fins at the back of the missile are visible through the body.

[attachment deleted by a basterd]
« Last Edit: January 16, 2013, 03:05:38 pm by Herr_Koos »

 
Re: PCS2 freezes at splash screen
I've got a feeling FSF can give you more guidance than I can on this one. I'd normally say it's a problem with the actual model;
It sounds a lot like an inverted-normals issue...
but I haven't fiddled with this kind of stuff enough to say, let alone provide a solution. Best of luck all the same.

 
Re: PCS2 freezes at splash screen
Definitely looks like a Z-buffer thing, but if it happens with all WCSaga models, inverted normals could hardly be the cause (they're not known for producing buggy models AFAIK). Ehm. Are your GPU drivers up-to-date? Check on your GPU manufacturer's website, don't trust your computer manufacturer or (even worse) Microsoft to get the proper drivers. What happens if you switch PCS2 to solid (textureless) view?

  
Re: PCS2 freezes at splash screen
All sorted now. I will give some more detail in case anyone runs into a similar problem.

GPU settings may have been the problem after all. I always keep my drivers up to date, in fact I'm slightly obsessive about such things. :-) Turns out that may have been my downfall. Out of desperation, I made some changes to my Catalyst profile settings and presets. I created an application profile specifically for PCS, and made all settings application-driven instead of being forced. Somewhere along the line, one of the changes worked, and all models now display normally again.

My guess is that PCS didn't like the forced value of one of my profile settings, but whether it was AA, AF, texture quality, v-sync, buffering, or something else, I cannot tell. Hopefully this knowledge will prove useful to someone in future.

Thanks to everyone for the replies!