Author Topic: -6 Avenger weapons available  (Read 574 times)

0 Members and 1 Guest are viewing this topic.

Offline potterman28wxcv

  • 27
  • Just a fan player
-6 Avenger weapons available
Hello, I am playing with 3.6.18 inferno (SSE), and i was launching the mission The Darkness and the Light from FSport 3.3 (with MediaVPs). I changed somewhat the weapons, giving to alpha 1 and 2 one more avenger (instead of the ML-16), then I ran into the mission. But I forgot to equip with furies, so I left the mission, and I relaunched it. Then, going in the weapon selection screen, there was "-6" avengers available, as you can see in the screenshot : (currently, alpha wing is equipped with exactly 6 avenger guns)

So, I left the game, and relaunched it with the Debug Release. Loading the mission, it crashed : (but it doesn't with the no-debug release)
Code: [Select]
Assert: (this_loadout_weapons[slot->wep[j]] >= 0)
File: missionscreencommon.cpp
Line: 1118
Attempting to restore the previous missions loadout has resulted in an invalid number of weapons available

ntdll.dll! ZwWaitForSingleObject + 21 bytes
kernel32.dll! WaitForSingleObjectEx + 67 bytes
kernel32.dll! WaitForSingleObject + 18 bytes
fs2_open_3_6_18_DEBUG_SSE.exe! SCP_DumpStack + 354 bytes
fs2_open_3_6_18_DEBUG_SSE.exe! WinAssert + 238 bytes
fs2_open_3_6_18_DEBUG_SSE.exe! wss_maybe_restore_loadout + 1216 bytes
fs2_open_3_6_18_DEBUG_SSE.exe! common_select_init + 316 bytes
fs2_open_3_6_18_DEBUG_SSE.exe! brief_init + 508 bytes
fs2_open_3_6_18_DEBUG_SSE.exe! game_enter_state + 663 bytes
fs2_open_3_6_18_DEBUG_SSE.exe! gameseq_set_state + 310 bytes
fs2_open_3_6_18_DEBUG_SSE.exe! game_process_event + 318 bytes
fs2_open_3_6_18_DEBUG_SSE.exe! gameseq_process_events + 152 bytes
fs2_open_3_6_18_DEBUG_SSE.exe! game_main + 782 bytes
fs2_open_3_6_18_DEBUG_SSE.exe! WinMain + 330 bytes
fs2_open_3_6_18_DEBUG_SSE.exe! __tmainCRTStartup + 358 bytes
fs2_open_3_6_18_DEBUG_SSE.exe! WinMainCRTStartup + 15 bytes
kernel32.dll! BaseThreadInitThunk + 18 bytes
ntdll.dll! RtlInitializeExceptionChain + 99 bytes
ntdll.dll! RtlInitializeExceptionChain + 54 bytes

And the debug log is here :
But the three last line are maybe more interessant :
Code: [Select]
ASSERTION: "(this_loadout_weapons[slot->wep[j]] >= 0)" at missionscreencommon.cpp:1118
 Attempting to restore the previous missions loadout has resulted in an invalid number of weapons available
Int3(): From c:\code\fs2_open_3_6_18\code\globalincs\windebug.cpp at line 1040

Anyway, it may happen only with my computer, and it doesn't alter so much the gameplay, so I think it's a very minor bug.


Offline niffiwan

  • 211
  • Eluder Class
Re: -6 Avenger weapons available
This looks like a code bug - would be able to fill out a mantis report for it?

Could you please attach:

1) steps to reproduce (i.e. your post here)
2) your fs2_open.log
3) your pilot files (if you haven't changed them since the problem occurred.

Creating a fs2_open.log | Red Alert Bug = Hex Edit | MediaVPs 2014: Bigger HUD gauges | 32bit libs for 64bit Ubuntu
Debian Packages (testing/unstable): Freespace2 | wxLauncher
m|m: I think I'm suffering from Stockholm syndrome. Bmpman is starting to make sense and it's actually written reasonably well...


Offline potterman28wxcv

  • 27
  • Just a fan player
Re: -6 Avenger weapons available
Done  :)

EDIT : in another mission, the same steps, the same result. I will notice it on mantis
« Last Edit: March 04, 2013, 05:12:27 am by potterman28wxcv »