Author Topic: [Solved] FS2 with MediaVPs 3.8 crashes upon ship destruction  (Read 580 times)

0 Members and 1 Guest are viewing this topic.

[Solved] FS2 with MediaVPs 3.8 crashes upon ship destruction
Hello, new member here. I've been having great fun going through Freespace 1 and ST:R with their respective MediaVPs just fine. However, it all comes crashing down when playing Freespace 2 with MVP 3.8.

As the title states, any time a ship is destroyed, the game will minimize to spit out "Could not find index 'createParticle' in type 'Testing'". A full fs2_open log with all the details will be provided below.

After running FS2 with 2014 MVPs 2.7.2 flawlessly, I'm certain that this occurs ONLY when I use version 3.8.

I installed everything through Knossos. Any help would be appreciated.
« Last Edit: July 13, 2019, 05:23:54 pm by TonyTonsils »

 
Re: FS2 with MediaVPs 3.8 crashes upon ship destruction
Do you use the recent most Nightly built? Log seems to suggest that. It looks like the new LUA Scripting system broke one of the MVP scripts.

 
Re: FS2 with MediaVPs 3.8 crashes upon ship destruction
Do you use the recent most Nightly built? Log seems to suggest that. It looks like the new LUA Scripting system broke one of the MVP scripts.

It appears that I am. Knossos seems to select the most recent build I have as the default.
Selecting 3.8.0-3 from the FSO Settings menu poses a new problem, wherein FS2 crashes on startup. Something about a missing token.

Code: [Select]
Error: game_settings.tbl(line 2):
Error: Missing required token: [#END]. Found [$Target Version:] instead.

File: parselo.cpp
Line: 290

ntdll.dll! ZwWaitForSingleObject + 20 bytes
KERNELBASE.dll! WaitForSingleObjectEx + 162 bytes
fs2_open_3_8_0_x64_AVX.exe! <no symbol>
fs2_open_3_8_0_x64_AVX.exe! <no symbol>
fs2_open_3_8_0_x64_AVX.exe! <no symbol>
fs2_open_3_8_0_x64_AVX.exe! <no symbol>
fs2_open_3_8_0_x64_AVX.exe! <no symbol>
fs2_open_3_8_0_x64_AVX.exe! <no symbol>
fs2_open_3_8_0_x64_AVX.exe! <no symbol>
fs2_open_3_8_0_x64_AVX.exe! <no symbol>
fs2_open_3_8_0_x64_AVX.exe! <no symbol>
fs2_open_3_8_0_x64_AVX.exe! <no symbol>
fs2_open_3_8_0_x64_AVX.exe! <no symbol>
fs2_open_3_8_0_x64_AVX.exe! <no symbol>
fs2_open_3_8_0_x64_AVX.exe! <no symbol>
KERNEL32.DLL! BaseThreadInitThunk + 20 bytes
ntdll.dll! RtlUserThreadStart + 33 bytes

As always, further details are in the fslog below.

 
Re: FS2 with MediaVPs 3.8 crashes upon ship destruction
This one is probably too old.

 
Re: FS2 with MediaVPs 3.8 crashes upon ship destruction
Testing with all three builds I have:
3.8.0-3: Crash on startup
July 12th nightly: Crash on ship blowing up
July 6th nightly: Exact same problem as 7/12 build

It's a complete mystery to me. Interesting side note is that multiple instances of FS2 sometimes start up once the crash happens, but that's likely from me holding down LMB during the crash.

 
Re: FS2 with MediaVPs 3.8 crashes upon ship destruction
I wasn't able to reproduce it on the 6th July built.

 
Re: FS2 with MediaVPs 3.8 crashes upon ship destruction
I wasn't able to reproduce it on the 6th July built.

I must've messed up something when selecting the 7/06 build in Knossos at first, since it's now working perfectly fine after double checking that I picked the right exe.

Everything seems to be in working order now. Culprit was 7/12 build. I guess this can be considered a solved issue.

Thanks for the help! :yes:

 
Re: [Solved] FS2 with MediaVPs 3.8 crashes upon ship destruction
Good to hear it works for you now. :)

 
Re: [Solved] FS2 with MediaVPs 3.8 crashes upon ship destruction
I have this exact same problem. How did you fix it? I don't understand how you solved the issue with the different build version. What are you referring to?

 
Re: [Solved] FS2 with MediaVPs 3.8 crashes upon ship destruction
I'm using a differnt built than the nightly from 12th July. 6th July does work; don't use a too old built though or you'll run into compability issues.

 
Re: [Solved] FS2 with MediaVPs 3.8 crashes upon ship destruction
Where do you select this at and load the july 6 build at?

 
Re: [Solved] FS2 with MediaVPs 3.8 crashes upon ship destruction
I think you can select it somewhere in Knossos - AFAIK (I don't have Knossos) you can select "most recent", "latest stable" and a specific built but I'm not sure.

  

Offline Colt

  • 27
  • Needs more dakka
    • Steam
Re: [Solved] FS2 with MediaVPs 3.8 crashes upon ship destruction
Solaris>Details>Options>FSO Settings. On the top of the window you select the July 6th FSO build (FSO 3.8.1-20190706).