Author Topic: Error running 3.7.0 with mediavps 2014 (SOLVED) i had to compile bin 3.7.2 64bit  (Read 1066 times)

0 Members and 1 Guest are viewing this topic.

Error running 3.7.0 with mediavps 2014 (SOLVED) i had to compile bin 3.7.2 64bit
Hello to everybody!
Here Debian Jessie.

My game works perfectly on mod 3.6.12 with the debian repository launcher (FS2_Open_3.7.0). But if i try to launch the mediavps 2014 i get this error!

Here output when i execute wxlauncher in shell:
[email protected]:~/Escritorio$ wxlauncher
ERROR: "mv_effects-sdf.tbm(line 16): Error: Required token = [#END] or [$Species_Name:], found [$Countermeasure Type:   Type One] ." at parse/parselo.cpp:336
AL lib: (EE) alc_cleanup: 1 device not closed
[email protected]:~/Escritorio$

Any idea? thx!
« Last Edit: February 04, 2015, 06:14:42 pm by MosC_AtheL »

 
Re: AL lib: (EE) alc_cleanup: 1 device not closed
MediaVPs_2014 doesn't work with FS2_Open_3.7.0. You need newer build like 3.7.2 RC5.
I don't know if version compiled on Ubuntu will work on Debian, so you must compile it from source.

About:
Code: [Select]
AL lib: (EE) alc_cleanup: 1 device not closedhttp://stackoverflow.com/questions/16161714/what-does-al-lib-alc-cleanup-1-device-not-closed-mean
Seems harmless info.

 

Offline AdmiralRalwood

  • 211
  • The Cthulhu programmer himself!
    • Skype
    • Steam
    • Twitter
Re: AL lib: (EE) alc_cleanup: 1 device not closed
The actual error is:
Code: [Select]
ERROR: "mv_effects-sdf.tbm(line 16): Error: Required token = [#END] or [$Species_Name:], found [$Countermeasure Type: Type One] ." at parse/parselo.cpp:336
Which, as noted, is because the 2014 MediaVPs are not compatible with FSO 3.7.0.
Ph'nglui mglw'nafh Codethulhu GitHub wgah'nagl fhtagn.

schrödinbug (noun) - a bug that manifests itself in running software after a programmer notices that the code should never have worked in the first place.

When you gaze long into BMPMAN, BMPMAN also gazes into you.

"I am one of the best FREDders on Earth" -General Battuta

<Aesaar> literary criticism is vladimir putin

<MageKing17> "There's probably a reason the code is the way it is" is a very dangerous line of thought. :P
<MageKing17> Because the "reason" often turns out to be "nobody noticed it was wrong".
(the very next day)
<MageKing17> this ****ing code did it to me again
<MageKing17> "That doesn't really make sense to me, but I'll assume it was being done for a reason."
<MageKing17> **** ME
<MageKing17> THE REASON IS PEOPLE ARE STUPID
<MageKing17> ESPECIALLY ME

<MageKing17> God damn, I do not understand how this is breaking.
<MageKing17> Everything points to "this should work fine", and yet it's clearly not working.
<MjnMixael> 2 hours later... "God damn, how did this ever work at all?!"
(...)
<MageKing17> so
<MageKing17> more than two hours
<MageKing17> but once again we have reached the inevitable conclusion
<MageKing17> How did this code ever work in the first place!?

<@The_E> Welcome to OpenGL, where standards compliance is optional, and error reporting inconsistent

<MageKing17> It was all working perfectly until I actually tried it on an actual mission.

<IronWorks> I am useful for FSO stuff again. This is a red-letter day!
* z64555 erases "Thursday" and rewrites it in red ink

<MageKing17> TIL the entire homing code is held up by shoestrings and duct tape, basically.

 

Offline jr2

  • The Mail Man
  • 212
  • It's prounounced jayartoo 0x6A7232
    • Steam
Re: AL lib: (EE) alc_cleanup: 1 device not closed
MediaVPs_2014 doesn't work with FS2_Open_3.7.0. You need newer build like 3.7.2 RC5.
I don't know if version compiled on Ubuntu will work on Debian, so you must compile it from source.

About:
Code: [Select]
AL lib: (EE) alc_cleanup: 1 device not closedhttp://stackoverflow.com/questions/16161714/what-does-al-lib-alc-cleanup-1-device-not-closed-mean
Seems harmless info.

Ubuntu is based on Debian.  So who knows (maybe?).

 
Re: AL lib: (EE) alc_cleanup: 1 device not closed
WOW! Really thank you for your fast and precise answer!

The compiled one for ubuntu you linked does not generate flag because some 32bits libs are missing. I think it is because it have been compiled for a 32 bits O.S and i use 64bits

So i m gonna to compile a launcher for my system and i will tell you how it works!

THX AGAIN! :)

----------------------------------------------------------------------------------------------------

GRRRRRRR REALLY!

Compiling this binary has been very...  :banghead:

I struggled in many errors, dependencies etc... I had to redo the job several times to get it finnaly done!!!  ;7.

Just some... issue: At wxlauncher bottom window i see this: OpenAL:463: Unknown error number 0x0000a004. :\ 
I found this:
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=749834
https://code.google.com/p/wxlauncher/issues/detail?id=110
but i won't work on this yet.

Than you all!

« Last Edit: February 04, 2015, 06:18:04 pm by MosC_AtheL »

  
Re: Error running 3.7.0 with mediavps 2014 (SOLVED) i had to compile bin 3.7.2 64bit
The way to get the 32 bit versions compiled here to work is to install all the 32 bit libs by appending
Code: [Select]
:i386 to each dependency.

See: http://www.hard-light.net/forums/index.php?topic=87563.msg1749218#msg1749218