Author Topic: Cannot play last mission of WiH part 2  (Read 989 times)

0 Members and 1 Guest are viewing this topic.

Offline Mort

  • 26
  • The dog that went meow
Cannot play last mission of WiH part 2
Currently, once the loading bar for the last mission fills up, I get this error. Please help. I installed the game through the FSO installer just 2 weeks ago.

Malloc Failed!

ntdll.dll! NtWaitForSingleObject + 21 bytes
kernel32.dll! WaitForSingleObjectEx + 67 bytes
kernel32.dll! WaitForSingleObject + 18 bytes
fs2_open_3_7_4_SSE2.exe! SCP_DumpStack + 213 bytes
fs2_open_3_7_4_SSE2.exe! bm_lock_dds + 72 bytes
fs2_open_3_7_4_SSE2.exe! bm_load_image_data + 265 bytes
fs2_open_3_7_4_SSE2.exe! bm_load_image_data + 133 bytes
fs2_open_3_7_4_SSE2.exe! bm_lock + 135 bytes
fs2_open_3_7_4_SSE2.exe! bm_free_data_fast + 38 bytes
fs2_open_3_7_4_SSE2.exe! opengl_create_texture + 167 bytes
fs2_open_3_7_4_SSE2.exe! gr_opengl_tcache_set_internal + 174 bytes
<no module>! <no symbol>
<no module>! <no symbol>
fs2_open_3_7_4_SSE2.exe! Weapon_info + 620749 bytes
<no module>! <no symbol>
<no module>! <no symbol>
<no module>! <no symbol>
<no module>! <no symbol>
<no module>! <no symbol>
<no module>! <no symbol>
<no module>! <no symbol>
<no module>! <no symbol>
<no module>! <no symbol>
<no module>! <no symbol>


[attachment deleted by admin]
« Last Edit: September 04, 2016, 10:18:59 pm by Mort »

 

Offline AdmiralRalwood

  • 211
  • The Cthulhu programmer himself!
    • Skype
    • Steam
    • Twitter
Re: Cannot play last mission of WiH part 2
Malloc Failed!
FSO is running out of usable memory. There's very little that can be done about this except to attempt to reduce how much memory FSO is using. You can try deleting/renaming the extension of/moving to somewhere FSO won't load them from the following files to see if it helps:
Code: [Select]
F:\Program Files (x86)\GOG.com\Freespace 2\bpcomplete\bpc-advanced1.vp
F:\Program Files (x86)\GOG.com\Freespace 2\bpcomplete\bpc-advanced2.vp
F:\Program Files (x86)\GOG.com\Freespace 2\bpcomplete\bpc-advanced3.vp
F:\Program Files (x86)\GOG.com\Freespace 2\mediavps_2014\MV_Advanced.vp
F:\Program Files (x86)\GOG.com\Freespace 2\mediavps_2014\MV_A-Glows.vp
If do that and FSO still gives a "Malloc Failed!" error, then there's really nothing to be done (unless your computer has at least 4 GB of RAM, in which case a 64-bit build would help... but we don't yet provide 64-bit nightly builds, so someone would have to compile one for you).
Ph'nglui mglw'nafh Codethulhu GitHub wgah'nagl fhtagn.

schrödinbug (noun) - a bug that manifests itself in running software after a programmer notices that the code should never have worked in the first place.

When you gaze long into BMPMAN, BMPMAN also gazes into you.

"I am one of the best FREDders on Earth" -General Battuta

<Aesaar> literary criticism is vladimir putin

<MageKing17> "There's probably a reason the code is the way it is" is a very dangerous line of thought. :P
<MageKing17> Because the "reason" often turns out to be "nobody noticed it was wrong".
(the very next day)
<MageKing17> this ****ing code did it to me again
<MageKing17> "That doesn't really make sense to me, but I'll assume it was being done for a reason."
<MageKing17> **** ME
<MageKing17> THE REASON IS PEOPLE ARE STUPID
<MageKing17> ESPECIALLY ME

<MageKing17> God damn, I do not understand how this is breaking.
<MageKing17> Everything points to "this should work fine", and yet it's clearly not working.
<MjnMixael> 2 hours later... "God damn, how did this ever work at all?!"
(...)
<MageKing17> so
<MageKing17> more than two hours
<MageKing17> but once again we have reached the inevitable conclusion
<MageKing17> How did this code ever work in the first place!?

<@The_E> Welcome to OpenGL, where standards compliance is optional, and error reporting inconsistent

<MageKing17> It was all working perfectly until I actually tried it on an actual mission.

<IronWorks> I am useful for FSO stuff again. This is a red-letter day!
* z64555 erases "Thursday" and rewrites it in red ink

<MageKing17> TIL the entire homing code is held up by shoestrings and duct tape, basically.

 

Offline Mort

  • 26
  • The dog that went meow
Re: Cannot play last mission of WiH part 2
Thanks. Deleted the high res texture files and the mission loaded. A shame though.

EDIT: Whole mission ran fine until the debriefing and the same error popped up when i clicked accept
« Last Edit: September 05, 2016, 09:58:26 am by Mort »