Author Topic: PUBLIC BETA: Knossos 0.14.3 (combined launcher/installer)  (Read 183141 times)

0 Members and 3 Guests are viewing this topic.

Offline Goober5000

  • HLP Loremaster
  • Administrator
  • 214
    • Goober5000 Productions
Re: PUBLIC BETA: Knossos 0.13.3 (combined launcher/installer)
The primary developer, ngld, has been inactive due to Real Life issues, and unfortunately, nobody else knows how to release builds for Knossos on anything other than Windows.

If you or anyone can help or provide insight into this, it would be very much appreciated.

 
Re: PUBLIC BETA: Knossos 0.13.3 (combined launcher/installer)
Here we go, easy as 1, 2, 3

Code: [Select]
sudo apt install nodejs npm python3-wheel python3-setuptools pyqt5-dev pyqt5-dev-tools qttools5-dev-tools qt5-default curl
sudo apt-get install python3-pyqt5.qtwebengine python3-pyqt5.qtwebchannel python3-requests-toolbelt python3-ply
wget http://ppa.launchpad.net/ngld/knossos/ubuntu/pool/main/p/python3-semantic-version/python3-semantic-version_2.3.1-1_all.deb
wget http://ppa.launchpad.net/ngld/knossos/ubuntu/pool/main/k/knossos/knossos_0.13.3-1~cosmic1_all.deb
wget http://ppa.launchpad.net/ngld/knossos/ubuntu/pool/main/p/python3-token-bucket/python3-token-bucket_0.2.0-1_all.deb
wget http://de.archive.ubuntu.com/ubuntu/pool/universe/p/python-raven/python3-raven_6.3.0-2_all.deb
curl https://raw.githubusercontent.com/pypa/pipenv/master/get-pipenv.py | sudo python3
curl -sS https://dl.yarnpkg.com/debian/pubkey.gpg | sudo apt-key add -
echo "deb https://dl.yarnpkg.com/debian/ stable main" | sudo tee /etc/apt/sources.list.d/yarn.list
sudo apt update && sudo apt install yarn
pipenv install
yarn install
sudo dpkg -i *.deb

After running "knossos" from command line there is an error message popping up

Code: [Select]
I don't know how to handle "\override_dh_link"! I only know fso:// .Any ideas?

Edith says: This can be corrected by this one-liner (see below):

Code: [Select]
echo 'exec python3 /usr/share/knossos/knossos/__main__.py "[email protected]"' | sudo tee /usr/bin/knossos
« Last Edit: May 16, 2020, 04:16:33 am by praseodym »

 

Offline jr2

  • The Mail Man
  • 212
  • It's prounounced jayartoo 0x6A7232
    • Steam
Re: PUBLIC BETA: Knossos 0.13.3 (combined launcher/installer)
Here we go, easy as 1, 2, 3

Code: [Select]
sudo apt install nodejs npm python3-wheel python3-setuptools pyqt5-dev pyqt5-dev-tools qttools5-dev-tools qt5-default curl
sudo apt-get install python3-pyqt5.qtwebengine python3-pyqt5.qtwebchannel python3-requests-toolbelt python3-ply
wget http://ppa.launchpad.net/ngld/knossos/ubuntu/pool/main/p/python3-semantic-version/python3-semantic-version_2.3.1-1_all.deb
wget http://ppa.launchpad.net/ngld/knossos/ubuntu/pool/main/k/knossos/knossos_0.13.3-1~cosmic1_all.deb
wget http://ppa.launchpad.net/ngld/knossos/ubuntu/pool/main/p/python3-token-bucket/python3-token-bucket_0.2.0-1_all.deb
wget http://de.archive.ubuntu.com/ubuntu/pool/universe/p/python-raven/python3-raven_6.3.0-2_all.deb
curl https://raw.githubusercontent.com/pypa/pipenv/master/get-pipenv.py | sudo python3
curl -sS https://dl.yarnpkg.com/debian/pubkey.gpg | sudo apt-key add -
echo "deb https://dl.yarnpkg.com/debian/ stable main" | sudo tee /etc/apt/sources.list.d/yarn.list
sudo apt update && sudo apt install yarn
pipenv install
yarn install
sudo dpkg -i *.deb

After running "knossos" from command line there is an error message popping up

Code: [Select]
I don't know how to handle "\override_dh_link"! I only know fso:// .Any ideas?

Fix can be found here:

Quote from: ngld
Sorry, this is a bug in the current Ubuntu package. This will hopefully be solved by the next release. In the meantime you can solve the issue by replacing "\override_dh_link" with "[email protected]" in /usr/bin/knossos.

 
Re: PUBLIC BETA: Knossos 0.13.3 (combined launcher/installer)
Worked!

THX

 
Re: PUBLIC BETA: Knossos 0.13.3 (combined launcher/installer)
Code: [Select]
[ 2567.716064] traps: QtWebEngineProc[3964] trap int3 ip:7f45a9d10cd3 sp:7ffdb95e8ee0 error:0 in libQt5WebEngineCore.so.5.12.8[7f45a561c000+4fac000]
[ 3351.918255] traps: QtWebEngineProc[4239] trap int3 ip:7fe7189f0cd3 sp:7ffe25160e90 error:0 in libQt5WebEngineCore.so.5.12.8[7fe7142fc000+4fac000]

Error when loading the installed mods after installing Retail. Ideas?

Edith says: No such error when using 20.04 instead of 18.04
« Last Edit: May 13, 2020, 09:21:04 am by praseodym »

 

Offline maz1417

  • 20
Re: PUBLIC BETA: Knossos 0.13.3 (combined launcher/installer)
Hey guys.

Been having a problem with Knossos 0.14.

It used to run without a hitch, played FSPORT with MediaVP's and everything. But now all of a sudden, whenever I hit play on any of the mods on Knossos it just shows FSO launching for a second then nothing. Nothing launches at all, which is weird since I didn't change anything in the setting.

I switched to nightly build, I'm using the Steam version of Freespace 2, installed in the C drive. Not a single mod works.

Any help is appreciated, really don't wanna go back to unpacking all the mods manually.

 
Re: PUBLIC BETA: Knossos 0.13.3 (combined launcher/installer)
Check antivirus if it doesn't block fso.

 
Re: PUBLIC BETA: Knossos 0.13.3 (combined launcher/installer)
Also, it's possible you installed FSO into some location that requires admin access to modify.
Mito [PL] - Today at 8:52 PM
I was supposed to make a short presentation about basics of optical fibers and here I am, listening to Eurobeat while reading about quantum cryptography.

 

Offline anagram

  • 22
Re: PUBLIC BETA: Knossos 0.13.3 (combined launcher/installer)
Hy people!

Anyone knows how to compile knossos in Ubuntu 20.04 ?

pipenv install fails. Looks like knossos is using a old version of sip and that can't be installed using pip.


An error occurred while installing sip==4.19.8! Will try again.
Installing initially–failed dependencies…
Looking in indexes: https://pypi.python.org/simple00

ERROR: Could not find a version that satisfies the requirement sip==4.19.8 (from -r /tmp/pipenv-22gd3riz-requirements/pipenv-d8e7ucan-requirement.txt (line 1)) (from versions: 5.0.0, 5.0.1, 5.1.0, 5.1.1, 5.1.2, 5.2.0)
ERROR: No matching distribution found for sip==4.19.8 (from -r /tmp/pipenv-22gd3riz-requirements/pipenv-d8e7ucan-requirement.txt (line 1))



Anyone can help?

 
Re: PUBLIC BETA: Knossos 0.13.3 (combined launcher/installer)
Try 0.13 as described above. It works here in MATE 20.04

 
Re: PUBLIC BETA: Knossos 0.13.3 (combined launcher/installer)
Yet another question: Do I really need to install all of the possible mediavps possible (3.8.0, 3.8.1, 3.8.2, etc) for compatibility reasons?! Do the respective builds refer to the same or to its own mediavps? Otherwise, the HDD is pretty full in a short time...

How to solve that if the standard build for each campaign refers to the respective medivps?

 

Offline anagram

  • 22
Re: PUBLIC BETA: Knossos 0.13.3 (combined launcher/installer)
Try 0.13 as described above. It works here in MATE 20.04

Now the error is longer, but the same result


An error occurred while installing sip==4.19.8 --hash=sha256:09f9a4e6c28afd0bafedb26ffba43375b97fe7207bd1a0d3513f79b7d168b3 31 --hash=sha256:105edaaa1c8aa486662226360bd3999b4b89dd56de3e314d82b83ed0587d87 83 --hash=sha256:1bb10aac55bd5ab0e2ee74b3047aa2016cfa7932077c73f602a6f6541af8cd 51 --hash=sha256:265ddf69235dd70571b7d4da20849303b436192e875ce7226be7144ca702a4 5c --hash=sha256:52074f7cb5488e8b75b52f34ec2230bc75d22986c7fe5cd3f2d266c23f3349 a7 --hash=sha256:5ff887a33839de8fc77d7f69aed0259b67a384dc91a1dc7588e328b0b980bd e2 --hash=sha256:74da4ddd20c5b35c19cda753ce1e8e1f71616931391caeac2de7a1715945c6 79 --hash=sha256:7d69e9cf4f8253a3c0dfc5ba6bb9ac8087b8239851f22998e98cb35cfe497b 68 --hash=sha256:97bb93ee0ef01ba90f57be2b606e08002660affd5bc380776dd8b0fcaa9e09 3a --hash=sha256:cf98150a99e43fda7ae22abe655b6f202e491d6291486548daa56cb15a2fcf 85 --hash=sha256:d9023422127b94d11c1a84bfa94933e959c484f2c79553c1ef23c69fe00d25 f8 --hash=sha256:e72955e12f4fccf27aa421be383453d697b8a44bde2cc26b08d876fd492d01 74! Will try again.
Installing initially failed dependencies%u2026
[pipenv.exceptions.InstallError]:   File "/usr/local/lib/python3.8/dist-packages/pipenv/core.py", line 1863, in do_install
[pipenv.exceptions.InstallError]:       do_init(
[pipenv.exceptions.InstallError]:   File "/usr/local/lib/python3.8/dist-packages/pipenv/core.py", line 1246, in do_init
[pipenv.exceptions.InstallError]:       do_install_dependencies(
[pipenv.exceptions.InstallError]:   File "/usr/local/lib/python3.8/dist-packages/pipenv/core.py", line 858, in do_install_dependencies
[pipenv.exceptions.InstallError]:       batch_install(
[pipenv.exceptions.InstallError]:   File "/usr/local/lib/python3.8/dist-packages/pipenv/core.py", line 763, in batch_install
[pipenv.exceptions.InstallError]:       _cleanup_procs(procs, not blocking, failed_deps_queue, retry=retry)
[pipenv.exceptions.InstallError]:   File "/usr/local/lib/python3.8/dist-packages/pipenv/core.py", line 681, in _cleanup_procs
[pipenv.exceptions.InstallError]:       raise exceptions.InstallError(c.dep.name, extra=err_lines)
[pipenv.exceptions.InstallError]: ['Looking in indexes: https://pypi.python.org/simple']
[pipenv.exceptions.InstallError]: ['ERROR: Could not find a version that satisfies the requirement sip==4.19.8 (from -r /tmp/pipenv-mq7t3pny-requirements/pipenv-goe747bp-requirement.txt (line 1)) (from versions: 5.0.0, 5.0.1, 5.1.0, 5.1.1, 5.1.2, 5.2.0)', 'ERROR: No matching distribution found for sip==4.19.8 (from -r /tmp/pipenv-mq7t3pny-requirements/pipenv-goe747bp-requirement.txt (line 1))']
ERROR: ERROR: Package installation failed...


 
Re: PUBLIC BETA: Knossos 0.13.3 (combined launcher/installer)
Thats the output of which command? pipenv install?

 
Re: PUBLIC BETA: Knossos 0.13.3 (combined launcher/installer)
Hy people!

Anyone knows how to compile knossos in Ubuntu 20.04 ?

pipenv install fails. Looks like knossos is using a old version of sip and that can't be installed using pip.


An error occurred while installing sip==4.19.8! Will try again.
Installing initially–failed dependencies…
Looking in indexes: https://pypi.python.org/simple00

ERROR: Could not find a version that satisfies the requirement sip==4.19.8 (from -r /tmp/pipenv-22gd3riz-requirements/pipenv-d8e7ucan-requirement.txt (line 1)) (from versions: 5.0.0, 5.0.1, 5.1.0, 5.1.1, 5.1.2, 5.2.0)
ERROR: No matching distribution found for sip==4.19.8 (from -r /tmp/pipenv-22gd3riz-requirements/pipenv-d8e7ucan-requirement.txt (line 1))



Anyone can help?

Ubuntu 20.04 (and derivatives) ship with Python 3.8.2, but knossos is built with Python 3.6.10. You may need to use virtualenv or asdf to setup a non-system python environment to get it to build. I had to on Pop!_OS 20.04.

Additionally, there is a bug in pyqt5 5.10.1 that prevents building/running of knossos on Ubuntu 19.10 and 20.04 (and derivatives). Bumping it up to 5.11.2 or dropping it to 5.9.2 and running pipenv install allows it to build and run.

 

Offline anagram

  • 22
Re: PUBLIC BETA: Knossos 0.13.3 (combined launcher/installer)
Thats the output of which command? pipenv install?
yes

 
Re: PUBLIC BETA: Knossos 0.13.3 (combined launcher/installer)
Weird, for some other reason I installed Ubuntu instead, here it works as well.

Try first

Code: [Select]
sudo apt-get update
sudo apt-get install --reinstall python3 build-essential libasound2:i386 libasyncns0:i386 libavahi-client-dev:i386 libc6:i386 libcaca0:i386 libdbus-1-3:i386 libflac8:i386 libgcc1:i386 libglu1-mesa:i386 libjansson4:i386 libjpeg-turbo8:i386 liblua5.1-0:i386 libncursesw5:i386 libogg0:i386 libopenal1:i386 libpulse0:i386 libpulse-dev:i386 libsdl1.2debian:i386 libsdl1.2-dev:i386 libslang2:i386 libsndfile1:i386 libstdc++6:i386 libtheora0:i386 libtinfo5:i386 libvorbis0a:i386 libvorbisenc2:i386 libvorbisfile3:i386 libwrap0:i386 libx11-6:i386 libxau6:i386 libxcb1:i386 libxdmcp6:i386 libxext6:i386 zlib1g:i386
sudo apt-get install --reinstall nodejs npm python3-wheel python3-setuptools pyqt5-dev pyqt5-dev-tools qttools5-dev-tools qt5-default curl python3-pyqt5.qtwebengine python3-pyqt5.qtwebchannel python3-requests-toolbelt python3-ply
sudo add-apt-repository ppa:linuxuprising/libpng12
sudo apt-get update
sudo apt-get install libpng12-0
You better c/p those lines

 

Offline anagram

  • 22
Re: PUBLIC BETA: Knossos 0.13.3 (combined launcher/installer)
It didn't work...

What version of Ubuntu do you have?

I think moduletux is right. I will need to use Python 3.6.10 to compile it. I have to learn how to setup a virtualenv with python first...   :sigh:

 
Re: PUBLIC BETA: Knossos 0.13.3 (combined launcher/installer)
I have 20.04 64bit

python3 --version
Code: [Select]
Python 3.8.2It worked here

 
Re: PUBLIC BETA: Knossos 0.13.3 (combined launcher/installer)
@praseodym It worked for me on Xubuntu 20.04  THANK YOU

 
Re: PUBLIC BETA: Knossos 0.13.3 (combined launcher/installer)
Glad it worked.

Obviously, there is something wrong with MATE, see the libqt5webengine errors above (at least in 18.04), with XFCE under MATE it worked as well, compiling was never a problem here.
« Last Edit: May 16, 2020, 04:18:39 am by praseodym »