Author Topic: PUBLIC BETA: Knossos 0.14.3 (combined launcher/installer)  (Read 189521 times)

0 Members and 1 Guest are viewing this topic.

Offline Iido

Re: PUBLIC BETA: Knossos 0.14.3 (combined launcher/installer)
THAT FIXED IT! It works now, thank you so much! I had already re-downloaded the installer for the last couple of attempts, so, the problem must have been the %appdata%\HardLightProductions\FreeSpaceOpen folder. Deleting that was the only thing I did differently this time.

Finally, time to get back to playing some mods! :D I outta take a spin through FS2 again soon too, it's been quite a while since I played... hey, I may do that first.

 

Offline Tarvis

  • 26
Re: PUBLIC BETA: Knossos 0.14.3 (combined launcher/installer)
Is there any way to stop campaign mods from installing or using MVPs?

Let's say hypothetically I prefer playing with original graphics, and I want to try something like ST:R. I cannot untick everything in the MVP checkboxes when it prompts the user for what to download even though ST:R does not require MVPs. So I'm forced to wait and download several GBs of the MVPs stuff before I can play, even if I'm just going to go and delete the MVPs.

And even if I did keep MVPs, I feel like there should be a better way in Knossos of handling optional mods like MVPs, cause it seems like it will always use it if it's there. A way of right clicking the mod and disabling the optional mods it specifies. That way I could decide when I want to or dont want to play using MVPs, just like I can play FS2 retail without them.

 

Offline Mobius

  • Back where he started
  • 213
  • Porto l'azzurro Dolce Stil Novo nella fantascienza
    • Skype
    • Twitter
    • The Lightblue Ribbon | Cultural Project
Re: PUBLIC BETA: Knossos 0.14.3 (combined launcher/installer)
The point about MVPs is that many mods actually require them. It means that they just won't run without the MVPs and/or they'll result in several bugs if run.

Additional settings normally allow to choose how far the graphics can be pushed in FSO (Advanced MVPs aren't a requirement, for example, and can be toggled on/off depending on the performance of your computer), but that's a different side of the coin.

 
Re: PUBLIC BETA: Knossos 0.14.3 (combined launcher/installer)
And even if I did keep MVPs, I feel like there should be a better way in Knossos of handling optional mods like MVPs, cause it seems like it will always use it if it's there.

I do think there needs to be a way for users to easily modify the mod stack when launching. Overriding version requirements, removing or inserting mods or whole packages, and anything else of the sort, without going into the develop tab or editing json. People inserting cockpit mods or high resolution HUD mods would benefit, and it'd make working around mods with bad version requirements much less painful.

 
 
Re: PUBLIC BETA: Knossos 0.14.3 (combined launcher/installer)
Hi, today I tried to launch Blue Planet Complete mod and received this error as attached. Please assist.

"A critical error occured! Knossos might not work correctly until you restart it.

The error has been reported and will hopefully be fixed soon. If you want to help, report this bug on our Dscord channel, in the HLP thread or on GitHub. Just click a button below to open the relevant page."

I restarted the launcher and my computer a few times, it's still not working.
I'm a great collector of mods, 73 and counting! Ask me for the list.

 
Re: PUBLIC BETA: Knossos 0.14.3 (combined launcher/installer)
Try verifying the file integrity.

P.S.:  BPcomplete is version 1.1.1 here!

 

Offline Rajive

  • 22
Re: PUBLIC BETA: Knossos 0.13.3 (combined launcher/installer)
Those strings appear in the retail FS2 strings.tbl game file:

Code: [Select]
;-------------------------------------------------
; File: MainHallMenu.cpp
;-------------------------------------------------

353, "(fr)Exit FreeSpace 2"
354, "(fr)Barracks - Manage your FreeSpace 2 pilots"
355, "Salle de départ - Commencer ou continuer une campagne"
356, "(fr)Tech room - View specifications of FreeSpace 2 ships and weaponry"
357, "(fr)Options - Change your FreeSpace 2 options"
358, "(fr)Campaign Room - View all available campaigns"
359, "Multijoueur - Lancer ou joindre une partie multijoueur"
360, "Vous n'avez pas défini le type de connexion Internet. Lancez le programme d'installation, sélectionnez l'option Installation puis l'onglet Réseau pour choisir le type de connexion."
361, "Winsock n'est pas installé. Il vous faut TCP/IP et Winsock pour jouer à FreeSpace en mode multijoueur."
362, "(fr)You have selected TCP/IP for multiplayer Freespace, but the TCP/IP protocol was not detected on your machine."
363, "Vous avez sélectionné la Connexion via modem pour vous connecter à l'Internet. Vous n'êtes pas connecté pour l'instant. Connectez-vous à votre prestataire de service Internet avant d'aller plus loin. "
364, "Vous avez indiqué que vous utilisez une connexion LAN pour les parties en réseau. On dirait que vous êtes connecté à votre prestataire de service Internet. Veuillez vous déconnecter, ou choisissez "
365, "Quitter le jeu ?"
366, "Les pilotes multijoueurs n'ont pas accès à la salle de campagne"
367, "Pilote mutlijoueur non valide !"
368, "'Charger mission' invalide pour pilotes multijoueurs"
369, "Démarrage rapide invalide pour pilotes multijoueurs "
370, "Niveau de difficulté: %s."
371, "Appuyez sur F1 pour afficher l'aide"

My guess is that the French translation was never finished, and the (fr) prefix indicated that the string still remained to be translated.

My question then, Rajive, is how you managed to play a version of the game that did not have this issue.  Did you reinstall FSO using a different method -- GOG, Steam, or CD?


I know it's been months since you asked that, my appologies.

At this time time I had FS1 and 2 on CD. I installed them, then installed FSO with the java installator. From what I remember I used FS1 file to get FSport in french, and a fan made translation for texte in FS2.
I still get those CD somewere but I think they wont work on W10.

 
Re: PUBLIC BETA: Knossos 0.14.3 (combined launcher/installer)
Try verifying the file integrity.

P.S.:  BPcomplete is version 1.1.1 here!

I have updated to version 1.1.1, it is still not working.

I have tried to launch other mods in the Knossos launcher. Mods such as Exile, Inferno Nostos, Aftermath Reboot, Sync, etc. are also not working.
I'm a great collector of mods, 73 and counting! Ask me for the list.

 

Offline jg18

  • A very happy zod
  • 210
  • can do more than spellcheck
Re: PUBLIC BETA: Knossos 0.14.3 (combined launcher/installer)
Can any Mac Mojave users assist below?

https://www.reddit.com/r/freespace/comments/jgh64x/does_freespace_open_work_on_mac_mojave_10146/
Thanks for posting here about this. I'm not on Reddit but am working on some Mac fixes for FSO and Knossos. If a Mac player is up for trying out a test build, they can PM me on HLP for details. If they post on #knossos on Discord, I'll probably see it, but a PM here is more reliable.

I have updated to version 1.1.1, it is still not working.

I have tried to launch other mods in the Knossos launcher. Mods such as Exile, Inferno Nostos, Aftermath Reboot, Sync, etc. are also not working.
A Knossos log would provide more details on the errors. Can you post yours as an attachment?

If you're on Windows, you can find the log by opening Explorer (Windows key + E) then in the address bar, type %appdata%\knossos and press Enter. The log file is called log.txt.

EDIT: I know that the error message says that the error has been reported, but only ngld has access to those reports.
« Last Edit: November 08, 2020, 01:07:12 am by jg18 »

 
Re: PUBLIC BETA: Knossos 0.14.3 (combined launcher/installer)
I have updated to version 1.1.1, it is still not working.

I have tried to launch other mods in the Knossos launcher. Mods such as Exile, Inferno Nostos, Aftermath Reboot, Sync, etc. are also not working.
A Knossos log would provide more details on the errors. Can you post yours as an attachment?

If you're on Windows, you can find the log by opening Explorer (Windows key + E) then in the address bar, type %appdata%\knossos and press Enter. The log file is called log.txt.

EDIT: I know that the error message says that the error has been reported, but only ngld has access to those reports.

Yes I am using Windows 10. Here is the log file in the attachment.
I'm a great collector of mods, 73 and counting! Ask me for the list.

 

Offline jg18

  • A very happy zod
  • 210
  • can do more than spellcheck
Re: PUBLIC BETA: Knossos 0.14.3 (combined launcher/installer)
Thanks for providing a log. It was very helpful.

Whenever you run the game, Knossos updates the timestamp for when you last played that specific mod. The log says that Knossos is getting a "permission denied" error when it tries to update the relevant file in your Knossos library folder.

The example from your log is for Inferno:

Code: [Select]
D:\Games\Knossos\FS2\Inferno-1.0.0\user.json

Can you check if this file exists? Open Windows Explorer, paste D:\Games\Knossos\FS2\Inferno-1.0.0 into the address bar, press Enter, and check if the file user.json is there.

If the file does exist, is there some reason why Knossos would not have permission to access it?

You can try running Knossos as administrator, although I'm not sure that should be necessary.

 

Offline jr2

  • The Mail Man
  • 212
  • It's prounounced jayartoo 0x6A7232
    • Steam
Re: PUBLIC BETA: Knossos 0.14.3 (combined launcher/installer)
Hunch: If the file exists, try running
Code: [Select]
chkdsk d: /f and see if that fixes it (wondering if it's a dirty shutdown in the middle of updating \Inferno-1.0.0\user.json)

 
Re: PUBLIC BETA: Knossos 0.14.3 (combined launcher/installer)
Thanks for providing a log. It was very helpful.

Whenever you run the game, Knossos updates the timestamp for when you last played that specific mod. The log says that Knossos is getting a "permission denied" error when it tries to update the relevant file in your Knossos library folder.

The example from your log is for Inferno:

Code: [Select]
D:\Games\Knossos\FS2\Inferno-1.0.0\user.json

Can you check if this file exists? Open Windows Explorer, paste D:\Games\Knossos\FS2\Inferno-1.0.0 into the address bar, press Enter, and check if the file user.json is there.

If the file does exist, is there some reason why Knossos would not have permission to access it?

You can try running Knossos as administrator, although I'm not sure that should be necessary.

Yes, the user.json file exists in the folder I have in my personal computer.
I'm a great collector of mods, 73 and counting! Ask me for the list.

  
Re: PUBLIC BETA: Knossos 0.14.3 (combined launcher/installer)
Thanks for providing a log. It was very helpful.

Whenever you run the game, Knossos updates the timestamp for when you last played that specific mod. The log says that Knossos is getting a "permission denied" error when it tries to update the relevant file in your Knossos library folder.

The example from your log is for Inferno:

Code: [Select]
D:\Games\Knossos\FS2\Inferno-1.0.0\user.json

Can you check if this file exists? Open Windows Explorer, paste D:\Games\Knossos\FS2\Inferno-1.0.0 into the address bar, press Enter, and check if the file user.json is there.

If the file does exist, is there some reason why Knossos would not have permission to access it?

You can try running Knossos as administrator, although I'm not sure that should be necessary.

Yes, the user.json file exists in the folder I have in my personal computer.

Hi, I managed to find a simple solution for it, I deleted the existing user.json file and re-run the mods via Knossos, they are working again.
I'm a great collector of mods, 73 and counting! Ask me for the list.

 

Offline Rico

Re: PUBLIC BETA: Knossos 0.14.3 (combined launcher/installer)
Hey Guys,

It appears the Ubuntu repo hasn't been updated for 20.04 LTS as I receive this error when I try to add it:

Code: [Select]
[email protected]:~$ sudo add-apt-repository ppa:ngld/knossos
Cannot add PPA: ''This PPA does not support focal''.

I'm trying to install on Linux Mint 20 which uses Ubuntu 20.04 LTS.

Regards,
Rico

 
Re: PUBLIC BETA: Knossos 0.14.3 (combined launcher/installer)
That repo doesnt work anymore in 20.04. Here, under Ubuntu MATE 20.04 use this approach:
Code: [Select]
sudo apt-get install python3 git build-essential libasyncns0:i386 libavahi-client-dev:i386 libc6:i386 libcaca0:i386 libdbus-1-3:i386 libflac8:i386 libgcc1:i386 libglu1-mesa:i386 libjansson4:i386 libjpeg-turbo8:i386 liblua5.1-0:i386 libncursesw5:i386 libogg0:i386 libopenal1:i386 libpulse0:i386 libpulse-dev:i386 libsdl1.2debian:i386 libsdl1.2-dev:i386 libslang2:i386 libsndfile1:i386 libstdc++6:i386 libtheora0:i386 libtinfo5:i386 libvorbis0a:i386 libvorbisenc2:i386 libvorbisfile3:i386 libwrap0:i386 libx11-6:i386 libxau6:i386 libxcb1:i386 libxdmcp6:i386 libxext6:i386 zlib1g:i386 python3-wheel python3-setuptools pyqt5-dev pyqt5-dev-tools qttools5-dev-tools qt5-default curl python3-pyqt5.qtwebengine python3-pyqt5.qtwebchannel python3-requests-toolbelt python3-ply git p7zip-full libopenal-dev ninja-build pipenv yarnpkg python3-semantic-version libsdl2-dev
sudo add-apt-repository     ppa:linuxuprising/libpng12
sudo apt-get update
sudo apt-get install libpng12-0
git clone -b master https://github.com/ngld/knossos.git
cd knossos
pip3 install token-bucket
yarnpkg install
python3 configure.py
ninja run
From the howto I made: https://wiki.ubuntuusers.de/Howto/Knossos/

 
Re: PUBLIC BETA: Knossos 0.14.3 (combined launcher/installer)
It would be wonderful if someone could get Knossos installable again by simply getting it from a PPA, but I gather that is quite a bit of work and requires a decent amount of maintenance to keep it functioning.  Praseodym and Anagram have both provided instructions for successfully building Knossos 0.14.3.  I'm pretty sure I'm using the same version of Mint as Rico (or something really close).  It looks intimidating, but it worked really well for me.  Well enough that I no longer had any reason to load Windows in nearly 2 months.  FSO was the only thing I kept my Windows 10 install for.  :)
"Any idiot can face a crisis; it is this day to day living that wears you out." – Anton Chekhov