Author Topic: Joystick not working  (Read 624 times)

0 Members and 1 Guest are viewing this topic.

Offline SF-Junky

  • 29
  • Bread can mold, what can you do?
Joystick not working
Yo.

I've just tried to play Inferno and found out my joystick is not working. When I was playing the last time a couple of weeks ago, everything worked just fine. I didn't change anything in the meantime, except switching to the latest nightly build. Switching back to an older build does not solve the problem. It's also not a mod issue as it is not working with any mod I use. wxlauncher does detect my joystick and I can also calibrate it. But when I launch a mission, it won't accept any input. Mouse and keyboard work just fine.

Any ideas?

 

Offline ngld

  • Administrator
  • 29
  • Knossos dev
Re: Joystick not working
This is a known SDL problem. Different version generate different GUIDs for the same device. You'll have to either edit the fs2_open.ini manually (you can find the correct GUID in the debug log) or replace the launcher's SDL2.dll with the DLL bundled with the nightly. A fix for Knossos is in the works. No idea if anyone's working on fixing this for wxL.

  

Offline m!m

  • 211
Re: Joystick not working
This has already been fixed for wxLauncher.

@SF-Junky: Could you try installing the wxLauncher test build from the link above? It would be good to know if this actually fixes the issue.