Author Topic: Freespace 2 Ope: Borderless Windowed?  (Read 2730 times)

0 Members and 1 Guest are viewing this topic.

Offline NJW1979

  • 23
Freespace 2 Ope: Borderless Windowed?
I love to play my less demanding games in 3840x2160 DSR on my 1080p ASUS VG278QR monitor.  When I have Freespace 2 Open set at 3840x2160 and have my desktop set at 1920x1080 I only see the top-left quadrant of the screen.  Does this port only run in borderless window?  Is there a command line parameter to force it to exclusive fullscreen.  At the moment I have to set my desktop resolution to 3840x2160, which I don't like to do as my screen is 27 inches, so text is near impossible to read.

 
Re: Freespace 2 Ope: Borderless Windowed?
You could try -fullscreen_window and see if it does anything.

https://wiki.hard-light.net/index.php/Command-Line_Reference#-fullscreen_window

I recall having this exact issue a long time ago but don't remember if I ever got it to work. What I do remember is that DSR can be quite finicky about your scaling settings so I recommend trying different scaling modes both in your GPU control panel and also your monitor.

 

Offline NJW1979

  • 23
Re: Freespace 2 Ope: Borderless Windowed?
I did try that but it did the same thing.  If I want to run Freespace 2 Open in 4K DSR, I have to set my desktop to 4K DSR first.  I think WXLauncher had an exclusive fullscreen option, but as I installed Freespace 2 Open with Knossos the game and Freespace 2 Open are in different folders, unlike the last time the java installer worked, when I was on Windows 7.

 
Re: Freespace 2 Ope: Borderless Windowed?
Another thing you can try is right clicking the FS2 open .exe and under Compatibility turn on Disable full screen optimizations. I don't have the game installed right now so this is just a guess.

Now that I think back, I probably ended up doing the same thing as you which is setting the desktop resolution to 4k before launching the game. It's a little inconvenient but at least it works.

 

Offline ShivanSpS

  • 210
Re: Freespace 2 Ope: Borderless Windowed?
just launch with the -window and the correct resolution

BUT, you will need to put the windows scaling to 100% in order to make it work properly. If you are running 4K as your windows resolution it is likely that you are using 150% scaling.

 

Offline NJW1979

  • 23
Re: Freespace 2 Ope: Borderless Windowed?
At least, in a few weeks, when I get my new monitor (ASUS VG27AQL1A TUF Gaming), I can play in 1440p natively, but I will still put it into DSR as the game runs so damn smoothly on my PC (Ryzen 9 3900x, 8Gb Gigabyte Eagle RTX3070, 32Gb 2400 DDR4 RAM).