Author Topic: Knossos with Reshade  (Read 1806 times)

0 Members and 1 Guest are viewing this topic.

Offline Octon

  • 22
Hello everyone. Thanks again for keeping this gem of a game still active. I just played a few missions and I was wondering if anyone has gotten Knossos to work with Reshade. I installed the mod that revamps the base game with modern graphics but I wanted to go a step further with reshade. I'm a bit of a noob when it comes to this kind of thing though so I was wondering does anyone have videos or instructions to get the Freespace Upgrade MediaVPS Version 4.6.8 to work with Reshade within Knossos?

If there's no video, a simple tutorial on how to get Reshade to work with using Knossos and that Freespace mod would be fantastic. My idea was to put Reshade in the bin  folder. Install Direct x9 and choose a few simple options like VIbrance, DPX, Fake HDR, Technicolor etc and then just hope that KNossos picks up the dll files when it launches the game.

From my investigation of other posts, it seems that I might need to do more hands on stuff like putting dll files somewhere? Anyway, I'm too confused to try to do this without some kind of help. Any help would be appreciated.

Thanks,
O

 
Running the Reshade installer and then pointing it to the fs2_open .exe should be enough. Reshade usually detects the API automatically, but if not make sure you select OpenGL.

 

Offline Octon

  • 22
I pointed it to the FS2_Open_23_0_0_x64_SSE2.exe file located in the Knossos/bin/FSO 23.0.0/windows/x64 folder and selected OpenGL and though it loads up and I can bring up the overlay which means Reshade has worked it doesn't work.

I mean I'm in the Hangar but none of items are selctable. Like nothing is selectable. Then in hangar, if I try to choose a shader from Reshade. THe colors go black and white.

Are you sure it's OpenGL not Vulkan or DirectX9?

 
Hard to say what's happening and I don't have the game installed right now so I can't really test it myself.

If the overlay shows up and you can see the shaders, it sounds like it should be working. Have you tried during a mission (ie. not in hangar or menus)?

I think Reshade locks the mouse cursor when you have the overlay open so that could explain why you can't select anything in the hangar.

 

Offline Octon

  • 22
Got it working. Thanks man. I tried the latest version didn't work. So went the latest version for Reshade 4.0. Worked!!!

 
Nice