Author Topic: Modeling question...  (Read 1089 times)

0 Members and 1 Guest are viewing this topic.

Offline Eiswolf

  • 26
Modeling question...
I have a problem by my Models. The Ship work without a error but when the wing from the ship crash to a Asteroid the Ship becomes no damage only the meters of default cube at Blender where i modeling the Ship crash to the asteroid the ship became damage... also is when a enemy weapon firing at the ship...
Why? 

Have i forgoten a important think? Or it is normal? Must they have more triangles in the wings or must they  a seperatly subsystem / subobject? What are the failure...
I work on this problem two weeks and now i have no ideas what is the problem or the solution...

I use Blender 2.6x, PCS2 latest version and FS2 3.6.14 RC6 and 7

I´m very desperate about this i hope anyone can help me by a solution for this problem...

I will start with my work for the Aerotech Project.
Aerotech Alpha v 0.1 download here ---> http://www.hard-light.net/forums/index.php?topic=87385.0

It plays in Battletech Univers

Aerotech Concept click here ---> http://www.hard-light.net/forums/index.php?topic=81572.0

 

Offline The E

  • He's Ebeneezer Goode
  • Global Moderator
  • 213
  • Nothing personal, just tech support.
    • Steam
    • Twitter
At a guess, I would assume that it's a bounding box issue, which is usually caused by a faulty model setup. If you would be so kind as to post or PM the model in question, we can take a look at it and see what's happening.
Let there be light
Let there be moon
Let there be stars and let there be you
Let there be monsters and let there be pain
Let us begin to feel again
--Devin Townsend, Genesis

 

Offline Droid803

  • Trusted poster of legit stuff
  • 213
  • /人 ◕ ‿‿ ◕ 人\ Do you want to be a Magical Girl?
    • Skype
    • Steam
Check the radius of all your subobjects too, because PCS2 is buggy at the moment.
« Last Edit: August 22, 2012, 12:34:20 pm by Droid803 »
(´・ω・`)
=============================================================

 

Offline Eiswolf

  • 26
here are the files.

It are only testfiles.

A scaled cube with texture and the POF file with the Cube.

The problem is only the original length of cube before scale will give damage and not the scaled...

When anyone need more or other files i can post it (tables and blender files)

[attachment removed and sold on the black market]
« Last Edit: August 22, 2012, 01:25:07 pm by Eiswolf »
Aerotech Alpha v 0.1 download here ---> http://www.hard-light.net/forums/index.php?topic=87385.0

It plays in Battletech Univers

Aerotech Concept click here ---> http://www.hard-light.net/forums/index.php?topic=81572.0

 

Offline Eiswolf

  • 26
okay... i have found the problem and the solution...

I set the Mass in PCS to 20 and then there became damage at the wings.
When i let the Mass from the PCS then will give the Asteroide damage and the ship will explode. Hmm.... it wasn

[attachment removed and sold on the black market]
« Last Edit: August 23, 2012, 11:43:58 am by Eiswolf »
Aerotech Alpha v 0.1 download here ---> http://www.hard-light.net/forums/index.php?topic=87385.0

It plays in Battletech Univers

Aerotech Concept click here ---> http://www.hard-light.net/forums/index.php?topic=81572.0

 
Your model's "Radius override" (PCS2 Header node) is set to 0. I suspect this borks your collision detection. Try setting it to the actual value (or slightly larger), see if that solves the problem.

Not sure what could cause this though.

 

Offline Eiswolf

  • 26
Thx. It works.
Aerotech Alpha v 0.1 download here ---> http://www.hard-light.net/forums/index.php?topic=87385.0

It plays in Battletech Univers

Aerotech Concept click here ---> http://www.hard-light.net/forums/index.php?topic=81572.0