Author Topic: PUBLIC BETA: Knossos 0.8.1 (combined launcher/installer)  (Read 5604 times)

0 Members and 2 Guests are viewing this topic.

Offline Rae2005

  • 22
Re: PUBLIC BETA: Knossos 0.8.1 (combined launcher/installer)
Let's get back to the original problem...

@Rae2005: That error in general means that a 64bit application is trying to load a 32bit DLL (or the other way round). In this case your 64bit FSO is probably trying to load the 32bit OpenAL DLL packaged with Knossos. If you install OpenAL from Creative or put OpenAL Soft's DLL in the FSO directory, your problem should be solved. The latest nightlies and the next FSO release will include the OpenAL DLL as well so this should more or less fix itself in the future. I could add a warning if the OpenAL DLL is missing though...
Thank you that has appeared to fix the problem. funny detail though is sometimes it worked and sometimes it didn't


Offline jr2

  • The Mail Man
  • 212
  • It's prounounced jayartoo 0x6A7232
    • Steam
Re: PUBLIC BETA: Knossos 0.8.1 (combined launcher/installer)
Thank you that has appeared to fix the problem. funny detail though is sometimes it worked and sometimes it didn't

Ah, Windows...

Re: PUBLIC BETA: Knossos 0.8.1 (combined launcher/installer)

Firstly I’d like to commend you guys for this tool. I’ve tried it and despite some of the new aspects of the Knossos (extra folder outside of the main FS2, mods being installed at the new Knossos folder instead of the FS2, layout...) I’ve sticked with it. I understand the intent of what is being done with Knossos. I’ve used mainly the YAL launcher with the mods being installed at the main FS2 folder. I’m running on a Windows 7 SP1, on a i5 with 2.4 GHZ. But (oh man here it comes) today I’ve installed the 0.8.1 update via the Knossos. When I tried to run it I received an error message, saying that it couldn’t find the game executable. So I go and do a full review on the options selected, because with was working fine until the update. On the next instance I’ve received a message saying that I had to reboot the Knossos, which I did and rebooted my pc as well. However the error messages kept on going the same and couldn’t run FS2 or any of the mods already installed. Furthermore, I tried to run FS2 again from the YAL launcher and now the game loaded the original retail version only, none of the mods installed in the main FS2 folder run anymore, not even the MediaSVPs_2014 mod. It must be something I’ve done wrong, or at least I tend to normally think that way immediatly. But I feel at a loss since everything I’ve done doesn’t work (reselecting the build, the exe in the options, etc...). Could you possibly point me out on a solution please? This is the game that I play the most...

PS - Sorry for the loooong description, just trying to provide as much info as possible.


Offline chief1983

  • Still lacks a custom title
  • Moderator
  • 212
  • ⬇️⬆️⬅️⬅️🅰➡️⬇️
    • Minecraft
    • Skype
    • Steam
    • Twitter
    • Fate of the Galaxy
Re: PUBLIC BETA: Knossos 0.8.1 (combined launcher/installer)
Well, I can say that, Knossos _should_ not modify an existing FS2 install whatsoever.  It only asks for its location so it can copy the retail data into its own storage location.  It'd be like if Steam could have copied the pak files for Half-Life 1 instead of having to download them, except since they could verify license keys they didn't need to bother with copying data.  But you still had to install a Steam-ified Half-Life even if you already had the old install laying around with your Counter-Strike and whatever mods, and other less popular mods did all have to go through the pains of being modified to work with Steam installs, etc.  It's really no different here, trying to move to a new paradigm can be a temporary pain but in the long run I think everyone can agree that a unified distribution and launching system is easier to work with these days, even if it does have to replace an existing setup to move forward.

But, if you never modified your own old install, Knossos should not have either, and I don't know why it would no longer work.  The item shared between the two would be your user data folder.  You could look into Users\<yourname>\AppData\Roaming\HardLightProductions\FreeSpace2Open\ folder but I'm not sure what I would recommend to check.  As a test, you could try simply renaming that folder and seeing if your YAL version creates a new one and runs successfully.  Don't delete it as it has your pilots, etc, but if that fixes anything then it can narrow down where the problem might lie.
Fate of the Galaxy - Now Hiring!  Apply within | Diaspora | SCP Home | Collada Importer for PCS2
Karajorma's 'How to report bugs' | Mantis
#freespace | #scp-swc | #diaspora | #SCP | #hard-light on EsperNet

"You may not sell or otherwise commercially exploit the source or things you created based on the source." -- Excerpt from FSO license, for reference

Nuclear1:  Jesus Christ zack you're a little too hamyurger for HLP right now...
iamzack:  i dont have hamynerge i just want ptatoc hips D:
redsniper:  Platonic hips?!
iamzack:  lays


Offline m!m

  • 210
Re: PUBLIC BETA: Knossos 0.8.1 (combined launcher/installer)
Knossos didn't change anything about your existing install but it changed where the engine expects the configuration data (which is also what chief1983 mentioned). YAL is pretty outdated and hasn't been updated to handle the new way FSO stores its configuration (and I am a bit proud that it still worked :p) so if you want to continue using both your Knossos install and the old install you will need to use wxLauncher. That has full support for the new configuration system.

Re: PUBLIC BETA: Knossos 0.8.1 (combined launcher/installer)
Thank you so much for the quick reply guys! I didn’t do anything and the Knossos launcher is now working!  :confused: I think I’m going to stick with the Knossos Launcher anyhow, I’ve tried the wx launcher (also on a separate folder from the main FS2 game folder) and it was easy to configure. Despite this I tried to load with the Media SVP’s 2014 mod and it didn’t loaded the hi-res textures again (pressing F3 at the main menu and checking the ship models, they show the old 1999 textures)... Ran through the configurations (HUD, Graphics, Gameplay, Audio, etc) and set the ones I’ve been using for the last 10 months without change, those that worked fine before installing Knossos. And still no cigar...  :hammer: Funny thing is that I’ve only noticed now that my old pilots are ALL gone!  :banghead: I was playing the SG 2017 mod (from the YAL launcher) and I was in the 20th mission or so, now it is gone! Now only the new pilots created from the Knossos launcher are displayed, even if I go back to launch FS2 with the wxlauncher or yal. Well, at least it was the only mod I was playing now, I had just finished the Exile mod!  :lol: Gonna start all over again...  :nono: I’m gonna give up on the “old” launchers and stick with the Knossos, I’m getting the hang of it now (I think...). Once again, thank you for the fast reply guys!  :D
« Last Edit: February 15, 2018, 03:15:28 pm by Viriatus79 »