Poll

to simplify it here is a poll

yes
0 (0%)
no
3 (60%)
notsure
2 (40%)

Total Members Voted: 5

Voting closed: April 27, 2021, 03:18:48 pm

Author Topic: Do I have to install these every time?  (Read 516 times)

0 Members and 1 Guest are viewing this topic.

Do I have to install these every time?
so my question is about the mv_advanced1-4 is for better textures in the world. do i need to install these for every addon i do or since i installed them for mediavps 4.4.1 already am i good. im asking cuz iv installed it already but it doesnt show installed, it just shows how much space its supposed to take when downloading. i have other ones as well that i installed that dont say installed like the mv_ assets as well so its a little confusing.  any help is appreciated and thanks in advance.


 

Offline 0rph3u5

  • 211
  • This place is empty promises all the way down..
Re: Do I have to install these every time?
The MV_Advanced-series of packages provides even higher resolution textures when applicable (e.g. the texture for the Medusa in MV_Assets_T_Maps3.vp is 1024x1024, its counterpart in MV_Advanced2.vp is 2048x2048); they are fully optional to the function of the MVPs.

Mods themselves may uncheck these as part of their dependencies in Knossos to keep the size of the required downloads down - and that's where Knossos gets its instructions from what to quene up for download as neccessary, or just check if it is installed. The ones with greyed out and with checkmarks are not what you have installed, but what Knossos cannot uncheck because the Mod's dependencies tell it those are essential and have to be downloaded for the mod to function.
"When you work with water, you have to know and respect it. When you labour to subdue it, you have to understand that one day it may rise up and turn all your labours into nothing. For what is water, which seeks to make all things level, which has no taste or colour of its own, but a liquid form of Nothing?" - Graham Swift, Waterland

==================

"I am Curiosity, and I've always wondered what would become of you, here at the end of the world." - The Guide/The Curious Other, Othercide

"As you sought to steal a kingdom for yourself, so must you do again, a thousand times over. For a theft, a true theft, must be practiced to be earned." - The terms of Nyrissa's curse, Pathfinder: Kingmaker

"...because they are not Dragons."

  

Offline ngld

  • Administrator
  • 29
  • Knossos dev
Re: Do I have to install these every time?
Knossos should indicate that the optional packages are already installed but I wouldn't be surprised if a UI bug causes them to appear as shown in the screenshot. Whenever you install a mod package, it's always active for this mod regardless of whether you launch it directly or it's used as a dependency.
A simple way to test this would be to confirm the install prompt as it is and then click the Modify button on the MediaVPs mod. If that dialog still shows the MV_Advanced packages as installed, they're still there and will be used when possible.
For the record: There are a bunch of small bugs in the current Knossos release and I'm currently working on a rewrite from scratch which will fix these and other issues (like the mod list sometimes appearing empty) but it's going to take a while until it's done.