Author Topic: Are you having trouble with a bug?  (Read 13555 times)

0 Members and 1 Guest are viewing this topic.

Offline redmenace

  • 211
Are you having trouble with a bug?
:welcome:
Government is the great fiction through which everybody endeavors to live at the expense of everybody else.
              -Frederic Bastiat

 

Offline redmenace

  • 211
Are you having trouble with a bug?
Kazan suggests reinstalling everything.
Government is the great fiction through which everybody endeavors to live at the expense of everybody else.
              -Frederic Bastiat

 

Offline taylor

  • Super SCP/Linux Guru
  • Moderator
  • 212
    • http://www.icculus.org/~taylor
Re: Gamecrash at Serverstart
Quote
Originally posted by Rosiel
Well...I am new to this community and I tried to play FS2 on the net with FS open but everytime I try to make a server it always crashes. So i tried it in debug-mode and got this:

Not wanting to go through all of the posts to figure out what build you've got, try using a newer one.  The problem you report should be fixed in the 3.6.5 beta and if it's not let me know since I may have missed something.  It should have been fixed in 3.6 but I think part of my fix got missed and with a certain state it will still crash.  Haven't figured out exactly what that certain state is though.

 

Offline Rosiel

  • 21
Are you having trouble with a bug?
I use the version 3.6 but I will try the beta then. Wish me luck :D

 

Offline Karza

  • 23
Are you having trouble with a bug?
I just encountered this baby.

Error: Can't open file
File:U:\src\cvs\fs2_open.testing\code\Model\ModelRead.cpp
Line: 1543

Call stack:
------------------------------------------------------------------
------------------------------------------------------------------

This appears when loading the 1st act command briefing that appears after the herc II training missions (the one where Petrarch tells that the Shivans are coming again).

My system:

Athlon XP 2600+ (tbred 2)
1GB 333 DDR
Club3D Radeon 9800 pro 128 (catalyst 4.12)
MSI MS-6712 motherboard
Windows XP Home (Finnish)

I'm running with this commandline: D:\FS2\fs2_open_T-20050103.exe -spec -glow -pcx32 -jpgtga. I'm using OpenGL video.

I have installed all 3.6.5 media vp files.

 

Offline karajorma

  • King Louie - Jungle VIP
  • Administrator
  • 214
    • Karajorma's Freespace FAQ
Are you having trouble with a bug?
Looks like you've got an error in your table file. Which media vp files have you downloaded? Do you have any mods installed?
Karajorma's Freespace FAQ. It's almost like asking me yourself.

[ Diaspora ] - [ Seeds Of Rebellion ] - [ Mind Games ]

 

Offline Karza

  • 23
Are you having trouble with a bug?
The newest media vps from indiegames, except mv loplanets.

No mods installed.

 

Offline Trivial Psychic

  • 212
  • Snoop Junkie
Are you having trouble with a bug?
Quote
Originally posted by Karza
I just encountered this baby.

Error: Can't open file
File:U:\src\cvs\fs2_open.testing\code\Model\ModelRead.cpp
Line: 1543


http://www.hard-light.net/forums/index.php/topic,29507.0.html
The Trivial Psychic Strikes Again!

 

Offline Karza

  • 23
Are you having trouble with a bug?
I see. So how do I fix it? That thread did clarify the reason for this, but didn't mention any fix.

 
Are you having trouble with a bug?
You put the file cruiser03x.pof into your data\models folder. Assuming its not already in there. You can find the model in one of Lightspeeds Shinemap packs.
Carpe Diem Poste Crastinus

"When life gives you lemons...
Blind people with them..."

"Yah, dude, penises rock." Turambar

FUKOOOOV!

 

Offline Karza

  • 23
Are you having trouble with a bug?
Which one and where can I get it? The pack in the shinemaps' development thread doesn't have the file.

EDIT: Well, the readme says it was included in build 5.0, but I can't find the file in build 18.0 (the current, and only one I have found).

EDIT2: Well, I did find it after all.

EDIT3: That got me past the aforementioned bug, but now the game crashes just about every time its trying to load a mission. A lion at the door took some 10 tries before it ran, and the one after that shares the problem (And I ran out of patience trying to load it :mad: ). Bah.
« Last Edit: January 13, 2005, 07:09:03 am by 2158 »

 

Offline karajorma

  • King Louie - Jungle VIP
  • Administrator
  • 214
    • Karajorma's Freespace FAQ
Are you having trouble with a bug?
Are you using the mv_music.vp? Some people have reported problems with it (as I'm just about to :D )
Karajorma's Freespace FAQ. It's almost like asking me yourself.

[ Diaspora ] - [ Seeds Of Rebellion ] - [ Mind Games ]

 

Offline Karza

  • 23
Are you having trouble with a bug?
I was, tried without, but no change. This bug (or some remarkably similar one) already seems to have been reported to mantis, so I guess I can only wait for it to be fixed...

 

Offline PrISM

  • 22
Are you having trouble with a bug?
Well I guess I'm not going to be able to try out the SCP tonight. It runs the training missions fine but then crashes once I try to start the campaign. Same thing happens if I try to run FS2 on it's own. Going to have to try to reinstall again tomorrow. :(

 

Offline karajorma

  • King Louie - Jungle VIP
  • Administrator
  • 214
    • Karajorma's Freespace FAQ
Are you having trouble with a bug?
Any error message pop up after the crash?
Karajorma's Freespace FAQ. It's almost like asking me yourself.

[ Diaspora ] - [ Seeds Of Rebellion ] - [ Mind Games ]

 

Offline PrISM

  • 22
Are you having trouble with a bug?
Ok, if I use the FS2 launcher I get this error:

Error: Error parsing 'weapons.tbl'
Error code = 2.

File:C:\projects\freespace2\code\Weapon\Weapons.cpp
Line: 1432

Call stack:
------------------------------------------------------------------
------------------------------------------------------------------

I can go into the 'debugger' and countinue on but the same type of errors keep popping up. I hit about 7 before getting to the first mission.

If I try running it from the SCP launcher I get to the ready room, but once I enter the campaign I get the 'FreeSpace has encountered a problem and needs to close.  We are sorry for the inconvenience.' error and that's it.

I'm running the patched version of FS2. System specs are:

CPU: AMD Athlon™ 64 Processor 3500+, 2210MHz
RAM: 1024MB
GFX: NVIDIA GeForce 6800 GT (latest drivers)
OS: Windows XP Professional, Service Pack 2

I'm going to do a clean reinstall of just FS2 and see how it runs without the SCP. It could just be that FS2 just doesn't like my machine.
« Last Edit: January 16, 2005, 01:19:25 pm by 2458 »

 

Offline karajorma

  • King Louie - Jungle VIP
  • Administrator
  • 214
    • Karajorma's Freespace FAQ
Are you having trouble with a bug?
You definately can't run the retail version while the SCP media.vp files are installed. So the first part is no surprise.

The second part is a little more mystifying though. Unless it's the music.vp I've been having all kinds of problems with it. I need to take it apart and see if I can narrow down the bug.
Karajorma's Freespace FAQ. It's almost like asking me yourself.

[ Diaspora ] - [ Seeds Of Rebellion ] - [ Mind Games ]

 

Offline PrISM

  • 22
Are you having trouble with a bug?
So should I just try some of the other .vps minus the music?

 

Offline phreak

  • Gun Phreak
  • 211
  • -1
Are you having trouble with a bug?
it seems like the music vp is the only one causing troubles.  just simply removing it from your fs2 directory should fix it until we figure out whats going on.  If you don't have mv_music.vp then its some other problem.

There have been problems on mission load that we haven't been able to nail down just yet, so that may be another problem.
Offically approved by Ebola Virus Man :wtf:
phreakscp - gtalk

 

Offline PrISM

  • 22
Are you having trouble with a bug?
Is there anyway to remove the music.vp if I've used the zpack.vp or should I just reinstall them as seperate .vps?