Author Topic: EA ships in mission 3 do not render...  (Read 2289 times)

0 Members and 1 Guest are viewing this topic.

Offline Starks

  • 29
EA ships in mission 3 do not render...
They have funky textures.
Formerly of the Dark Wings and Legion of Apocalypse

 

Offline Woomeister

  • Infyrno Missile
  • Moderator
  • 213
    • Inferno SCP
Re: EA ships in mission 3 do not render...
Sounds like a memory problem. Use a different CVS build for now if that's what your using.

 

Offline Starks

  • 29
Re: EA ships in mission 3 do not render...
I'm using 1/10/06
Formerly of the Dark Wings and Legion of Apocalypse

 

Offline Woomeister

  • Infyrno Missile
  • Moderator
  • 213
    • Inferno SCP
Re: EA ships in mission 3 do not render...
We're stuck with Sept 2005 builds so I can't help you there.

 
Re: EA ships in mission 3 do not render...
I've noticed something similar with the 16/01/05 CVS build tested using our most recent content revisions. Mantised - LLivingLarge, please document your symptoms on Mantis bug 724 if your symptoms are similar from the ones I've documented there.

Or is this something completely different?

 
Re: EA ships in mission 3 do not render...
I have seen a problem like that, but it happens with Models Collisions, my situation (a rare one):

I set the Moon (3,600,000m Diameter) to collide the Earth (12,400,000m), however in exchange of colliding both dissapear, the model can be targetted but it's not there.......

I think that was a problem that I caused because of the Hi-Amounts of Coordinates, but it seems to not be then.......

If I order the Moon to collide my Ship (Kamikaze), the Moon 1st goes through me (rare not), but when it does a full loop, that time, yes it Collides me, and of course kills me.......

--------------------------------

It isn't related to a Mass Limit problem, both the Earth and Moon I made have Mass set to 2000..........(my models aren't set to "no_collide" and "navbouy", so are really like any other ship)

 

Offline Woomeister

  • Infyrno Missile
  • Moderator
  • 213
    • Inferno SCP
Re: EA ships in mission 3 do not render...
That might be due to non Inferno builds not liking very large models as much.

 
Re: EA ships in mission 3 do not render...
Do Inferno Build has a Higher Limit for Model size?

The Coordinate limit is the same for Alpha 1 (Player Ship), it's at +700,000 from Initial Point, anyone else can go to the end of the universe.......that's really bad from Volition...........(give us back our freedom.....)

 

Offline Woomeister

  • Infyrno Missile
  • Moderator
  • 213
    • Inferno SCP
Re: EA ships in mission 3 do not render...
They're supposed to, originally FS Open builds wouldn't render anything more than 40km or so away, so anything bigger than a Juggernaught would start to vanish from a distance. I'm not sure what the ranges are now though. It's a Z Buffer limit that makes the models start to disappear after a certain distance.

 

Offline Trivial Psychic

  • 212
  • Snoop Junkie
Re: EA ships in mission 3 do not render...
In standard (non-Inferno) builds, you can still see Knossos 3 in "Into the Lion's Den" and that was 101 KM away.
The Trivial Psychic Strikes Again!

 

Offline Woomeister

  • Infyrno Missile
  • Moderator
  • 213
    • Inferno SCP
Re: EA ships in mission 3 do not render...
You couldn't in the past. Looks like the limit was changed then.

 
Re: EA ships in mission 3 do not render...
So, everyone you were with the old concept, all of you almost make me wonder, "um.....another thing that I break".

Before this question:

Quote
Do Inferno Build has a Higher Limit for Model size?

The Coordinate limit is the same for Alpha 1 (Player Ship), it's at +700,000 from Initial Point, anyone else can go to the end of the universe.......that's really bad from Volition...........(give us back our freedom.....)

I set the Earth with a Diameter of 12,400,000 m, and the Moon with a Diameter of 3,600,000, I place the Earth at Z +20,000,000, and the Moon as it should be at 400,000,000 m away from the Earth, that means 412,000,000 m.

I remember I take I screenshoot, the Moon can be seen, it's like a Big Star, but it's really far away, and everything was working OK..................

(Make a 3D Earth is really hard.......I understimate it........I would prefer the try of make a Ship Model........)