Author Topic: Need Help! Inferno+SCP launch crash!  (Read 2771 times)

0 Members and 1 Guest are viewing this topic.

Offline warham

  • 22
Need Help! Inferno+SCP launch crash!
Hi,

greetings to all member and sry for my bad english, I am from Austria.

I stumbled across Inferno today, downloaded it but it won´t work!

Here are the things I did:

1. installed Freespace 2 Retail
2. installed SCP current build (3.6.7 or something) (to main game folder)
3. installed Inferno RC1 (to INFR1 folder)
4. installed Inferno SCP Patch (INFR1 folder)

now Freespace SCP worked fine, had no problems at all

after I installed Inferno, I started the launcher, specified the mod folder and started the game. I got to see the launch screen for about a second, then it instantly crashed to the desktop with the following error message:

Error: species_defs.tbl(27):
Error: Required token = [$AwacsMultiplier:], found [$Species_Name:

Vasudan] .

File:C:\Languages\Visual Studio Projects\Visual

C++\fs2_open\code\Parse\PARSELO.CPP
Line: 535
[This filename points to the location of a file on the computer that

built this executable]

Call stack:
------------------------------------------------------------------
------------------------------------------------------------------

well I thought I should search for species_def.tbl or parselo.cpp on my computer to see if I can do something, but these files are not present on my computer anywhere! There is also no C:\languages\.. oder fs2_open folder as well!!

So WTF is going on here?

What do I have to do to get it working? Please help me with this problem!
thx
warham

 

Offline Woomeister

  • Infyrno Missile
  • Moderator
  • 213
    • Inferno SCP
Re: Need Help! Inferno+SCP launch crash!
The patch species_defs is out of date. They changed the species_defs code while back and for a few builds it broke INF. Newer builds should use default built in values when no values are given in the tables.

Try one of the recent CVS builds and that should work.
http://www.hard-light.net/forums/index.php/board,97.0.html

If not Shadow0000 update should fix it:
http://www.hard-light.net/forums/index.php/topic,37185.0.html

 

Offline warham

  • 22
Re: Need Help! Inferno+SCP launch crash!
I downloaded the latest CVS Inferno build. it works now, THANX! :)

only one problem left, when I played SCP only with the old fs2_open.exe (with OpenGL, got a Radeon 9800 Pro), the shinemaps or glowmaps or whatever were working fine.

but now with the new CVS, the shiny look is gone with opengl and also with d3d! (the features are of course selected in the features tab)

is there a solution to that as well?

thx

 

Offline Woomeister

  • Infyrno Missile
  • Moderator
  • 213
    • Inferno SCP
Re: Need Help! Inferno+SCP launch crash!
Here's some things to try:

Make sure your using the most up to date launcher. Version 5.3 works for me. Make sure it is adding -spec and -glow in the top box in the features tab when your selecting them. If not add them under the custom list and see if that works.

You may need the actual shinemaps now as I believe newer builds won't show any shine effect without them. I don't think I included any by default when the patch was made. You can get shinemaps for the default textures from the SCP media VPS.

You may need newer drivers for the shinemaps to reappear in recent builds using OGL. If your using older driver like the CAT4 drivers they may be too old for it now.

 

Offline warham

  • 22
Re: Need Help! Inferno+SCP launch crash!
I am using launcher 5.3, spec and glow are there. I am also using the latest Media VPs, including advanced effects and the latest Catalyst drivers (a few weeks old).

The shinemaps still work on the original Freespace 2 models (under opengl only), but not with the Inferno models. So I guess I need the specific shinemaps for the Inferno ship models?

if those are not included in the RC1 or the SCP Patch, where can I find them?

with all those different files flying around and me beeing new to SCP, it is a little hard getting the right stuff :confused:


 

Offline Woomeister

  • Infyrno Missile
  • Moderator
  • 213
    • Inferno SCP
Re: Need Help! Inferno+SCP launch crash!
Most of the Inferno capship models use standard FS2 maps. If your running mission 1 and the Phobos has no glow or shinemaps you may have your mod directory set up wrong. Do you have the media VPs in a seperate mod directory? if you do you need to use multi-mod support to get them to work with the INF mod directory.
I don't know if there's any public shinemaps for the custom textures used in R1...

R1 was originally designed for retail only, and since there wasn't much support for it R1 after the patch it wasn't kept up to date to work with the latest SCP at its full potential.

 

Offline warham

  • 22
Re: Need Help! Inferno+SCP launch crash!
The Media VPs are in the main directory, glow and shinemaps are definitely not working.

But thanx for the tips anyway, at least I can play Inferno at all. :)

cheers

EDIT: it´s working now, ships are all shiney now!  :D

downloaded extra shinemaps from here http://scp.indiegames.us/download.php?view.13 and put them in the main maps folder as well as the inferno mod directory (to be sure :D)
« Last Edit: May 01, 2006, 09:12:55 am by warham »

 

Offline neoterran

  • 210
Re: Need Help! Inferno+SCP launch crash!
warham, you shouldn't put anything in the main data folders. All those shinemaps and other things you see linked to from lightspeed are already in the mediavps.

what you should be doing is putting all the mod files / mod vps in a mod folder with no spaces in the freespace directory.

then you should create (or copy) a mod.ini file that contains a link to the mediavps folder you have in the "secondry list" option. that way when you load the mod, it will also load the mediavps.

when you start putting stuff in the main data folder, you'll run in trouble if you have many different mods, because some won't work with each other.
« Last Edit: May 01, 2006, 10:07:35 am by neoterran »
Official Taylor Fan Club Member.
Chief Grognard.
"How much code could a coder code if a coder could code code?"