Author Topic: error after selecting my pilot  (Read 3038 times)

0 Members and 1 Guest are viewing this topic.

Offline Rufus

  • 21
error after selecting my pilot
Im using v15c scp and the newest version of the port (v3.0.3), and after i select the mod the game loads, plays the video properly, but when i select my pilot i get this error:

Error: Invalid ship type "GTF Myrmidon" found in $Ship Choices: of campaign file
File:D:\C++\Freespace\fs2_open\code\Parse\PARSELO.CPP
Line: 2490
[This filename points to the location of a file on the computer that built this executable]

Call stack:
------------------------------------------------------------------
------------------------------------------------------------------

How can i fix this? I downloaded the scp pack that had fs1 mod with it, and i downloaded the newest version from here just incase, i also tried making a new pilot for fs1 but that didnt work either.

Im not sure if this post belongs here or in the scp forum but all my other mods work properly so i put it here, i searched the forums a bit but couldnt find anything usefull.

 

Offline Goober5000

  • HLP Loremaster
  • Moderator
  • 214
    • Goober5000 Productions
Re: error after selecting my pilot
Is this your only installed mod?  Are you using the -mod command line?

If the answer to either question is yes, then try creating a new pilot when you first start the game.

 

Offline Rufus

  • 21
Re: error after selecting my pilot
Creating a new pilot didn't help, im using the scp launcher to select the mod, and i have a few other mods that came included with the download, derelict, transend, and the mediavps for the fs2 campaign.

 

Offline Goober5000

  • HLP Loremaster
  • Moderator
  • 214
    • Goober5000 Productions
Re: error after selecting my pilot
It sounds like you have multiple incompatible mods installed.  Read karajorma's FAQ.
http://homepage.ntlworld.com/karajorma/FAQ/intro.html

 
Re: error after selecting my pilot
I have the same problem... I'm using the ShivanSpSs FS2 SCP Pack v1.5c, which I installed into a new directory (so no old mods, etc). I guess the pack in question simply has too much stuff included...? Mind you, the Derelict and Transcend work (apparently) fine.

Also, (at least) the intro movie is black, though the sound plays fine... however... when I play it in windows media player, it works just fine, so I clearly have the necessary codecs'.
« Last Edit: May 04, 2006, 09:01:41 am by Uglybrush »

 

Offline Flaser

  • 210
  • man/fish warsie
Re: error after selecting my pilot
Do you have the latest DivX codec installed?
If yes, you may want to either downgrade or uninstall it altogheter and use the fddshow filter for playback.
(The esiest thing to do is to uninstall all DivX, ogg/ogm, mkv codecs/packs and install the Matroska pack.)
"I was going to become a speed dealer. If one stupid fairytale turns out to be total nonsense, what does the young man do? If you answered, “Wake up and face reality,” you don’t remember what it was like being a young man. You just go to the next entry in the catalogue of lies you can use to destroy your life." - John Dolan

 

Offline ShivanSpS

  • 210
Re: error after selecting my pilot
Do you have selected the FS1 campaing??! The only way that SCP are calling the Myrmidon is because you have selected the FS2 campaing which port mod....
« Last Edit: May 04, 2006, 06:08:52 pm by ShivanSpS »

 
Re: error after selecting my pilot
I use the launcher to set mod to FS1, and then launch the game. Though newly created pilots would have FS2 campaign selected by default, right? I'm not sure if there's anything I can do to change that...

 

Offline Rufus

  • 21
Re: error after selecting my pilot
Edit: found a fix, altho its "ghetto". When it hits that error, alt tab once to get back to fs2, alt tab again to get the error window itself selected and just click ok over and over, eventually you will get into the main room, then just select the freespace main campaign and restart.
« Last Edit: May 05, 2006, 09:04:19 am by Rufus »

 
Re: error after selecting my pilot
Yay, it worked! Thanks a bunch.

 

Offline karajorma

  • King Louie - Jungle VIP
  • Administrator
  • 214
    • Karajorma's Freespace FAQ
Re: error after selecting my pilot
The best solution is to replace the 25th April CVS build with the 29th April one. That will solve this particular problem.
Karajorma's Freespace FAQ. It's almost like asking me yourself.

[ Diaspora ] - [ Seeds Of Rebellion ] - [ Mind Games ]

 

Offline ShivanSpS

  • 210
Re: error after selecting my pilot
the 1.6 patch also fix this, well the only that they do is remove the kara 4/25 CVS and put the kara 4/29 ones.

http://www.oxyshare.com/d/mtvfn9Iswb2/1_5c%20to%201_6%20patch.exe.html