Author Topic: (nearly) no sound with FSO 3.6.9 RC3 and FSPort 3.03 -solved  (Read 1939 times)

0 Members and 1 Guest are viewing this topic.

(nearly) no sound with FSO 3.6.9 RC3 and FSPort 3.03 -solved
Hello,

i just did update from FSO 3.6.7 / Launcher 5.3 to FSO 3.6.9 RC3 /Launcher 5.3.
With 3.6.7 I had all available sounds, speech and music during gameplay. I changed to FSO 3.6.9 RC3 due to the bug that caused mission SM2-06A.FS2 to crash (see http://www.hard-light.net/forums/index.php/topic,40698.0.html). With FSO 3.6.9 RC3 I do not have any sounds nor music on the main Freespace screen. During mission briefing and weapon/ship selection even speech is missing. During flight the only sound I have got are the soundeffects from canon fires of larger ships (freighters, warships). Nothing else. No speech, no ship sounds, no explosions...
I use "direct sound" as sound option.
This is my launcher.ini

#
# DO NOT EDIT THIS FILE
#
[launcher]
exe_filepath = E:\Games\fs2\fs2_open_r.exe;
game_flags =  -spec -glow -env -jpgtga -mipmap -nomotiondebris -2d_poof -missile_lighting -dualscanlines -targetinfo -orbradar -ballistic_gauge -snd_preload ;
active_mod = fs1port;

Besides, FSO 3.6.9RC5 or Launcher 5.4 causes an Acces Violation on my system immedialty after starting.
« Last Edit: July 18, 2006, 05:17:07 pm by nighthawk »

 

Offline taylor

  • Super SCP/Linux Guru
  • 212
    • http://www.icculus.org/~taylor
Re: (nearly) no sound with FSO 3.6.9 RC3 and FSPort 3.03
Do you have OpenAL 1.1 installed?

 
Re: (nearly) no sound with FSO 3.6.9 RC3 and FSPort 3.03
Thank You!
That did it.

If someone is looking for the file, here it goes:
http://www.openal.org/downloads.html


 

Offline taylor

  • Super SCP/Linux Guru
  • 212
    • http://www.icculus.org/~taylor
Re: (nearly) no sound with FSO 3.6.9 RC3 and FSPort 3.03 -solved
You're welcome.  Though, the Launcher is actually supposed to notify you if you need to install OpenAL 1.1, not have an access violation.  I'll have to take a look at that.  :)

 
Re: (nearly) no sound with FSO 3.6.9 RC3 and FSPort 3.03 -solved
With FSO 3.6.9RC5 or Launcher 5.4 and OpenAL installed no more access violations do happen when starting.

bye